summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-09-10 07:54:30 +0000
committerChristoph Mende <angelos@gentoo.org>2010-09-10 07:54:30 +0000
commit03bd5e5f78bbbd8229a8e39f2e803ab54bac2bae (patch)
tree916d62ae3914b397983ce87660b0c6cc0c929880 /media-sound/ario
parentVersion bump. Don't use full path in ip location to avoid bugs like #334277 f... (diff)
downloadgentoo-2-03bd5e5f78bbbd8229a8e39f2e803ab54bac2bae.tar.gz
gentoo-2-03bd5e5f78bbbd8229a8e39f2e803ab54bac2bae.tar.bz2
gentoo-2-03bd5e5f78bbbd8229a8e39f2e803ab54bac2bae.zip
Version bump (bug #333407)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/ario')
-rw-r--r--media-sound/ario/ChangeLog7
-rw-r--r--media-sound/ario/ario-1.5.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/media-sound/ario/ChangeLog b/media-sound/ario/ChangeLog
index 24174f0e3bb3..80a1c76d5cd3 100644
--- a/media-sound/ario/ChangeLog
+++ b/media-sound/ario/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/ario
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ChangeLog,v 1.16 2010/06/16 14:15:37 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ChangeLog,v 1.17 2010/09/10 07:54:30 angelos Exp $
+
+*ario-1.5 (06 Sep 2010)
+
+ 06 Sep 2010; <angelos@gentoo.org> +ario-1.5.ebuild:
+ Version bump (bug #333407)
16 Jun 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> ario-1.4.4.ebuild:
x86 stable wrt bug #322911
diff --git a/media-sound/ario/ario-1.5.ebuild b/media-sound/ario/ario-1.5.ebuild
new file mode 100644
index 000000000000..ec75ce763fa8
--- /dev/null
+++ b/media-sound/ario/ario-1.5.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ario-1.5.ebuild,v 1.1 2010/09/10 07:54:30 angelos Exp $
+
+EAPI=1
+inherit gnome2-utils
+
+DESCRIPTION="a GTK2 MPD (Music Player Daemon) client inspired by Rythmbox"
+HOMEPAGE="http://ario-player.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}-player/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="audioscrobbler dbus debug +idle libnotify nls python taglib zeroconf"
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ dev-libs/libunique
+ dev-libs/libxml2
+ media-libs/libmpdclient
+ net-misc/curl
+ net-libs/gnutls
+ >=x11-libs/gtk+-2.16:2
+ audioscrobbler? ( net-libs/libsoup:2.4 )
+ dbus? ( dev-libs/dbus-glib )
+ libnotify? ( x11-libs/libnotify )
+ python? ( dev-python/pygtk
+ dev-python/pygobject )
+ taglib? ( media-libs/taglib )
+ zeroconf? ( net-dns/avahi )"
+DEPEND="sys-devel/gettext
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ --enable-libmpdclient2 \
+ --enable-search \
+ --enable-playlists \
+ --disable-xmms2 \
+ --disable-deprecations \
+ $(use_enable audioscrobbler) \
+ $(use_enable dbus) \
+ $(use_enable debug) \
+ $(use_enable idle mpdidle) \
+ $(use_enable libnotify notify) \
+ $(use_enable nls) \
+ $(use_enable python) \
+ $(use_enable taglib) \
+ $(use_enable zeroconf avahi)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}