summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-04-16 22:21:09 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-04-16 22:21:09 +0000
commitaff607a56df30d1211b6c95b3f50413560e7c926 (patch)
treea946a2f3a10baf1f1c7eb6f0dfa1ff9fe5e5f829 /media-sound/alsa-utils
parentamd64 stable, bug 308521 (diff)
downloadgentoo-2-aff607a56df30d1211b6c95b3f50413560e7c926.tar.gz
gentoo-2-aff607a56df30d1211b6c95b3f50413560e7c926.tar.bz2
gentoo-2-aff607a56df30d1211b6c95b3f50413560e7c926.zip
Version bump. Input validation has been added to alsamixer. alsactl now features improved debugging features.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog9
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.23.ebuild97
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.23-modprobe.d.patch12
3 files changed, 117 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 28e3f18990e7..41b40b73fcc2 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.294 2010/02/13 16:24:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.295 2010/04/16 22:21:09 chainsaw Exp $
+
+*alsa-utils-1.0.23 (16 Apr 2010)
+
+ 16 Apr 2010; <chainsaw@gentoo.org> +alsa-utils-1.0.23.ebuild,
+ +files/alsa-utils-1.0.23-modprobe.d.patch:
+ Version bump. Input validation has been added to alsamixer. alsactl now
+ features improved debugging features.
13 Feb 2010; Raúl Porcel <armin76@gentoo.org>
alsa-utils-1.0.21-r1.ebuild:
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.23.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.23.ebuild
new file mode 100644
index 000000000000..0e0f328800d6
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.23.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.23.ebuild,v 1.1 2010/04/16 22:21:09 chainsaw Exp $
+
+EAPI=2
+inherit eutils
+
+MY_P=${P/_rc/rc}
+ALSA_DRIVER_VER="1.0.23"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2
+ mirror://alsaproject/driver/alsa-driver-${ALSA_DRIVER_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc nls minimal"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ doc? ( app-text/xmlto )"
+RDEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ virtual/modutils
+ !minimal? ( sys-apps/pciutils )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if [[ -e "${ROOT}etc/modules.d/alsa" ]]; then
+ eerror "Obsolete config /etc/modules.d/alsa found."
+ die "Move /etc/modules.d/alsa to /etc/modprobe.d/alsa.conf."
+ fi
+
+ if [[ -e "${ROOT}etc/modprobe.d/alsa" ]]; then
+ eerror "Obsolete config /etc/modprobe.d/alsa found."
+ die "Move /etc/modprobe.d/alsa to /etc/modprobe.d/alsa.conf."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-modprobe.d.patch
+}
+
+src_configure() {
+ local myconf=""
+ use doc || myconf="--disable-xmlto"
+
+ econf ${myconf} \
+ $(use_enable nls)
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ${ALSA_UTILS_DOCS} || die
+
+ newbin "${WORKDIR}/alsa-driver-${ALSA_DRIVER_VER}/utils/alsa-info.sh" \
+ alsa-info
+
+ newinitd "${FILESDIR}/alsasound.initd-r4" alsasound
+ newconfd "${FILESDIR}/alsasound.confd-r3" alsasound
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa.conf
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+ elog "The script will load ALSA modules, if you choose to use a modular"
+ elog "configuration. The Gentoo ALSA developers recommend you to build"
+ elog "your audio drivers into the kernel unless the device is hotpluggable"
+ elog "or you need to supply specific options (such as model= to HD Audio)."
+ echo
+ ewarn "Automated unloading of ALSA modules is deprecated and unsupported."
+ ewarn "Should you choose to use it, bug reports will not be accepted."
+ echo
+ if use minimal; then
+ ewarn "The minimal use flag disables the dependency on pciutils that"
+ ewarn "is needed by alsaconf at runtime."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.23-modprobe.d.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.23-modprobe.d.patch
new file mode 100644
index 000000000000..efe75923c1bd
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.23-modprobe.d.patch
@@ -0,0 +1,12 @@
+diff -uNr alsa-utils-1.0.23.ORIG//alsaconf/alsaconf.in alsa-utils-1.0.23/alsaconf/alsaconf.in
+--- alsa-utils-1.0.23.ORIG//alsaconf/alsaconf.in 2010-04-16 23:16:24.972269218 +0100
++++ alsa-utils-1.0.23/alsaconf/alsaconf.in 2010-04-16 23:16:47.781310369 +0100
+@@ -301,7 +301,7 @@
+ fi
+ else
+ if [ "$distribution" = "gentoo" ]; then
+- cfgfile="/etc/modules.d/alsa"
++ cfgfile="/etc/modprobe.d/alsa.conf"
+ elif [ "$kernel" = "new" ]; then
+ cfgfile="/etc/modprobe.conf"
+ if [ -d /etc/modprobe.d ]; then