summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-14 21:45:22 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-07-14 21:45:22 +0000
commit229244cd8637a14b4138d4f1a1150abb082e0f3e (patch)
treeb33152c354af379f0bdc2605463afc43f595d0f4 /media-sound/alsa-tools
parentVersion bump, this version does not build with hidden visibility. (diff)
downloadgentoo-2-229244cd8637a14b4138d4f1a1150abb082e0f3e.tar.gz
gentoo-2-229244cd8637a14b4138d4f1a1150abb082e0f3e.tar.bz2
gentoo-2-229244cd8637a14b4138d4f1a1150abb082e0f3e.zip
Fix DEPEND/RDEPEND, thanks to Yoshi Watanabe in bug #140308.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'media-sound/alsa-tools')
-rw-r--r--media-sound/alsa-tools/ChangeLog7
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.0.10.ebuild11
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.0.11.ebuild11
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.0.12_rc1.ebuild11
4 files changed, 24 insertions, 16 deletions
diff --git a/media-sound/alsa-tools/ChangeLog b/media-sound/alsa-tools/ChangeLog
index 9248eb3fe613..bd6e090c3af9 100644
--- a/media-sound/alsa-tools/ChangeLog
+++ b/media-sound/alsa-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/alsa-tools
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.107 2006/06/23 12:45:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.108 2006/07/14 21:45:22 flameeyes Exp $
+
+ 14 Jul 2006; Diego Pettenò <flameeyes@gentoo.org>
+ alsa-tools-1.0.10.ebuild, alsa-tools-1.0.11.ebuild,
+ alsa-tools-1.0.12_rc1.ebuild:
+ Fix DEPEND/RDEPEND, thanks to Yoshi Watanabe in bug #140308.
*alsa-tools-1.0.12_rc1 (23 Jun 2006)
diff --git a/media-sound/alsa-tools/alsa-tools-1.0.10.ebuild b/media-sound/alsa-tools/alsa-tools-1.0.10.ebuild
index baa515c84697..d2a7a949123f 100644
--- a/media-sound/alsa-tools/alsa-tools-1.0.10.ebuild
+++ b/media-sound/alsa-tools/alsa-tools-1.0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.10.ebuild,v 1.7 2006/06/16 21:17:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.10.ebuild,v 1.8 2006/07/14 21:45:22 flameeyes Exp $
inherit eutils flag-o-matic
@@ -15,24 +15,25 @@ SLOT="0.9"
KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
IUSE="fltk gtk"
-DEPEND=">=media-libs/alsa-lib-1.0.0
+RDEPEND=">=media-libs/alsa-lib-1.0.0
virtual/alsa
fltk? ( =x11-libs/fltk-1.1* )
gtk? ( =x11-libs/gtk+-1.2* )"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
# This is a list of the tools in the package.
# Some of the tools don't make proper use of CFLAGS, even though
- # all of them seem to use autoconf. This needs to be fixed.
+ # all of them seem to use autoconf. This needs to be fixed.
#
# By default, all the supported tools will be compiled.
# If you want to only compile for specific tool(s), set ALSA_TOOLS
# environment to a space-separated list of tools that you want to build.
# For example:
#
- # env ALSA_TOOLS='as10k1 ac3dec' emerge alsa-tools
+ # env ALSA_TOOLS='as10k1 ac3dec' emerge alsa-tools
#
if [ -z "${ALSA_TOOLS}" ]; then
ALSA_TOOLS="ac3dec as10k1 hdsploader mixartloader seq/sbiload \
@@ -47,7 +48,7 @@ pkg_setup() {
fi
# sb16_csp won't build on ppc64 _AND_ ppc (and is not needed)
- if use !ppc64 && use !ppc; then
+ if use !ppc64 && use !ppc; then
ALSA_TOOLS="${ALSA_TOOLS} sb16_csp"
fi
diff --git a/media-sound/alsa-tools/alsa-tools-1.0.11.ebuild b/media-sound/alsa-tools/alsa-tools-1.0.11.ebuild
index 85d744c538ad..ae7f91eccb2f 100644
--- a/media-sound/alsa-tools/alsa-tools-1.0.11.ebuild
+++ b/media-sound/alsa-tools/alsa-tools-1.0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.11.ebuild,v 1.8 2006/06/16 21:17:22 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.11.ebuild,v 1.9 2006/07/14 21:45:22 flameeyes Exp $
inherit eutils flag-o-matic autotools
@@ -15,24 +15,25 @@ SLOT="0.9"
KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
IUSE="fltk gtk"
-DEPEND=">=media-libs/alsa-lib-1.0.0
+RDEPEND=">=media-libs/alsa-lib-1.0.0
virtual/alsa
fltk? ( =x11-libs/fltk-1.1* )
gtk? ( =x11-libs/gtk+-1.2* )"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
# This is a list of the tools in the package.
# Some of the tools don't make proper use of CFLAGS, even though
- # all of them seem to use autoconf. This needs to be fixed.
+ # all of them seem to use autoconf. This needs to be fixed.
#
# By default, all the supported tools will be compiled.
# If you want to only compile for specific tool(s), set ALSA_TOOLS
# environment to a space-separated list of tools that you want to build.
# For example:
#
- # env ALSA_TOOLS='as10k1 ac3dec' emerge alsa-tools
+ # env ALSA_TOOLS='as10k1 ac3dec' emerge alsa-tools
#
if [ -z "${ALSA_TOOLS}" ]; then
ALSA_TOOLS="ac3dec as10k1 hdsploader mixartloader seq/sbiload \
@@ -47,7 +48,7 @@ pkg_setup() {
fi
# sb16_csp won't build on ppc64 _AND_ ppc (and is not needed)
- if use !ppc64 && use !ppc; then
+ if use !ppc64 && use !ppc; then
ALSA_TOOLS="${ALSA_TOOLS} sb16_csp"
fi
diff --git a/media-sound/alsa-tools/alsa-tools-1.0.12_rc1.ebuild b/media-sound/alsa-tools/alsa-tools-1.0.12_rc1.ebuild
index 7281162ce1e3..841edc4a7440 100644
--- a/media-sound/alsa-tools/alsa-tools-1.0.12_rc1.ebuild
+++ b/media-sound/alsa-tools/alsa-tools-1.0.12_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.12_rc1.ebuild,v 1.1 2006/06/23 12:45:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.12_rc1.ebuild,v 1.2 2006/07/14 21:45:22 flameeyes Exp $
inherit eutils flag-o-matic autotools
@@ -15,24 +15,25 @@ SLOT="0.9"
KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="fltk gtk"
-DEPEND=">=media-libs/alsa-lib-1.0.0
+RDEPEND=">=media-libs/alsa-lib-1.0.0
virtual/alsa
fltk? ( =x11-libs/fltk-1.1* )
gtk? ( =x11-libs/gtk+-1.2* )"
+DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
pkg_setup() {
# This is a list of the tools in the package.
# Some of the tools don't make proper use of CFLAGS, even though
- # all of them seem to use autoconf. This needs to be fixed.
+ # all of them seem to use autoconf. This needs to be fixed.
#
# By default, all the supported tools will be compiled.
# If you want to only compile for specific tool(s), set ALSA_TOOLS
# environment to a space-separated list of tools that you want to build.
# For example:
#
- # env ALSA_TOOLS='as10k1 ac3dec' emerge alsa-tools
+ # env ALSA_TOOLS='as10k1 ac3dec' emerge alsa-tools
#
if [ -z "${ALSA_TOOLS}" ]; then
ALSA_TOOLS="ac3dec as10k1 hdsploader mixartloader seq/sbiload \
@@ -47,7 +48,7 @@ pkg_setup() {
fi
# sb16_csp won't build on ppc64 _AND_ ppc (and is not needed)
- if use !ppc64 && use !ppc; then
+ if use !ppc64 && use !ppc; then
ALSA_TOOLS="${ALSA_TOOLS} sb16_csp"
fi