summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-08-04 08:04:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-08-04 08:04:48 +0000
commitd7f2c011dc27c9520503a742374baf914af6f4a1 (patch)
treeada61376b43ef437bb473e35fdfb8ba5255fc682 /media-sound/aeolus
parentversion bump (diff)
downloadgentoo-2-d7f2c011dc27c9520503a742374baf914af6f4a1.tar.gz
gentoo-2-d7f2c011dc27c9520503a742374baf914af6f4a1.tar.bz2
gentoo-2-d7f2c011dc27c9520503a742374baf914af6f4a1.zip
version bump
(Portage version: 2.2_rc35/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/aeolus')
-rw-r--r--media-sound/aeolus/ChangeLog7
-rw-r--r--media-sound/aeolus/aeolus-0.8.2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/media-sound/aeolus/ChangeLog b/media-sound/aeolus/ChangeLog
index 016315da9ca2..3e07f8dfff8c 100644
--- a/media-sound/aeolus/ChangeLog
+++ b/media-sound/aeolus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/aeolus
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aeolus/ChangeLog,v 1.5 2009/01/25 14:56:31 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aeolus/ChangeLog,v 1.6 2009/08/04 08:04:48 aballier Exp $
+
+*aeolus-0.8.2 (04 Aug 2009)
+
+ 04 Aug 2009; Alexis Ballier <aballier@gentoo.org> +aeolus-0.8.2.ebuild:
+ version bump
25 Jan 2009; Markus Meier <maekke@gentoo.org> aeolus-0.8.1.ebuild:
amd64/x86 stable, bug #256042
diff --git a/media-sound/aeolus/aeolus-0.8.2.ebuild b/media-sound/aeolus/aeolus-0.8.2.ebuild
new file mode 100644
index 000000000000..61ed9de8141f
--- /dev/null
+++ b/media-sound/aeolus/aeolus-0.8.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aeolus/aeolus-0.8.2.ebuild,v 1.1 2009/08/04 08:04:48 aballier Exp $
+
+inherit versionator toolchain-funcs multilib
+
+MY_P=${PN}-$(replace_version_separator 3 '-')
+
+DESCRIPTION="A synthesised pipe organ emulator"
+HOMEPAGE="http://www.kokkinizita.net/linuxaudio/aeolus/index.html"
+SRC_URI="http://www.kokkinizita.net/linuxaudio/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libclalsadrv-1.2.2
+ >=media-libs/libclthreads-2.2.1
+ >=media-libs/libclxclient-3.3.2
+ x11-libs/libXft
+ x11-libs/libX11
+ >=media-sound/jack-audio-connection-kit-0.109.2
+ media-libs/alsa-lib
+ sys-libs/readline"
+
+RDEPEND="${DEPEND}
+ media-libs/stops"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+src_compile() {
+ tc-export CXX
+ sed -i -e "s/-O3//" Makefile || die "Failed to remove forced CFLAGS"
+ sed -i -e "s:/sbin/ldconfig:true:" Makefile || die "Failed to remove ldconfig call CFLAGS"
+ sed -i -e "s/g++/$(tc-getCXX)/" Makefile || die "Failed to set correct compiler"
+ emake PREFIX="/usr" LIBDIR=$(get_libdir) || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ emake PREFIX="${D}/usr" install || die "make install failed"
+ dodoc README AUTHORS
+ echo "-S /usr/share/stops" > "${T}/aeolus.conf"
+ insinto /etc
+ doins "${T}/aeolus.conf"
+}