summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-12 09:05:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-12 09:05:51 +0000
commit0d193f4c210ac9b5ce1d5b2994f265c946589a5a (patch)
treeac3b8cae247947f1c1f55f56f2b8178b523a6f78 /media-sound/aeolus
parentversion bump (diff)
downloadgentoo-2-0d193f4c210ac9b5ce1d5b2994f265c946589a5a.tar.gz
gentoo-2-0d193f4c210ac9b5ce1d5b2994f265c946589a5a.tar.bz2
gentoo-2-0d193f4c210ac9b5ce1d5b2994f265c946589a5a.zip
version bump, by Xavier Miller <xavier.miller@cauwe.org>, bug #310973
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/aeolus')
-rw-r--r--media-sound/aeolus/ChangeLog9
-rw-r--r--media-sound/aeolus/aeolus-0.8.4.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/media-sound/aeolus/ChangeLog b/media-sound/aeolus/ChangeLog
index 3e07f8dfff8c..2d192dff5ae5 100644
--- a/media-sound/aeolus/ChangeLog
+++ b/media-sound/aeolus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/aeolus
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aeolus/ChangeLog,v 1.6 2009/08/04 08:04:48 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aeolus/ChangeLog,v 1.7 2010/04/12 09:05:51 aballier Exp $
+
+*aeolus-0.8.4 (12 Apr 2010)
+
+ 12 Apr 2010; Alexis Ballier <aballier@gentoo.org> +aeolus-0.8.4.ebuild:
+ version bump, by Xavier Miller <xavier.miller@cauwe.org>, bug #310973
*aeolus-0.8.2 (04 Aug 2009)
diff --git a/media-sound/aeolus/aeolus-0.8.4.ebuild b/media-sound/aeolus/aeolus-0.8.4.ebuild
new file mode 100644
index 000000000000..0357cf2a292b
--- /dev/null
+++ b/media-sound/aeolus/aeolus-0.8.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aeolus/aeolus-0.8.4.ebuild,v 1.1 2010/04/12 09:05:51 aballier Exp $
+
+inherit versionator toolchain-funcs multilib
+
+MY_P=${PN}-$(replace_version_separator 3 '-')
+
+DESCRIPTION="A synthesised pipe organ emulator"
+HOMEPAGE="http://www.kokkinizita.net/linuxaudio/aeolus/index.html"
+SRC_URI="http://www.kokkinizita.net/linuxaudio/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libclalsadrv-2.0.0
+ >=media-libs/libclthreads-2.4.0
+ >=media-libs/libclxclient-3.6.1
+ x11-libs/libXft
+ x11-libs/libX11
+ >=media-sound/jack-audio-connection-kit-0.109.2
+ media-libs/alsa-lib
+ sys-libs/readline"
+
+RDEPEND="${DEPEND}
+ media-libs/stops"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)/source
+
+src_compile() {
+ tc-export CXX
+ sed -i -e "s/-O3//" Makefile || die "Failed to remove forced CFLAGS"
+ sed -i -e "s:/sbin/ldconfig:true:" Makefile || die "Failed to remove ldconfig call CFLAGS"
+ sed -i -e "s/g++/$(tc-getCXX)/" Makefile || die "Failed to set correct compiler"
+ emake PREFIX="/usr" LIBDIR=$(get_libdir) || die "make failed"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install || die "make install failed"
+ dodoc ../README ../AUTHORS
+ echo "-S /usr/share/stops" > "${T}/aeolus.conf"
+ insinto /etc
+ doins "${T}/aeolus.conf"
+}