summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-12-27 17:02:58 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-12-27 17:02:58 +0000
commitff5dbe663ad3e4c279bec32fbce627d8c665149a (patch)
treeffc9dd44b793394ee284be6318446b15556ce500 /media-radio
parentinitial commit of osm2mp (diff)
downloadgentoo-2-ff5dbe663ad3e4c279bec32fbce627d8c665149a.tar.gz
gentoo-2-ff5dbe663ad3e4c279bec32fbce627d8c665149a.tar.bz2
gentoo-2-ff5dbe663ad3e4c279bec32fbce627d8c665149a.zip
version bump by Thomas Beierlein
(Portage version: 2.2_rc19/cvs/Linux 2.6.27.10 x86_64)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tucnak2/ChangeLog7
-rw-r--r--media-radio/tucnak2/tucnak2-2.23.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/media-radio/tucnak2/ChangeLog b/media-radio/tucnak2/ChangeLog
index 599ec4b43f08..88cd10e83ee9 100644
--- a/media-radio/tucnak2/ChangeLog
+++ b/media-radio/tucnak2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/tucnak2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/ChangeLog,v 1.5 2008/12/19 14:09:18 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/ChangeLog,v 1.6 2008/12/27 17:02:58 darkside Exp $
+
+*tucnak2-2.23 (27 Dec 2008)
+
+ 27 Dec 2008; Jeremy Olexa <darkside@gentoo.org> +tucnak2-2.23.ebuild:
+ version bump by Thomas Beierlein
19 Dec 2008; Jeremy Olexa <darkside@gentoo.org>
+files/tucnak2-2.20-hamlib.diff, tucnak2-2.20.ebuild:
diff --git a/media-radio/tucnak2/tucnak2-2.23.ebuild b/media-radio/tucnak2/tucnak2-2.23.ebuild
new file mode 100644
index 000000000000..ff52a6dc515b
--- /dev/null
+++ b/media-radio/tucnak2/tucnak2-2.23.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/tucnak2/tucnak2-2.23.ebuild,v 1.1 2008/12/27 17:02:58 darkside Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa ftdi gpm hamlib"
+
+RDEPEND=">=dev-libs/glib-2
+ media-libs/libsndfile
+ >=media-libs/libsdl-1.2
+ alsa? ( media-libs/alsa-lib )
+ ftdi? ( dev-embedded/libftdi )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib )
+ >=media-libs/libpng-1.2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-2.19-doc.diff" \
+ "${FILESDIR}/${PN}-2.19-appname.diff"
+ eautoreconf
+}
+
+
+src_compile() {
+ econf $(use_with alsa) $(use_with ftdi) \
+ $(use_with gpm) $(use_with hamlib) --with-sdl
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ doman debian/tucnak2.1 || die "doman failed"
+ dodoc AUTHORS ChangeLog TODO doc/NAVOD.sxw doc/NAVOD.pdf || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak2 add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak2 can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+}