summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2014-06-26 09:15:53 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2014-06-26 09:15:53 +0000
commitb43817223165dd7ee9defdd294a10792eb6b6845 (patch)
treee81891f0ce8280cd357414625bd464ad0eb24271 /media-radio
parentBump (diff)
downloadgentoo-2-b43817223165dd7ee9defdd294a10792eb6b6845.tar.gz
gentoo-2-b43817223165dd7ee9defdd294a10792eb6b6845.tar.bz2
gentoo-2-b43817223165dd7ee9defdd294a10792eb6b6845.zip
Add newer version from SVN snapshot which does not segfault (bug #511630). Thanks for reporting Teun
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/wspr/ChangeLog12
-rw-r--r--media-radio/wspr/files/wspr-3.01-PIL.patch11
-rw-r--r--media-radio/wspr/files/wspr-3.01-script.patch19
-rw-r--r--media-radio/wspr/files/wspr-3.01-verbose.patch12
-rw-r--r--media-radio/wspr/wspr-3.01.ebuild95
5 files changed, 147 insertions, 2 deletions
diff --git a/media-radio/wspr/ChangeLog b/media-radio/wspr/ChangeLog
index 9b3af59ac518..976a9bc825eb 100644
--- a/media-radio/wspr/ChangeLog
+++ b/media-radio/wspr/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-radio/wspr
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/ChangeLog,v 1.13 2013/07/30 13:22:04 tomjbe Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/ChangeLog,v 1.14 2014/06/26 09:15:52 tomjbe Exp $
+
+*wspr-3.01 (26 Jun 2014)
+
+ 26 Jun 2014; Thomas Beierlein <tomjbe@gentoo.org> +wspr-3.01.ebuild,
+ +files/wspr-3.01-PIL.patch, +files/wspr-3.01-script.patch,
+ +files/wspr-3.01-verbose.patch:
+ Add newer version from SVN snapshot which does not segfault (bug #511630).
+ Thanks for reporting Teun
30 Jul 2013; Thomas Beierlein <tomjbe@gentoo.org> -wspr-2.00.ebuild:
Drop pre EAPI=4 version wrt bug #478576
diff --git a/media-radio/wspr/files/wspr-3.01-PIL.patch b/media-radio/wspr/files/wspr-3.01-PIL.patch
new file mode 100644
index 000000000000..ce4689195147
--- /dev/null
+++ b/media-radio/wspr/files/wspr-3.01-PIL.patch
@@ -0,0 +1,11 @@
+--- wspr.py.orig 2014-06-23 21:25:51.000000000 +0200
++++ wspr.py 2014-06-23 21:26:03.000000000 +0200
+@@ -35,7 +35,7 @@
+ from Numeric import zeros
+ import array
+ import dircache
+-import Image, ImageTk, ImageDraw
++from PIL import Image, ImageTk, ImageDraw
+ from WsprMod.palettes import colormapblue, colormapgray0, colormapHot, \
+ colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
+ from types import *
diff --git a/media-radio/wspr/files/wspr-3.01-script.patch b/media-radio/wspr/files/wspr-3.01-script.patch
new file mode 100644
index 000000000000..f64a11b68a64
--- /dev/null
+++ b/media-radio/wspr/files/wspr-3.01-script.patch
@@ -0,0 +1,19 @@
+--- wspr.py.orig 2014-06-24 19:13:55.000000000 +0200
++++ wspr.py 2014-06-24 19:14:43.000000000 +0200
+@@ -1,3 +1,4 @@
++#!/usr/bin/python
+ #-------------------------------------------------------------------- WSPR
+ # $Date: 2014/06/26 09:15:53 $ $Revision: 1.1 $
+ #
+--- wspr.orig 2014-06-24 18:57:00.000000000 +0200
++++ wspr 2014-06-24 19:09:50.000000000 +0200
+@@ -1,2 +1,7 @@
+-LD_LIBRARY_PATH=./lib
+-python -O wspr.py
++#!/bin/sh
++if [ ! -e ~/.wspr ] ; then
++ mkdir ~/.wspr
++ mkdir ~/.wspr/save
++fi
++cd ~/.wspr
++/usr/bin/wspr.py
diff --git a/media-radio/wspr/files/wspr-3.01-verbose.patch b/media-radio/wspr/files/wspr-3.01-verbose.patch
new file mode 100644
index 000000000000..b697cfe444dd
--- /dev/null
+++ b/media-radio/wspr/files/wspr-3.01-verbose.patch
@@ -0,0 +1,12 @@
+# make f2py verbose
+--- Makefile.in.orig 2014-06-23 21:14:51.000000000 +0200
++++ Makefile.in 2014-06-23 21:15:11.000000000 +0200
+@@ -95,7 +95,7 @@
+ OBJS2C = ${SRCS2C:.c=.o}
+
+ WsprMod/w.so: ${OBJS2C} $(SRCS2C) $(SRCS2F90) $(SRCS2F77) acom1.f90
+- ${F2PY} -c --quiet --noopt --debug -m w \
++ ${F2PY} -c --noopt --debug -m w \
+ --f77flags="${FFLAGS}" --f90flags="${FFLAGS}" \
+ --fcompiler=${FCV} --f77exec=${FC} --f90exec=${FC} \
+ --opt="-fbounds-check ${FFLAGS}" \
diff --git a/media-radio/wspr/wspr-3.01.ebuild b/media-radio/wspr/wspr-3.01.ebuild
new file mode 100644
index 000000000000..f8e6b9889602
--- /dev/null
+++ b/media-radio/wspr/wspr-3.01.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/wspr/wspr-3.01.ebuild,v 1.1 2014/06/26 09:15:52 tomjbe Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="tk"
+
+inherit autotools fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
+
+MY_P=${P}.r2792
+
+DESCRIPTION="Weak Signal Propagation Reporter"
+HOMEPAGE="http://www.physics.princeton.edu/pulsar/K1JT/wspr.html"
+SRC_URI="http://dev.gentoo.org/~tomjbe/distfiles/${MY_P}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/python-imaging[tk,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ virtual/pmw[${PYTHON_USEDEP}]
+ sci-libs/fftw:3.0
+ media-libs/hamlib
+ media-libs/portaudio
+ media-libs/libsamplerate"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( BUGS WSPR_Announcement.TXT WSPR0_Instructions.TXT WSPR_Quick_Start.TXT )
+
+pkg_setup() {
+ fortran-2_pkg_setup
+}
+
+get_fcomp() {
+ case $(tc-getFC) in
+ *gfortran* ) FCOMP="gfortran" ;;
+ * ) FCOMP=$(tc-getFC) ;;
+ esac
+}
+
+python_prepare_all() {
+ tc-export FC
+ get_fcomp
+ export FC="${FCOMP}"
+
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-2.00-libdir.patch
+ "${FILESDIR}"/${P}-verbose.patch
+ "${FILESDIR}"/${PN}-3.01-script.patch
+ "${FILESDIR}"/${P}-PIL.patch
+ )
+
+ distutils-r1_python_prepare_all
+
+ sed -i -e "s/LDFLAGS} ${LIBS}/LDFLAGS} -fPIC ${LIBS}/" Makefile.in || die
+ sed -i -e "s#/usr/local/lib#/usr/$(get_libdir)#" configure.ac || die
+ sed -i -e '/makedirs/d' setup.py || die
+ eautoreconf
+}
+
+# Note: very hacky build system.
+# autoconf which doesn't really need Python
+# then custom Makefile which compiles the Python module with f2py
+# and finally hacked setup.py which relies on w.so created by make
+
+src_configure() {
+ # configure the build of the fortran module
+ econf --with-portaudio-lib-dir=/usr/$(get_libdir)
+
+ # then fork the sources
+ python_copy_sources
+ DISTUTILS_IN_SOURCE_BUILD=1
+}
+
+python_compile() {
+ # -shared is neded by f2py but cannot be set earlier as configure does
+ # not like it
+ local LDFLAGS=${LDFLAGS}
+ append-ldflags -shared
+ emake -j1
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ dobin wspr
+ insinto /usr/share/${PN}
+ doins hamlib_rig_numbers
+}