summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-15 12:27:57 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-15 12:27:57 +0000
commit2036dd2b3dcea99e714fe36e494c0e409582c3e1 (patch)
treee1949485e103dc5ba9f028249d25e8b68ad49442 /media-radio
parentUnmasking spandsp as upstream told us to use >=spandsp-0.0.6_pre2. Fix packag... (diff)
downloadgentoo-2-2036dd2b3dcea99e714fe36e494c0e409582c3e1.tar.gz
gentoo-2-2036dd2b3dcea99e714fe36e494c0e409582c3e1.tar.bz2
gentoo-2-2036dd2b3dcea99e714fe36e494c0e409582c3e1.zip
Fixed build problem with >=spandsp-0.0.6_pre2, bug #249338, thank Yaroslav Gorbunov for report and patch. Fixed build issue with --as-needed, bug #247807, thank Diego E. 'Flameeyes' Pettenò for report. Force to use up-to-date spandsp library.
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/svxlink/ChangeLog10
-rw-r--r--media-radio/svxlink/files/svxlink-080730--as-needed.patch13
-rw-r--r--media-radio/svxlink/files/svxlink-080730-spandsp-0.0.6_pre2.patch21
-rw-r--r--media-radio/svxlink/svxlink-080730.ebuild6
4 files changed, 47 insertions, 3 deletions
diff --git a/media-radio/svxlink/ChangeLog b/media-radio/svxlink/ChangeLog
index c0ed3c1c18bd..09dd5de9f646 100644
--- a/media-radio/svxlink/ChangeLog
+++ b/media-radio/svxlink/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-radio/svxlink
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/ChangeLog,v 1.5 2008/09/23 03:48:53 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/ChangeLog,v 1.6 2008/12/15 12:27:51 pva Exp $
+
+ 15 Dec 2008; Peter Volkov <pva@gentoo.org>
+ +files/svxlink-080730--as-needed.patch,
+ +files/svxlink-080730-spandsp-0.0.6_pre2.patch, svxlink-080730.ebuild:
+ Fixed build problem with >=spandsp-0.0.6_pre2, bug #249338, thank Yaroslav
+ Gorbunov for report and patch. Fixed build issue with --as-needed, bug
+ #247807, thank Diego E. 'Flameeyes' Pettenò for report. Force to use
+ up-to-date spandsp library.
*svxlink-080730 (23 Sep 2008)
*svxlink-080102-r1 (23 Sep 2008)
diff --git a/media-radio/svxlink/files/svxlink-080730--as-needed.patch b/media-radio/svxlink/files/svxlink-080730--as-needed.patch
new file mode 100644
index 000000000000..c6ca9d9c4fc5
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink-080730--as-needed.patch
@@ -0,0 +1,13 @@
+=== modified file 'async/demo/Makefile.default'
+--- async/demo/Makefile.default 2008-11-30 12:25:03 +0000
++++ async/demo/Makefile.default 2008-11-30 12:34:18 +0000
+@@ -62,7 +62,7 @@
+ PRGSRC =
+
+ # Libraries compiled in the project (in $(LIB)).
+-PROJLIBS = -lasynccpp -lasyncaudio
++PROJLIBS = -lasynccpp -lasyncaudio -lasynccore
+ ifdef QT_BIN
+ PROJLIBS += -lasyncqt
+ endif
+
diff --git a/media-radio/svxlink/files/svxlink-080730-spandsp-0.0.6_pre2.patch b/media-radio/svxlink/files/svxlink-080730-spandsp-0.0.6_pre2.patch
new file mode 100644
index 000000000000..8a248dec4436
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink-080730-spandsp-0.0.6_pre2.patch
@@ -0,0 +1,21 @@
+=== modified file 'svxlink/trx/SpanDtmfDecoder.cpp'
+--- svxlink/trx/SpanDtmfDecoder.cpp 2008-12-07 18:35:58 +0000
++++ svxlink/trx/SpanDtmfDecoder.cpp 2008-12-07 18:38:37 +0000
+@@ -40,6 +40,7 @@
+ #include <stdlib.h>
+ #include <stdint.h>
+ #include <spandsp.h>
++#include <spandsp/expose.h>
+
+
+ /****************************************************************************
+@@ -166,7 +167,7 @@
+ }
+
+ dtmf_rx_init(&p->rx_state, NULL, this);
+- dtmf_rx_parms(&p->rx_state, FALSE, max_fwd_twist, max_rev_twist);
++ dtmf_rx_parms(&p->rx_state, FALSE, max_fwd_twist, max_rev_twist, -99);
+ dtmf_rx_set_realtime_callback(&p->rx_state, SpanDtmfDecoder::toneReportCb,
+ this);
+
+
diff --git a/media-radio/svxlink/svxlink-080730.ebuild b/media-radio/svxlink/svxlink-080730.ebuild
index 4494ff213b77..f560718a7808 100644
--- a/media-radio/svxlink/svxlink-080730.ebuild
+++ b/media-radio/svxlink/svxlink-080730.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/svxlink-080730.ebuild,v 1.1 2008/09/23 03:48:53 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/svxlink-080730.ebuild,v 1.2 2008/12/15 12:27:51 pva Exp $
EAPI=1
@@ -19,7 +19,7 @@ RDEPEND="dev-lang/tcl
media-sound/gsm
x11-libs/qt:3
dev-libs/libsigc++:1.2
- media-libs/spandsp
+ >=media-libs/spandsp-0.0.6_pre2
dev-libs/popt"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
@@ -28,6 +28,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${PN}-fix-Makefile.diff"
+ epatch "${FILESDIR}/${P}--as-needed.patch"
+ epatch "${FILESDIR}/${P}-spandsp-0.0.6_pre2.patch"
}
src_compile() {