summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2014-05-16 05:22:34 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2014-05-16 05:22:34 +0000
commit72c7b5a0cacf597dce9f6836a166c4823483f514 (patch)
treee627f4eaf7735aae52ce6af431ecf9ee36c89392 /media-radio/unixcw
parentAdd ~mips also to test-unit:2 since that is other arches have done for bug 33... (diff)
downloadgentoo-2-72c7b5a0cacf597dce9f6836a166c4823483f514.tar.gz
gentoo-2-72c7b5a0cacf597dce9f6836a166c4823483f514.tar.bz2
gentoo-2-72c7b5a0cacf597dce9f6836a166c4823483f514.zip
Bug fix release
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x762053D5)
Diffstat (limited to 'media-radio/unixcw')
-rw-r--r--media-radio/unixcw/ChangeLog9
-rw-r--r--media-radio/unixcw/unixcw-3.3.1.ebuild72
2 files changed, 79 insertions, 2 deletions
diff --git a/media-radio/unixcw/ChangeLog b/media-radio/unixcw/ChangeLog
index c14f6492e083..bd23ab26955f 100644
--- a/media-radio/unixcw/ChangeLog
+++ b/media-radio/unixcw/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/unixcw
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.12 2013/12/25 13:26:27 tomjbe Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/ChangeLog,v 1.13 2014/05/16 05:22:34 tomjbe Exp $
+
+*unixcw-3.3.1 (16 May 2014)
+
+ 16 May 2014; Thomas Beierlein <tomjbe@gentoo.org> +unixcw-3.3.1.ebuild:
+ Bug fix release
*unixcw-3.3.0 (25 Dec 2013)
diff --git a/media-radio/unixcw/unixcw-3.3.1.ebuild b/media-radio/unixcw/unixcw-3.3.1.ebuild
new file mode 100644
index 000000000000..5b8df17259d7
--- /dev/null
+++ b/media-radio/unixcw/unixcw-3.3.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/unixcw/unixcw-3.3.1.ebuild,v 1.1 2014/05/16 05:22:34 tomjbe Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="A package of programs that fit together to form a morse code tutor program."
+HOMEPAGE="http://unixcw.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="alsa ncurses pulseaudio suid qt4"
+
+RDEPEND="ncurses? ( sys-libs/ncurses )
+ qt4? ( dev-qt/qtgui:4[qt3support] )
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool
+ !<=app-misc/cw-1.0.16-r1"
+
+src_prepare() {
+ append-cflags -std=gnu99
+ # add path to qt4 libs
+ sed -i -e "s#LDADD = -L#LDADD = -L/usr/$(get_libdir)/qt4 -L#g" \
+ src/xcwcp/Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ econf --libdir=/usr/$(get_libdir) \
+ $(use_enable pulseaudio ) \
+ $(use_enable alsa ) \
+ $(use_enable ncurses cwcp ) \
+ $(use_enable qt4 xcwcp )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+ dodoc ChangeLog NEWS README
+ if ! use suid ; then
+ fperms 711 /usr/bin/cw
+ if use ncurses ; then
+ fperms 711 /usr/bin/cwcp
+ fi
+ if use qt4 ; then
+ fperms 711 /usr/bin/xcwcp
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use suid ; then
+ ewarn "You have choosen to install 'cw', 'cwcp' and 'xcwcp' setuid"
+ ewarn "by setting USE=suid."
+ ewarn "Be aware that this is a security risk and not recommended."
+ ewarn ""
+ ewarn "These files do only need root access if you want to use the"
+ ewarn "PC speaker for morse sidetone output. You can alternativly"
+ ewarn "drop USE=suid and use sudo."
+ else
+ elog "Be aware that 'cw', 'cwcp' and 'xcwcp' needs root access if"
+ elog "you want to use the PC speaker for morse sidetone output."
+ elog "You can call the programs via sudo for that (see 'man sudo')."
+ fi
+}