summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-19 16:15:01 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-19 16:15:01 +0000
commit281224d30f3deac6a418f166212dff5bc8352dc3 (patch)
treef1015b70154b312198ad865a0dae8fb89e4c6c0b /media-radio/svxlink
parentunused patches (diff)
downloadgentoo-2-281224d30f3deac6a418f166212dff5bc8352dc3.tar.gz
gentoo-2-281224d30f3deac6a418f166212dff5bc8352dc3.tar.bz2
gentoo-2-281224d30f3deac6a418f166212dff5bc8352dc3.zip
Remove automagic x11-libs/qt:3 detection wrt #301744, thanks to Ben de Groot and Thomas Beierlein.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-radio/svxlink')
-rw-r--r--media-radio/svxlink/ChangeLog9
-rw-r--r--media-radio/svxlink/files/svxlink-090426-noqt.patch52
-rw-r--r--media-radio/svxlink/svxlink-090426.ebuild12
3 files changed, 65 insertions, 8 deletions
diff --git a/media-radio/svxlink/ChangeLog b/media-radio/svxlink/ChangeLog
index 80725593e102..1c4010444c28 100644
--- a/media-radio/svxlink/ChangeLog
+++ b/media-radio/svxlink/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-radio/svxlink
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/ChangeLog,v 1.14 2009/12/28 16:21:24 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/ChangeLog,v 1.15 2010/02/19 16:14:59 ssuominen Exp $
+
+ 19 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> svxlink-090426.ebuild,
+ +files/svxlink-090426-noqt.patch:
+ Remove automagic x11-libs/qt:3 detection wrt #301744, thanks to Ben de
+ Groot and Thomas Beierlein.
28 Dec 2009; Samuli Suominen <ssuominen@gentoo.org> svxlink-090426.ebuild:
Stop using deprecated kde-functions.eclass.
diff --git a/media-radio/svxlink/files/svxlink-090426-noqt.patch b/media-radio/svxlink/files/svxlink-090426-noqt.patch
new file mode 100644
index 000000000000..01ee4e1eb0e2
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink-090426-noqt.patch
@@ -0,0 +1,52 @@
+Remove automagic Qt3 detection
+
+https://bugs.gentoo.org/301744
+
+--- create_config.sh
++++ create_config.sh
+@@ -60,45 +60,6 @@
+ output "ECHO=/bin/echo -e"
+ fi
+
+-# Checking for QT
+-info "--- Checking for QT..."
+-if which pkg-config > /dev/null 2>&1; then
+- if pkg-config qt; then
+- info "yes (pkg-config qt)\n"
+- output "QT_LIBPATH=$(pkg-config qt --libs-only-L)"
+- output "QT_LIBS=$(pkg-config qt --libs-only-l)"
+- output "QT_INCPATH=$(pkg-config qt --cflags-only-I)"
+- output "QT_CFLAGS=$(pkg-config qt --cflags-only-other)"
+- QT_PREFIX=$(pkg-config qt --variable=prefix)
+- elif pkg-config qt-mt; then
+- info "yes (pkg-config qt-mt)\n"
+- output "QT_LIBPATH=$(pkg-config qt-mt --libs-only-L)"
+- output "QT_LIBS=$(pkg-config qt-mt --libs-only-l)"
+- output "QT_INCPATH=$(pkg-config qt-mt --cflags-only-I)"
+- output "QT_CFLAGS=$(pkg-config qt-mt --cflags-only-other)"
+- QT_PREFIX=$(pkg-config qt-mt --variable=prefix)
+- fi
+-fi
+-if [ -z "$QT_PREFIX" -a -n "$QTDIR" ]; then
+- info "yes (QTDIR)\n"
+- output "QT_LIBPATH=-L${QTDIR}/lib"
+- if [ -n "$(ls ${QTDIR}/lib/libqt-mt* 2> /dev/null)" ]; then
+- output "QT_LIBS=-lqt-mt"
+- else
+- output "QT_LIBS=-lqt"
+- fi
+- output "QT_INCPATH=-I${QTDIR}/include"
+- output "QT_CFLAGS="
+- QT_PREFIX=${QTDIR}
+-fi
+-if [ -n "$QT_PREFIX" ]; then
+- QT_BIN="${QT_PREFIX}/bin"
+- output "QT_BIN=${QT_BIN}"
+- output "QT_MOC=${QT_BIN}/moc"
+- output "QT_UIC=${QT_BIN}/uic"
+-else
+- info "no (optional)\n"
+-fi
+
+ # Checking for libsigc++
+ sigc_version=1.2
diff --git a/media-radio/svxlink/svxlink-090426.ebuild b/media-radio/svxlink/svxlink-090426.ebuild
index e7d56e7029f7..5b7b22ff2b0e 100644
--- a/media-radio/svxlink/svxlink-090426.ebuild
+++ b/media-radio/svxlink/svxlink-090426.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/svxlink-090426.ebuild,v 1.4 2009/12/28 16:21:24 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/svxlink/svxlink-090426.ebuild,v 1.5 2010/02/19 16:14:59 ssuominen Exp $
EAPI=2
-inherit multilib qt3
+inherit eutils multilib
DESCRIPTION="Multi Purpose Voice Services System, including Qtel for EchoLink"
HOMEPAGE="http://svxlink.sourceforge.net/"
@@ -16,7 +16,6 @@ IUSE=""
RDEPEND="dev-lang/tcl
media-sound/gsm
- x11-libs/qt:3
dev-libs/libgcrypt
media-libs/speex
dev-libs/libsigc++:1.2
@@ -27,8 +26,9 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
src_prepare() {
- epatch "${FILESDIR}/${PN}-080730--as-needed.patch"
- epatch "${FILESDIR}/${P}-gcc44.patch"
+ epatch "${FILESDIR}"/${PN}-080730--as-needed.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-noqt.patch
sed -i -e "s:/lib:/$(get_libdir):g" makefile.cfg || die
}