summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2015-01-28 14:56:35 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2015-01-28 14:56:35 +0000
commitd61c41a0a4eaa94bd7fa677c4dce1417dcbbd586 (patch)
tree485c61ec77422c55e48d0471fc9fb738a8859fd6 /media-plugins
parentVersion bump, drop old (diff)
downloadgentoo-2-d61c41a0a4eaa94bd7fa677c4dce1417dcbbd586.tar.gz
gentoo-2-d61c41a0a4eaa94bd7fa677c4dce1417dcbbd586.tar.bz2
gentoo-2-d61c41a0a4eaa94bd7fa677c4dce1417dcbbd586.zip
parameter --epgimages available in rc-script
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-live/ChangeLog9
-rw-r--r--media-plugins/vdr-live/files/confd-0.329
-rw-r--r--media-plugins/vdr-live/files/rc-addon-0.3.sh31
-rw-r--r--media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild6
-rw-r--r--media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild109
5 files changed, 179 insertions, 5 deletions
diff --git a/media-plugins/vdr-live/ChangeLog b/media-plugins/vdr-live/ChangeLog
index 8640ee33776a..568ce7dd7532 100644
--- a/media-plugins/vdr-live/ChangeLog
+++ b/media-plugins/vdr-live/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-plugins/vdr-live
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.45 2015/01/21 13:01:35 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/ChangeLog,v 1.46 2015/01/28 14:56:35 hd_brummy Exp $
+
+*vdr-live-0.3.0_p20130504-r2 (28 Jan 2015)
+
+ 28 Jan 2015; Joerg Bornkessel <hd_brummy@gentoo.org>
+ vdr-live-0.3.0_p20130504-r1.ebuild, +vdr-live-0.3.0_p20130504-r2.ebuild,
+ +files/confd-0.3, +files/rc-addon-0.3.sh:
+ parameter --epgimages available in rc-script
21 Jan 2015; Joerg Bornkessel <hd_brummy@gentoo.org>
vdr-live-0.3.0_p20130504-r1.ebuild:
diff --git a/media-plugins/vdr-live/files/confd-0.3 b/media-plugins/vdr-live/files/confd-0.3
new file mode 100644
index 000000000000..cb1dce04dfb5
--- /dev/null
+++ b/media-plugins/vdr-live/files/confd-0.3
@@ -0,0 +1,29 @@
+# configuration of media-plugins/vdr-live
+
+# for people who want more secure
+# with ssl access.
+# on usage, you have to install vdr-live
+# with USE="ssl"
+#
+# SSL ADDRESS --> https://<your-ip>:8443/
+#
+# allowed values: yes no
+# default: no
+#LIVE_USE_SSL="yes"
+
+# default given portnumber
+# only changes needed on problems
+#
+#LIVE_PORT="8008"
+#LIVE_SSL_PORT="8443"
+
+# bind to these IP addresses
+# default, your IP will automaticly detected
+#
+LIVE_BIND_IPS="127.0.0.1"
+
+# for people who have epgimges
+# default: /var/cache/vdr/epgimges
+#
+# set this to your own path, if needed
+#EPGIMAGES_DIR=" "
diff --git a/media-plugins/vdr-live/files/rc-addon-0.3.sh b/media-plugins/vdr-live/files/rc-addon-0.3.sh
new file mode 100644
index 000000000000..1ff3b1982cf8
--- /dev/null
+++ b/media-plugins/vdr-live/files/rc-addon-0.3.sh
@@ -0,0 +1,31 @@
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/files/rc-addon-0.3.sh,v 1.1 2015/01/28 14:56:35 hd_brummy Exp $
+#
+# zzam@g.o
+# hd_brummy@g.o
+
+EPGIMAGES_DIR="/var/cache/vdr/epgimages"
+
+plugin_pre_vdr_start() {
+ if [ "${LIVE_USE_SSL:=no}" = "yes" ]; then
+ if [ -n "${LIVE_SSL_PORT}" ]; then
+ add_plugin_param "-s ${LIVE_SSL_PORT}"
+ fi
+
+ add_plugin_param "--cert=/etc/vdr/plugins/live/live.pem"
+ add_plugin_param "--key=/etc/vdr/plugins/live/live-key.pem"
+
+ else
+ if [ -n "${LIVE_PORT}" ]; then
+ add_plugin_param "-p ${LIVE_PORT}"
+ fi
+ fi
+
+ if [ -d ${EPGIMAGES_DIR} ]; then
+ add_plugin_param "--epgimages=${EPGIMAGES_DIR}"
+ fi
+
+ local ip
+ for ip in ${LIVE_BIND_IPS:=`hostname -i`}; do
+ add_plugin_param "-i ${ip}"
+ done
+}
diff --git a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild
index d722d2f65a97..8d10db7c056f 100644
--- a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild
+++ b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild,v 1.2 2015/01/21 13:01:35 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r1.ebuild,v 1.3 2015/01/28 14:56:35 hd_brummy Exp $
EAPI=5
@@ -53,9 +53,7 @@ make_live_cert() {
}
src_configure() {
- vdr-plugin-2_src_configure
-
- # tmp. disabeled gcc -std=c++11, due massiv compile errors
+ # tmp. disabled gcc -std=c++11, due massiv compile errors
filter-flags -std=c++11
}
diff --git a/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild
new file mode 100644
index 000000000000..5284d043b88b
--- /dev/null
+++ b/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-live/vdr-live-0.3.0_p20130504-r2.ebuild,v 1.1 2015/01/28 14:56:35 hd_brummy Exp $
+
+EAPI=5
+
+inherit vdr-plugin-2 ssl-cert
+
+DESCRIPTION="VDR Plugin: Web Access To Settings"
+HOMEPAGE="http://live.vdr-developer.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~hd_brummy/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pcre ssl"
+
+DEPEND="media-video/vdr
+ >=dev-libs/tntnet-2.2.1[ssl=]
+ >=dev-libs/cxxtools-2.2.1
+ pcre? ( >=dev-libs/libpcre-8.12[cxx] )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+VDR_CONFD_FILE="${FILESDIR}/confd-0.3"
+VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.3.sh"
+
+KEEP_I18NOBJECT="yes"
+
+make_live_cert() {
+ # TODO: still true?
+ # ssl-cert eclass creates a "invalid" cert, create our own one
+ local base=$(get_base 1)
+ local keydir="/etc/vdr/plugins/live"
+
+ SSL_ORGANIZATION="${SSL_ORGANIZATION:-VDR Plugin Live}"
+ SSL_COMMONNAME="${SSL_COMMONNAME:-`hostname -f`}"
+
+ echo
+ gen_cnf || return 1
+ echo
+ gen_key 1 || return 1
+ gen_csr 1 || return 1
+ gen_crt 1 || return 1
+ echo
+
+ install -d "${ROOT}${keydir}"
+ install -m0400 "${base}.key" "${ROOT}${keydir}/live-key.pem"
+ install -m0444 "${base}.crt" "${ROOT}${keydir}/live.pem"
+ chown vdr:vdr "${ROOT}"/etc/vdr/plugins/live/live{,-key}.pem
+}
+
+src_configure() {
+ # tmp. disabled gcc -std=c++11, due massiv compile errors
+ filter-flags -std=c++11
+}
+
+src_prepare() {
+ # new Makefile handling ToDp
+# cp "${FILESDIR}/live.mk" "${S}/Makefile"
+
+ # remove untranslated language files
+ rm "${S}"/po/{ca_ES,da_DK,el_GR,et_EE,hr_HR,hu_HU,nl_NL,nn_NO,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+ vdr-plugin-2_src_prepare
+
+ epatch "${FILESDIR}/${P}_vdr-2.1.2.diff"
+
+ if ! use pcre; then
+ sed -i "s:^HAVE_LIBPCRECPP:#HAVE_LIBPCRECPP:" Makefile || die
+ fi
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /usr/share/vdr/plugins/live
+ doins -r live/*
+
+ fowners -R vdr:vdr /usr/share/vdr/plugins/live
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ elog "To be able to use all functions of vdr-live"
+ elog "you should emerge and enable"
+ elog "media-plugins/vdr-epgsearch to search the EPG,"
+ elog "media-plugins/vdr-streamdev for Live-TV streaming"
+
+ elog "The default username/password is:"
+ elog "\tadmin:live"
+
+ if use ssl ; then
+ if path_exists -a "${ROOT}"/etc/vdr/plugins/live/live.pem; then
+ einfo "found an existing SSL cert, to create a new SSL cert, run:\n"
+ einfo "emerge --config ${PN}"
+ else
+ einfo "No SSL cert found, creating a default one now"
+ make_live_cert
+ fi
+ fi
+}
+
+pkg_config() {
+ make_live_cert
+}