summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-02-11 07:34:18 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-02-11 07:34:18 +0000
commitcf46866426fe62a769670120beed74b3776d4f5c (patch)
tree7ce297485f5346348d2c2c56bb7f7bda91c7fb13 /media-plugins
parentAdd media-plugins/gst-plugins-ffmpeg-0.10.13_p201211 prereleases to libav pac... (diff)
downloadgentoo-2-cf46866426fe62a769670120beed74b3776d4f5c.tar.gz
gentoo-2-cf46866426fe62a769670120beed74b3776d4f5c.tar.bz2
gentoo-2-cf46866426fe62a769670120beed74b3776d4f5c.zip
Add the gstreamer-2012.11 SDK git snapshot of gst-plugins-ffmpeg with additional backported patches from gst-plugins-libav-1.1 for libav-9 and (hopefully) ffmpeg-1.1 compatibility; should fix bug #423717. Pin existing ebuild to libav-0.8 and ffmpeg-0.10.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-ffmpeg/ChangeLog12
-rw-r--r--media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13-r2.ebuild4
-rw-r--r--media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13_p201211.ebuild64
3 files changed, 77 insertions, 3 deletions
diff --git a/media-plugins/gst-plugins-ffmpeg/ChangeLog b/media-plugins/gst-plugins-ffmpeg/ChangeLog
index 0026aab00902..7e496716f121 100644
--- a/media-plugins/gst-plugins-ffmpeg/ChangeLog
+++ b/media-plugins/gst-plugins-ffmpeg/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-plugins/gst-plugins-ffmpeg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/ChangeLog,v 1.151 2013/02/10 22:30:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/ChangeLog,v 1.152 2013/02/11 07:34:18 tetromino Exp $
+
+*gst-plugins-ffmpeg-0.10.13_p201211 (11 Feb 2013)
+
+ 11 Feb 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gst-plugins-ffmpeg-0.10.13-r2.ebuild,
+ +gst-plugins-ffmpeg-0.10.13_p201211.ebuild:
+ Add the gstreamer-2012.11 SDK git snapshot of gst-plugins-ffmpeg with
+ additional backported patches from gst-plugins-libav-1.1 for libav-9 and
+ (hopefully) ffmpeg-1.1 compatibility; should fix bug #423717. Pin existing
+ ebuild to libav-0.8 and ffmpeg-0.10.
10 Feb 2013; Agostino Sarubbo <ago@gentoo.org>
gst-plugins-ffmpeg-0.10.13-r2.ebuild:
diff --git a/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13-r2.ebuild b/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13-r2.ebuild
index 3cb0d15c1396..2a32302bd00f 100644
--- a/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13-r2.ebuild
+++ b/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13-r2.ebuild,v 1.12 2013/02/10 22:30:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13-r2.ebuild,v 1.13 2013/02/11 07:34:18 tetromino Exp $
EAPI=4
@@ -26,7 +26,7 @@ S=${WORKDIR}/${MY_P}
# the libpostproc dep should be cleaned in future
RDEPEND=">=media-libs/gstreamer-0.10.31:0.10
>=media-libs/gst-plugins-base-0.10.31:0.10
- >=virtual/ffmpeg-0.10
+ =virtual/ffmpeg-0.10*
|| ( media-video/ffmpeg media-libs/libpostproc <media-video/libav-0.8.2-r1 )
orc? ( >=dev-lang/orc-0.4.6 )"
DEPEND="${RDEPEND}
diff --git a/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13_p201211.ebuild b/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13_p201211.ebuild
new file mode 100644
index 000000000000..dcf6c83454d7
--- /dev/null
+++ b/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13_p201211.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-ffmpeg/gst-plugins-ffmpeg-0.10.13_p201211.ebuild,v 1.1 2013/02/11 07:34:18 tetromino Exp $
+
+EAPI=5
+
+inherit base eutils flag-o-matic
+
+MY_PN="gst-ffmpeg"
+MY_P=${MY_PN}-${PV}
+
+# Create a major/minor combo for SLOT
+PVP=(${PV//[-\._]/ })
+SLOT=${PVP[0]}.${PVP[1]}
+
+DESCRIPTION="FFmpeg based gstreamer plugin"
+HOMEPAGE="http://gstreamer.freedesktop.org/modules/gst-ffmpeg.html"
+#SRC_URI="http://gstreamer.freedesktop.org/src/${MY_PN}/${MY_P}.tar.bz2"
+SRC_URI="http://dev.gentoo.org/~tetromino/distfiles/${PN}/${MY_P}.tar.xz
+ http://dev.gentoo.org/~tetromino/distfiles/${PN}/${MY_P}-libav-9-patches.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+orc"
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND=">=media-libs/gstreamer-0.10.31:0.10
+ >=media-libs/gst-plugins-base-0.10.31:0.10
+ >=virtual/ffmpeg-9
+ || ( media-video/ffmpeg media-libs/libpostproc )
+ orc? ( >=dev-lang/orc-0.4.6 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -e 's/sleep 15//' -i configure.ac configure || die
+
+ # libav-9 support backported from gst-plugins-libav-1.1.0
+ epatch ../${MY_P}-libav-9-patches/*.patch
+
+ # monkey's audio requires planar audio support to be backported
+ sed -e 's#[ \t]elements/ffdemux_ape[^ ]*##' -i tests/check/Makefile.{am,in} || die
+}
+
+src_configure() {
+ # always use system ffmpeg if possible
+ econf \
+ --with-system-ffmpeg \
+ $(use_enable orc)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
+
+pkg_postinst() {
+ if has_version "media-video/ffmpeg"; then
+ elog "Please note that upstream uses media-video/libav"
+ elog "rather than media-video/ffmpeg. If you encoutner any"
+ elog "issues try to move from ffmpeg to libav."
+ fi
+}