summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-20 16:04:51 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-20 16:04:51 +0000
commit83effdb5aeb5ac2df8df55b7c54afd0836220f5e (patch)
tree8797063737e013baab5b19154e1e8e98f97e4053 /media-plugins/xine-d5d
parentupdated DEPEND (diff)
downloadgentoo-2-83effdb5aeb5ac2df8df55b7c54afd0836220f5e.tar.gz
gentoo-2-83effdb5aeb5ac2df8df55b7c54afd0836220f5e.tar.bz2
gentoo-2-83effdb5aeb5ac2df8df55b7c54afd0836220f5e.zip
move xine plugins
Diffstat (limited to 'media-plugins/xine-d5d')
-rw-r--r--media-plugins/xine-d5d/ChangeLog38
-rw-r--r--media-plugins/xine-d5d/files/digest-xine-d5d-0.2.71
-rw-r--r--media-plugins/xine-d5d/files/digest-xine-d5d-0.2.7-r11
-rw-r--r--media-plugins/xine-d5d/files/xine-d5d-0.2.7-r1-gentoo.diff14
-rw-r--r--media-plugins/xine-d5d/xine-d5d-0.2.7-r1.ebuild44
-rw-r--r--media-plugins/xine-d5d/xine-d5d-0.2.7.ebuild35
6 files changed, 133 insertions, 0 deletions
diff --git a/media-plugins/xine-d5d/ChangeLog b/media-plugins/xine-d5d/ChangeLog
new file mode 100644
index 000000000000..ad7090603753
--- /dev/null
+++ b/media-plugins/xine-d5d/ChangeLog
@@ -0,0 +1,38 @@
+# ChangeLog for media-video/xine-d5d
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xine-d5d/ChangeLog,v 1.1 2002/11/20 16:04:51 azarah Exp $
+
+*xine-d5d-0.2.7 (08 Jul 2002)
+
+ 20 Oct 2002; Seemant Kulleen <seemant@gentoo.org> xine-d5d-0.2.7-r1.ebuild :
+
+ Added big endian option to config.h. Thanks to: nall@themountaingoats.net
+ (Jonathan Nall) in bug #9326. This is applied to ppc, sparc and sparc64
+
+ 23 Sep 2002; Arcady Genkin <agenkin@thpoon.com> xine-d5d-0.2.7-r1.ebuild :
+
+ Applied patch by Josh McKinney <gentoo3281@bitfed.com> that fixes
+ compatibility issues with xine-0.9.13.
+
+ 08 Jul 2002; Brandon Low <lostlogic@gentoo.org> xine-d5d-0.2.7.ebuild :
+
+ New version, updated captain css mirror location.
+
+*xine-d5d-0.2.6 (03 Jul 2002)
+
+ 03 Jul 2002; Brandon Low <lostlogic@gentoo.org> xine-d5d-0.2.6.ebuild :
+
+ New version, everyone thanks Captain CSS if you see him :)
+
+*xine-d5d-0.2.4 (2 May 2002)
+
+ 2 May 2002; Arcady Genkin <agenkin@thpoon.com> xine-d5d-0.2.4.ebuild :
+
+ Update to latest version.
+
+*xine-d5d-0.2.3 (30 Apr 2002)
+
+ 30 April 2002; Arcady Genkin <agenkin@thpoon.com> xine-d5d-0.2.3.ebuild :
+
+ Initial version, adopted from the ebuild for d4d plugin, submitted by
+ Brandon Low <lostlogic@lostlogicx.com>.
diff --git a/media-plugins/xine-d5d/files/digest-xine-d5d-0.2.7 b/media-plugins/xine-d5d/files/digest-xine-d5d-0.2.7
new file mode 100644
index 000000000000..815f66836221
--- /dev/null
+++ b/media-plugins/xine-d5d/files/digest-xine-d5d-0.2.7
@@ -0,0 +1 @@
+MD5 73b7c4c1b3068c272d977495defd0aec d5d027.txt 391270
diff --git a/media-plugins/xine-d5d/files/digest-xine-d5d-0.2.7-r1 b/media-plugins/xine-d5d/files/digest-xine-d5d-0.2.7-r1
new file mode 100644
index 000000000000..815f66836221
--- /dev/null
+++ b/media-plugins/xine-d5d/files/digest-xine-d5d-0.2.7-r1
@@ -0,0 +1 @@
+MD5 73b7c4c1b3068c272d977495defd0aec d5d027.txt 391270
diff --git a/media-plugins/xine-d5d/files/xine-d5d-0.2.7-r1-gentoo.diff b/media-plugins/xine-d5d/files/xine-d5d-0.2.7-r1-gentoo.diff
new file mode 100644
index 000000000000..a2293c42f8d9
--- /dev/null
+++ b/media-plugins/xine-d5d/files/xine-d5d-0.2.7-r1-gentoo.diff
@@ -0,0 +1,14 @@
+diff -urN xine-d5d-0.2.7.orig/src/input_dvd.c xine-d5d-0.2.7/src/input_dvd.c
+--- xine-d5d-0.2.7.orig/src/input_dvd.c Fri Sep 20 00:50:43 2002
++++ xine-d5d-0.2.7/src/input_dvd.c Fri Sep 20 00:52:34 2002
+@@ -1050,7 +1050,8 @@
+ dvdnav_input_plugin_t *this;
+ config_values_t *config = xine->config;
+
+- if (iface != 7) {
++/* Josh McKinney 20 Sept 2002 - added api ver 8 to support xine 0.9.13 */
++ if (iface != 7 && iface != 8) {
+ printf("d5d input plugin doesn't support plugin API version %d.\n"
+ "PLUGIN DISABLED.\n"
+ "This means there's a version mismatch between xine and this input"
+
diff --git a/media-plugins/xine-d5d/xine-d5d-0.2.7-r1.ebuild b/media-plugins/xine-d5d/xine-d5d-0.2.7-r1.ebuild
new file mode 100644
index 000000000000..4ab7977cf44f
--- /dev/null
+++ b/media-plugins/xine-d5d/xine-d5d-0.2.7-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xine-d5d/xine-d5d-0.2.7-r1.ebuild,v 1.1 2002/11/20 16:04:51 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Captain CSS menu plugin for the xine media player"
+HOMEPAGE="http://members.fortunecity.de/captaincss/"
+SRC_URI="http://members.fortunecity.de/captaincss/d5d${PV//./}.txt"
+
+DEPEND=">=media-libs/xine-lib-0.9.12"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="x86 ppc"
+
+src_unpack() {
+
+ cp ${DISTDIR}/${A} . && chmod +x ${A} && ./${A} && \
+ tar zxf ${WORKDIR}/${P}.tgz || \
+ die "Unpacking failed"
+
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff || die "Patching failed"
+
+}
+
+src_compile() {
+
+ econf
+
+ if use ppc || use sparc || use sparc64
+ then
+ einfo "Configuring for Big-Endian Architecture"
+ echo "#define WORDS_BIGENDIAN" >> config.h
+ fi
+
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL README NEWS
+}
diff --git a/media-plugins/xine-d5d/xine-d5d-0.2.7.ebuild b/media-plugins/xine-d5d/xine-d5d-0.2.7.ebuild
new file mode 100644
index 000000000000..947f78f40472
--- /dev/null
+++ b/media-plugins/xine-d5d/xine-d5d-0.2.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xine-d5d/xine-d5d-0.2.7.ebuild,v 1.1 2002/11/20 16:04:51 azarah Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Captain CSS menu plugin for the xine media player"
+HOMEPAGE="http://members.fortunecity.de/captaincss/"
+SRC_URI="http://members.fortunecity.de/captaincss/d5d${PV//./}.txt"
+
+DEPEND="~media-libs/xine-lib-0.9.12"
+
+SLOT="0"
+LICENSE="LGPL"
+KEYWORDS="x86 ppc"
+
+src_unpack() {
+
+ cp ${DISTDIR}/${A} . && chmod +x ${A} && ./${A} && \
+ tar zxf ${WORKDIR}/${P}.tgz || \
+ die "Unpacking failed"
+
+}
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL README NEWS
+}