summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2012-10-19 13:25:39 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2012-10-19 13:25:39 +0000
commitfcdd5ad447bdd47d97e2ac07c6d9b1257365e2b4 (patch)
tree7238a3e156cf353eadb93d69750f71a1b9d27fac /media-plugins/gst-plugins-x
parentfix bug 243886, thanks to Michael Weber (xmw@gentoo.org) for providing a patch (diff)
downloadgentoo-2-fcdd5ad447bdd47d97e2ac07c6d9b1257365e2b4.tar.gz
gentoo-2-fcdd5ad447bdd47d97e2ac07c6d9b1257365e2b4.tar.bz2
gentoo-2-fcdd5ad447bdd47d97e2ac07c6d9b1257365e2b4.zip
Prevent unnecessary linking with libICE, libSM. Fixes #368753.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 29C3E2EC)
Diffstat (limited to 'media-plugins/gst-plugins-x')
-rw-r--r--media-plugins/gst-plugins-x/ChangeLog8
-rw-r--r--media-plugins/gst-plugins-x/gst-plugins-x-0.10.35-r1.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/media-plugins/gst-plugins-x/ChangeLog b/media-plugins/gst-plugins-x/ChangeLog
index d89eee1641ae..ae82329b1561 100644
--- a/media-plugins/gst-plugins-x/ChangeLog
+++ b/media-plugins/gst-plugins-x/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/gst-plugins-x
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-x/ChangeLog,v 1.125 2012/05/12 18:10:33 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-x/ChangeLog,v 1.126 2012/10/19 13:25:39 ford_prefect Exp $
+
+*gst-plugins-x-0.10.35-r1 (19 Oct 2012)
+
+ 19 Oct 2012; Arun Raghavan <ford_prefect@gentoo.org>
+ +gst-plugins-x-0.10.35-r1.ebuild:
+ Prevent unnecessary linking with libICE, libSM. Fixes #368753.
12 May 2012; Alexis Ballier <aballier@gentoo.org>
gst-plugins-x-0.10.35.ebuild:
diff --git a/media-plugins/gst-plugins-x/gst-plugins-x-0.10.35-r1.ebuild b/media-plugins/gst-plugins-x/gst-plugins-x-0.10.35-r1.ebuild
new file mode 100644
index 000000000000..4f313c82913b
--- /dev/null
+++ b/media-plugins/gst-plugins-x/gst-plugins-x-0.10.35-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gst-plugins-x/gst-plugins-x-0.10.35-r1.ebuild,v 1.1 2012/10/19 13:25:39 ford_prefect Exp $
+
+EAPI=3
+
+inherit gst-plugins-base
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+# xshm is a compile time option of ximage, which is in libXext
+GST_PLUGINS_BUILD="x xshm"
+GST_PLUGINS_BUILD_DIR="ximage"
+
+src_prepare() {
+ gst-plugins-base_src_prepare
+
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure
+}