summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2015-01-18 20:01:46 +0000
committerMarkus Meier <maekke@gentoo.org>2015-01-18 20:01:46 +0000
commitd990b90972ba282eb81f7e5cbf61437c8490ea87 (patch)
treecec404674037008b7d63960c6d261ec4d146f718 /media-libs
parentFix ChangeLog, sign (diff)
downloadgentoo-2-d990b90972ba282eb81f7e5cbf61437c8490ea87.tar.gz
gentoo-2-d990b90972ba282eb81f7e5cbf61437c8490ea87.tar.bz2
gentoo-2-d990b90972ba282eb81f7e5cbf61437c8490ea87.zip
version bump for bug #527204: depend dev-libs/gobject-introspection for bug #469202, add subslot operator dep for media-gfx/exiv2 for bug #536944, make python support optional, update HOMEPAGE
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 072AD062)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gexiv2/ChangeLog11
-rw-r--r--media-libs/gexiv2/gexiv2-0.10.2.ebuild51
2 files changed, 60 insertions, 2 deletions
diff --git a/media-libs/gexiv2/ChangeLog b/media-libs/gexiv2/ChangeLog
index d6b1f6b85ba1..7ab263b02ab9 100644
--- a/media-libs/gexiv2/ChangeLog
+++ b/media-libs/gexiv2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/gexiv2
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/ChangeLog,v 1.28 2014/11/29 13:34:33 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/ChangeLog,v 1.29 2015/01/18 20:01:46 maekke Exp $
+
+*gexiv2-0.10.2 (18 Jan 2015)
+
+ 18 Jan 2015; Markus Meier <maekke@gentoo.org> +gexiv2-0.10.2.ebuild:
+ version bump for bug #527204: depend dev-libs/gobject-introspection for bug
+ #469202, add subslot operator dep for media-gfx/exiv2 for bug #536944, make
+ python support optional, update HOMEPAGE
29 Nov 2014; Pacho Ramos <pacho@gentoo.org> gexiv2-0.6.1.ebuild:
Support python 3.4
diff --git a/media-libs/gexiv2/gexiv2-0.10.2.ebuild b/media-libs/gexiv2/gexiv2-0.10.2.ebuild
new file mode 100644
index 000000000000..e349909205a9
--- /dev/null
+++ b/media-libs/gexiv2/gexiv2-0.10.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gexiv2/gexiv2-0.10.2.ebuild,v 1.1 2015/01/18 20:01:46 maekke Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit eutils multilib python-r1 toolchain-funcs versionator
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="GObject-based wrapper around the Exiv2 library"
+HOMEPAGE="https://wiki.gnome.org/Projects/gexiv2"
+SRC_URI="mirror://gnome/sources/${PN}/${MY_PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="introspection python static-libs"
+
+REQUIRED_USE="python? ( introspection ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.1:2
+ >=media-gfx/exiv2-0.21:0=
+ introspection? ( dev-libs/gobject-introspection )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ tc-export CXX
+}
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIB="$(get_libdir)" install
+ dodoc AUTHORS NEWS README THANKS
+
+ if use python ; then
+ python_moduleinto gi/overrides/
+ python_foreach_impl python_domodule GExiv2.py
+ fi
+
+ use static-libs || prune_libtool_files --modules
+}