summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2004-06-24 16:45:01 +0000
committerBryan Stine <battousai@gentoo.org>2004-06-24 16:45:01 +0000
commitba5fe947e5263fd3cce31026171f5a26863549f0 (patch)
tree1265978bf0c4cce2ffdae0bcc2663b428b2be49b /media-libs
parentstable on x86, QA (Manifest recommit) (diff)
downloadgentoo-2-ba5fe947e5263fd3cce31026171f5a26863549f0.tar.gz
gentoo-2-ba5fe947e5263fd3cce31026171f5a26863549f0.tar.bz2
gentoo-2-ba5fe947e5263fd3cce31026171f5a26863549f0.zip
Fix build with 2.6 headers. Closes bug #54999.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/glide-v3/ChangeLog8
-rw-r--r--media-libs/glide-v3/files/glide-v3-3.10-2.6-headers-fix.patch75
-rw-r--r--media-libs/glide-v3/glide-v3-3.10-r4.ebuild3
3 files changed, 84 insertions, 2 deletions
diff --git a/media-libs/glide-v3/ChangeLog b/media-libs/glide-v3/ChangeLog
index d81fa00b4509..e4a21d36963c 100644
--- a/media-libs/glide-v3/ChangeLog
+++ b/media-libs/glide-v3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/glide-v3
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/glide-v3/ChangeLog,v 1.15 2004/06/14 19:53:17 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glide-v3/ChangeLog,v 1.16 2004/06/24 16:45:01 battousai Exp $
+
+ 24 Jun 2004; Bryan Stine <battousai@gentoo.org>;
+ +files/glide-v3-3.10-2.6-headers-fix.patch, glide-v3-3.10-r4.ebuild:
+ New patch to fix building against 2.6 kernel headers. Thanks to Jan
+ Drugowitsch <jdrugo@gmx.at> for reporting and providing the patch. This closes
+ bug 54999.
14 Jun 2004; Donnie Berkholz <spyderous@gentoo.org>; +metadata.xml:
Add metadata.
diff --git a/media-libs/glide-v3/files/glide-v3-3.10-2.6-headers-fix.patch b/media-libs/glide-v3/files/glide-v3-3.10-2.6-headers-fix.patch
new file mode 100644
index 000000000000..9b6ab3fcd6a5
--- /dev/null
+++ b/media-libs/glide-v3/files/glide-v3-3.10-2.6-headers-fix.patch
@@ -0,0 +1,75 @@
+--- swlibs/newpci/pcilib/fxlinux.c.orig 2004-06-24 15:00:06.485686968 +0100
++++ swlibs/newpci/pcilib/fxlinux.c 2004-06-24 15:19:57.414638248 +0100
+@@ -129,7 +129,7 @@
+ default:
+ return 0;
+ }
+- if (ioctl(linuxDevFd, _IOR('3', 3, sizeof(struct pioData)), &desc)==-1)
++ if (ioctl(linuxDevFd, _IOR('3', 3, struct pioData), &desc)==-1)
+ return 0;
+ switch (size) {
+ case 1:
+@@ -153,7 +153,7 @@
+ desc.size=size;
+ desc.device=device;
+ desc.value=&data;
+- if (ioctl(linuxDevFd, _IOW('3', 4, sizeof(struct pioData)), &desc)==-1)
++ if (ioctl(linuxDevFd, _IOW('3', 4, struct pioData), &desc)==-1)
+ return FXFALSE;
+ return FXTRUE;
+ }
+@@ -253,7 +253,7 @@
+ desc.size=sizeof(tmp);
+ desc.value=&tmp;
+ /* fprintf(stderr, "Read byte desc at %x tmp at %x\n", &desc, &tmp); */
+- ioctl(linuxDevFd, _IOR(0, 0, sizeof(struct pioData)), &desc);
++ ioctl(linuxDevFd, _IOR(0, 0, struct pioData), &desc);
+ /* fprintf(stderr, "Got byte %d versus %d\n", tmp, inb(port)); */
+ return tmp;
+ }
+@@ -273,7 +273,7 @@
+ desc.size=sizeof(tmp);
+ desc.value=&tmp;
+ /* fprintf(stderr, "Read word desc at %x tmp at %x\n", &desc, &tmp); */
+- ioctl(linuxDevFd, _IOR(0, 0, sizeof(struct pioData)), &desc);
++ ioctl(linuxDevFd, _IOR(0, 0, struct pioData), &desc);
+ /* fprintf(stderr, "Got word %d versus %d\n", tmp, inw(port)); */
+ return tmp;
+ }
+@@ -293,7 +293,7 @@
+ desc.size=sizeof(tmp);
+ desc.value=&tmp;
+ /* fprintf(stderr, "Read long desc at %x tmp at %x\n", &desc, &tmp); */
+- ioctl(linuxDevFd, _IOR(0, 0, sizeof(struct pioData)), &desc);
++ ioctl(linuxDevFd, _IOR(0, 0, struct pioData), &desc);
+ /* fprintf(stderr, "Got long %x versus %x\n", tmp, inl(port)); */
+ return tmp;
+ }
+@@ -311,7 +311,7 @@
+ desc.port=port;
+ desc.size=sizeof(data);
+ desc.value=&data;
+- return ioctl(linuxDevFd, _IOW(0, 1, sizeof(struct pioData)), &desc)!=-1;
++ return ioctl(linuxDevFd, _IOW(0, 1, struct pioData), &desc)!=-1;
+ }
+
+ static FxBool
+@@ -327,7 +327,7 @@
+ desc.port=port;
+ desc.size=sizeof(data);
+ desc.value=&data;
+- return ioctl(linuxDevFd, _IOW(0, 1, sizeof(struct pioData)), &desc)!=-1;
++ return ioctl(linuxDevFd, _IOW(0, 1, struct pioData), &desc)!=-1;
+ }
+
+ static FxBool
+@@ -343,7 +343,7 @@
+ desc.port=port;
+ desc.size=sizeof(data);
+ desc.value=&data;
+- return ioctl(linuxDevFd, _IOW(0, 1, sizeof(struct pioData)), &desc)!=-1;
++ return ioctl(linuxDevFd, _IOW(0, 1, struct pioData), &desc)!=-1;
+ }
+
+ static FxBool
+
diff --git a/media-libs/glide-v3/glide-v3-3.10-r4.ebuild b/media-libs/glide-v3/glide-v3-3.10-r4.ebuild
index 10a2e7d24e50..6f93e861ba76 100644
--- a/media-libs/glide-v3/glide-v3-3.10-r4.ebuild
+++ b/media-libs/glide-v3/glide-v3-3.10-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/glide-v3/glide-v3-3.10-r4.ebuild,v 1.5 2004/06/14 19:51:54 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glide-v3/glide-v3-3.10-r4.ebuild,v 1.6 2004/06/24 16:45:01 battousai Exp $
# NOTE: Do NOT build this with optimizations, as it will make this package
# unstable!!!!
@@ -41,6 +41,7 @@ src_unpack() {
cd ${S}
epatch ${WORKDIR}/${P}-fixes.patch
+ epatch ${FILESDIR}/${P}-2.6-headers-fix.patch
export WANT_AUTOMAKE="1.4" WANT_AUTOCONF="2.5"
libtoolize -f && aclocal && automake && autoconf
}