summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2013-04-02 19:40:10 +0000
committerThomas Sachau <tommy@gentoo.org>2013-04-02 19:40:10 +0000
commit5c0e05bfddc9264e522bf4423a6fb71238448235 (patch)
tree00b473898cc97841ebc0e6e0b4fd70e0251fc629 /media-libs
parentRespect AR. Version bump. (diff)
downloadgentoo-2-5c0e05bfddc9264e522bf4423a6fb71238448235.tar.gz
gentoo-2-5c0e05bfddc9264e522bf4423a6fb71238448235.tar.bz2
gentoo-2-5c0e05bfddc9264e522bf4423a6fb71238448235.zip
Add USE flag for vlc player backend, fixes bug 464200
(Portage version: 2.2.0_alpha170-r1/cvs/Linux x86_64, signed Manifest commit with key 0x35899067)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/emotion/ChangeLog10
-rw-r--r--media-libs/emotion/emotion-1.7.4-r1.ebuild49
-rw-r--r--media-libs/emotion/metadata.xml3
3 files changed, 60 insertions, 2 deletions
diff --git a/media-libs/emotion/ChangeLog b/media-libs/emotion/ChangeLog
index 4fc3ef740318..611d9f50d53e 100644
--- a/media-libs/emotion/ChangeLog
+++ b/media-libs/emotion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/emotion
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/emotion/ChangeLog,v 1.9 2012/12/27 16:41:19 tommy Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/emotion/ChangeLog,v 1.10 2013/04/02 19:40:10 tommy Exp $
+
+*emotion-1.7.4-r1 (02 Apr 2013)
+
+ 02 Apr 2013; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +emotion-1.7.4-r1.ebuild, metadata.xml:
+ Add USE flag for vlc player backend, fixes bug 464200
27 Dec 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> emotion-1.7.4.ebuild:
Fix configure options for USE=doc
diff --git a/media-libs/emotion/emotion-1.7.4-r1.ebuild b/media-libs/emotion/emotion-1.7.4-r1.ebuild
new file mode 100644
index 000000000000..86cca377adaa
--- /dev/null
+++ b/media-libs/emotion/emotion-1.7.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/emotion/emotion-1.7.4-r1.ebuild,v 1.1 2013/04/02 19:40:10 tommy Exp $
+
+inherit enlightenment
+
+DESCRIPTION="video libraries for e17"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer static-libs vlc xine"
+
+DEPEND=">=media-libs/evas-1.7.4
+ >=media-libs/edje-1.7.4
+ >=dev-libs/ecore-1.7.4
+ >=dev-libs/eeze-1.7.4
+ vlc? ( media-video/vlc )
+ xine? ( >=media-libs/xine-lib-1.1.1 )
+ !gstreamer? ( !vlc? ( !xine? ( >=media-libs/xine-lib-1.1.1 ) ) )
+ gstreamer? (
+ =media-libs/gstreamer-0.10*
+ =media-libs/gst-plugins-good-0.10*
+ =media-plugins/gst-plugins-ffmpeg-0.10*
+ )"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ if ! use vlc && ! use xine && ! use gstreamer ; then
+ export MY_ECONF="--enable-xine --disable-gstreamer --disable-generic-vlc"
+ else
+ export MY_ECONF="
+ $(use_enable xine) \
+ $(use_enable gstreamer) \
+ $(use_enable vlc generic-vlc)
+ "
+ fi
+
+ MY_ECONF+="
+ $(use_enable doc)
+ "
+
+ if use gstreamer ; then
+ addpredict "/root/.gconfd"
+ addpredict "/root/.gconf"
+ fi
+
+ enlightenment_src_compile
+}
diff --git a/media-libs/emotion/metadata.xml b/media-libs/emotion/metadata.xml
index 99165add909f..282424f678d2 100644
--- a/media-libs/emotion/metadata.xml
+++ b/media-libs/emotion/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>enlightenment</herd>
+<use>
+ <flag name='vlc'>Enable support for the <pkg>media-video/vlc</pkg> player backend</flag>
+</use>
</pkgmetadata>