summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2014-10-27 11:25:23 +0000
committerAlfredo Tupone <tupone@gentoo.org>2014-10-27 11:25:23 +0000
commit4d5a0dcdc3e208d02fa1bb42765840e24da468d0 (patch)
treeebc79793948d1047fd74e21907c00a5431df4a9a /media-libs
parentVersion bump (diff)
downloadgentoo-2-4d5a0dcdc3e208d02fa1bb42765840e24da468d0.tar.gz
gentoo-2-4d5a0dcdc3e208d02fa1bb42765840e24da468d0.tar.bz2
gentoo-2-4d5a0dcdc3e208d02fa1bb42765840e24da468d0.zip
Fix test. Bug #526558
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/cal3d/ChangeLog10
-rw-r--r--media-libs/cal3d/cal3d-0.11.0-r1.ebuild46
-rw-r--r--media-libs/cal3d/files/cal3d-0.11.0-tests.patch11
3 files changed, 42 insertions, 25 deletions
diff --git a/media-libs/cal3d/ChangeLog b/media-libs/cal3d/ChangeLog
index 65bd62677b4f..1a631a4e5891 100644
--- a/media-libs/cal3d/ChangeLog
+++ b/media-libs/cal3d/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/cal3d
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/cal3d/ChangeLog,v 1.35 2012/06/29 11:48:28 tupone Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cal3d/ChangeLog,v 1.36 2014/10/27 11:25:23 tupone Exp $
+
+ 27 Oct 2014; Alfredo Tupone <tupone@gentoo.org> cal3d-0.11.0-r1.ebuild,
+ +files/cal3d-0.11.0-tests.patch:
+ Fix test. Bug #526558 by flameeyes@gentoo.org
+ Migrating to EAPI 5
+ removing base eclass usage
29 Jun 2012; Tupone Alfredo <tupone@gentoo.org> cal3d-0.11.0-r1.ebuild,
+files/cal3d-0.11.0-verbose.patch:
diff --git a/media-libs/cal3d/cal3d-0.11.0-r1.ebuild b/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
index 766c9bc1bdc4..3107247c53f4 100644
--- a/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
+++ b/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/cal3d/cal3d-0.11.0-r1.ebuild,v 1.12 2012/06/29 11:48:28 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/cal3d/cal3d-0.11.0-r1.ebuild,v 1.13 2014/10/27 11:25:23 tupone Exp $
-EAPI=2
-inherit eutils base autotools
+EAPI=5
+inherit eutils autotools
DESCRIPTION="Cal3D is a skeletal based character animation library"
HOMEPAGE="http://home.gna.org/cal3d"
@@ -21,37 +21,37 @@ DEPEND="doc? (
RDEPEND=""
src_prepare() {
- DOCS=( AUTHORS ChangeLog README TODO )
- use doc && HTML_DOCS=( docs/html/api docs/html/guide )
- PATCHES=( "${FILESDIR}"/${P}-gcc43.patch
- "${FILESDIR}"/${P}-verbose.patch )
-
- base_src_prepare
- if use doc; then
- sed -i \
- -e "s:db2html:docbook2html:g" \
- configure.in \
- docs/Makefile.am \
- || die "sed for doc failed"
- eautoreconf
- fi
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-tests.patch \
+ "${FILESDIR}"/${P}-verbose.patch
+ sed -i \
+ -e "s:db2html:docbook2html:g" \
+ configure.in \
+ docs/Makefile.am \
+ || die "sed for doc failed"
+ eautoreconf
}
src_configure() {
econf \
$(use_enable debug) \
- $(use_enable 16bit-indices) \
- || die
+ $(use_enable 16bit-indices)
}
src_compile() {
- base_src_compile
+ emake
if use doc; then
cd docs
- emake doc-api || die "Failed making doc-api"
- emake doc-guide || die "Failed making doc-guide"
+ emake doc-api
+ emake doc-guide
mkdir -p html/{guide,api}
mv *.{html,gif} html/guide/
mv api/html/* html/api/
fi
}
+
+src_install() {
+ default
+ use doc && dohtml -r docs/html/api docs/html/guide
+}
diff --git a/media-libs/cal3d/files/cal3d-0.11.0-tests.patch b/media-libs/cal3d/files/cal3d-0.11.0-tests.patch
new file mode 100644
index 000000000000..3a6754f40155
--- /dev/null
+++ b/media-libs/cal3d/files/cal3d-0.11.0-tests.patch
@@ -0,0 +1,11 @@
+--- tests/Makefile.am.old 2014-10-27 12:14:44.534607920 +0100
++++ tests/Makefile.am 2014-10-27 12:16:00.825891248 +0100
+@@ -14,7 +14,7 @@
+ EXTRA_DIST = \
+ $(wildcard cal3d_converter/base.??f)
+
+-TESTS_ENVIRONMENT = sh ./run
++LOG_COMPILER = sh ./run
+ TESTS = converter/skeleton converter/mesh converter/material converter/animation
+
+ .PHONY: ${TESTS}