summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2014-08-14 00:15:23 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2014-08-14 00:15:23 +0000
commit0f836bc916c682dc3f71c2671aed55149f8eba7c (patch)
tree0fbae187be6af2b1a9ef56f1bd5ac4184dc554f6 /media-libs
parentStable for HPPA (bug #519518). (diff)
downloadgentoo-2-0f836bc916c682dc3f71c2671aed55149f8eba7c.tar.gz
gentoo-2-0f836bc916c682dc3f71c2671aed55149f8eba7c.tar.bz2
gentoo-2-0f836bc916c682dc3f71c2671aed55149f8eba7c.zip
Fix patch, bug 477114, Move to EAPI 5.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key B1E955DB)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/quarter/ChangeLog8
-rw-r--r--media-libs/quarter/files/quarter-1.0.0-gcc44.patch6
-rw-r--r--media-libs/quarter/quarter-1.0.0-r1.ebuild37
3 files changed, 22 insertions, 29 deletions
diff --git a/media-libs/quarter/ChangeLog b/media-libs/quarter/ChangeLog
index b2458984b9d3..8bd93734fd4a 100644
--- a/media-libs/quarter/ChangeLog
+++ b/media-libs/quarter/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/quarter
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/quarter/ChangeLog,v 1.6 2013/03/02 21:48:45 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/quarter/ChangeLog,v 1.7 2014/08/14 00:15:23 reavertm Exp $
+
+ 14 Aug 2014; Maciej Mrozowski <reavertm@gentoo.org>
+ files/quarter-1.0.0-gcc44.patch, quarter-1.0.0-r1.ebuild:
+ Fix patch, bug 477114, Move to EAPI 5.
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> quarter-1.0.0-r1.ebuild:
Move Qt dependencies to the new category
diff --git a/media-libs/quarter/files/quarter-1.0.0-gcc44.patch b/media-libs/quarter/files/quarter-1.0.0-gcc44.patch
index 9c3a44c1b513..e0f422b4cd36 100644
--- a/media-libs/quarter/files/quarter-1.0.0-gcc44.patch
+++ b/media-libs/quarter/files/quarter-1.0.0-gcc44.patch
@@ -1,6 +1,6 @@
-diff -ru ../Quarter-1.0.0/src/Quarter/Quarter.cpp ./src/Quarter/Quarter.cpp
---- ../Quarter-1.0.0/src/Quarter/Quarter.cpp 2009-01-26 22:47:07.000000000 +0100
-+++ ./src/Quarter/Quarter.cpp 2010-05-18 16:17:25.246880238 +0200
+diff -ruN Quarter-1.0.0/src/Quarter/Quarter.cpp my/src/Quarter/Quarter.cpp
+--- Quarter-1.0.0/src/Quarter/Quarter.cpp 2009-01-26 22:47:07.000000000 +0100
++++ my/src/Quarter/Quarter.cpp 2014-08-14 01:48:45.019728780 +0200
@@ -123,6 +123,7 @@
\subpage examiner
*/
diff --git a/media-libs/quarter/quarter-1.0.0-r1.ebuild b/media-libs/quarter/quarter-1.0.0-r1.ebuild
index d6d3ce6cf0f6..41f22741da5e 100644
--- a/media-libs/quarter/quarter-1.0.0-r1.ebuild
+++ b/media-libs/quarter/quarter-1.0.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/quarter/quarter-1.0.0-r1.ebuild,v 1.5 2013/03/02 21:48:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/quarter/quarter-1.0.0-r1.ebuild,v 1.6 2014/08/14 00:15:23 reavertm Exp $
-EAPI="2"
+EAPI=5
-inherit base
+inherit autotools-utils
MY_P="${P/q/Q}"
@@ -37,24 +37,13 @@ PATCHES=(
DOCS=(AUTHORS NEWS README)
src_configure() {
- # Bug 336008
- MAKEOPTS=-j1
-
- econf \
- htmldir="${ROOT}usr/share/doc/${PF}/html" \
- --enable-pkgconfig \
- --enable-shared \
- --with-coin \
- $(use_enable debug) \
- $(use_enable debug symbols) \
- $(use_enable doc html) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- base_src_install
-
- # Do not install .la files
- rm -f "${D}"/usr/lib*/qt4/plugins/designer/*.{la,a}
- use static-libs || rm -f "${D}"/usr/lib*/*.la
+ local myeconfargs=(
+ htmldir="${ROOT}usr/share/doc/${PF}/html"
+ --enable-pkgconfig
+ --with-coin
+ $(use_enable debug)
+ $(use_enable debug symbols)
+ $(use_enable doc html)
+ )
+ autotools-utils_src_configure
}