summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-29 21:37:28 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-29 21:37:28 +0000
commit032bda6343686f78f8b19b77c480bb218f862f88 (patch)
treeb4f9007b7b9c94fabc2f137496357be7f6ffb3d4 /media-libs/x264
parentamd64/x86 stable, bug #275179 (diff)
downloadgentoo-2-032bda6343686f78f8b19b77c480bb218f862f88.tar.gz
gentoo-2-032bda6343686f78f8b19b77c480bb218f862f88.tar.bz2
gentoo-2-032bda6343686f78f8b19b77c480bb218f862f88.zip
bump a new snapshot
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog8
-rw-r--r--media-libs/x264/x264-0.0.20090629.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 69393cd24f7f..178291f39275 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.21 2009/06/29 21:26:53 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.22 2009/06/29 21:37:28 aballier Exp $
+
+*x264-0.0.20090629 (29 Jun 2009)
+
+ 29 Jun 2009; Alexis Ballier <aballier@gentoo.org>
+ +x264-0.0.20090629.ebuild:
+ bump a new snapshot
29 Jun 2009; Alexis Ballier <aballier@gentoo.org>
-files/x264-onlylib.patch, -x264-0.0.20070924.ebuild,
diff --git a/media-libs/x264/x264-0.0.20090629.ebuild b/media-libs/x264/x264-0.0.20090629.ebuild
new file mode 100644
index 000000000000..642e9e0f5975
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20090629.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20090629.ebuild,v 1.1 2009/06/29 21:37:28 aballier Exp $
+
+EAPI="1"
+inherit multilib eutils toolchain-funcs versionator
+
+MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +threads"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-nostrip.patch"
+ epatch "${FILESDIR}/${PN}-onlylib-20090408.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ ./configure --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --enable-pic --enable-shared \
+ "--extra-cflags=${CFLAGS}" \
+ "--extra-ldflags=${LDFLAGS}" \
+ "--extra-asflags=${ASFLAGS}" \
+ "--host=${CHOST}" \
+ $(use_enable threads pthread) \
+ ${myconf} \
+ --disable-mp4-output \
+ || die "configure failed"
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}
+
+pkg_postinst() {
+ elog "Please note that this package now only installs"
+ elog "${PN} libraries. In order to have the encoder,"
+ elog "please emerge media-video/x264-encoder."
+}