summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-02 08:59:07 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-02 08:59:07 +0000
commit6fa5bfd8c1b90aa46204cdf8f52c2cfd292d3a72 (patch)
tree5b06ee752d3ff0fe2fed8f15c857f7f792ea97b5 /media-libs/sg
parentDrop unneeded patch. (diff)
downloadgentoo-2-6fa5bfd8c1b90aa46204cdf8f52c2cfd292d3a72.tar.gz
gentoo-2-6fa5bfd8c1b90aa46204cdf8f52c2cfd292d3a72.tar.bz2
gentoo-2-6fa5bfd8c1b90aa46204cdf8f52c2cfd292d3a72.zip
Fixed automagic doxygen usage
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/sg')
-rw-r--r--media-libs/sg/ChangeLog6
-rw-r--r--media-libs/sg/files/1.4-doc.patch20
-rw-r--r--media-libs/sg/sg-1.4.ebuild21
3 files changed, 40 insertions, 7 deletions
diff --git a/media-libs/sg/ChangeLog b/media-libs/sg/ChangeLog
index b81dad342a74..3a14d421182f 100644
--- a/media-libs/sg/ChangeLog
+++ b/media-libs/sg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/sg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sg/ChangeLog,v 1.1 2010/11/01 13:59:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sg/ChangeLog,v 1.2 2010/11/02 08:59:07 jlec Exp $
+
+ 02 Nov 2010; Justin Lecher <jlec@gentoo.org> +files/1.4-doc.patch,
+ sg-1.4.ebuild:
+ Fixed automagic doxygen usage
*sg-1.4 (01 Nov 2010)
diff --git a/media-libs/sg/files/1.4-doc.patch b/media-libs/sg/files/1.4-doc.patch
new file mode 100644
index 000000000000..cfc1b21b20cb
--- /dev/null
+++ b/media-libs/sg/files/1.4-doc.patch
@@ -0,0 +1,20 @@
+diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
+index 3ee562c..7f424e8 100644
+--- a/doc/doxygen/Makefile.am
++++ b/doc/doxygen/Makefile.am
+@@ -29,13 +29,11 @@
+ ## Author: Michael Holst
+ ## ###########################################################################
+
+-docdir = @prefix@/doc/sg
+-
+ doc_DATA = sg_doc
+
+ sg_doc:
+ $(doxygen_path) $(top_srcdir)/doc/doxygen/sg.dox
+
+ install-docDATA:
+- mkdir -p $(docdir)
+- cp -r ../api $(docdir)/
++ mkdir -p $(DESTDIR)/@docdir@
++ cp -r ../api $(DESTDIR)/@docdir@/
diff --git a/media-libs/sg/sg-1.4.ebuild b/media-libs/sg/sg-1.4.ebuild
index a23f0727e2cd..0969b839fd96 100644
--- a/media-libs/sg/sg-1.4.ebuild
+++ b/media-libs/sg/sg-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sg/sg-1.4.ebuild,v 1.1 2010/11/01 13:59:49 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sg/sg-1.4.ebuild,v 1.2 2010/11/02 08:59:07 jlec Exp $
EAPI="3"
@@ -13,7 +13,7 @@ SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-2"
-IUSE="opengl"
+IUSE="doc opengl"
RDEPEND="
dev-libs/maloc
@@ -22,13 +22,19 @@ RDEPEND="
virtual/glu
virtual/opengl
)"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen )"
S="${WORKDIR}"/${PN}
src_prepare() {
rm src/{gl,glu,glw} -rf
- epatch "${FILESDIR}"/${PV}-opengl.patch
+ epatch \
+ "${FILESDIR}"/${PV}-opengl.patch \
+ "${FILESDIR}"/${PV}-doc.patch
eautoreconf
}
@@ -50,12 +56,15 @@ src_configure() {
export FETK_GL_INCLUDE="${sg_include}"/GL
export FETK_MOTIF_INCLUDE="${sg_include}"
+ use doc || myconf="${myconf} --with-doxygen= --with-dot="
+
use opengl && myconf="${myconf} --enable-glforce --enable-gluforce --enable-glwforce"
econf \
- ${myconf} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-triplet \
--enable-shared \
- --disable-triplet
+ ${myconf}
}
src_install() {