summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-04-18 21:14:59 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-04-18 21:14:59 +0000
commit46632cb1001cd67fc959d6a5521f9c1a1d67ab5e (patch)
treeef87240065550026eb14e306b3608ef04cacded2 /media-libs/sdl2-net
parentMask >=media-video/mkvtoolnix-6.9.0 waiting for qt5. (diff)
downloadgentoo-2-46632cb1001cd67fc959d6a5521f9c1a1d67ab5e.tar.gz
gentoo-2-46632cb1001cd67fc959d6a5521f9c1a1d67ab5e.tar.bz2
gentoo-2-46632cb1001cd67fc959d6a5521f9c1a1d67ab5e.zip
add multilib support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'media-libs/sdl2-net')
-rw-r--r--media-libs/sdl2-net/ChangeLog9
-rw-r--r--media-libs/sdl2-net/sdl2-net-2.0.0-r1.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/media-libs/sdl2-net/ChangeLog b/media-libs/sdl2-net/ChangeLog
index 7110be964ad5..7fbb16880532 100644
--- a/media-libs/sdl2-net/ChangeLog
+++ b/media-libs/sdl2-net/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sdl2-net
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl2-net/ChangeLog,v 1.1 2013/08/28 21:46:02 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl2-net/ChangeLog,v 1.2 2014/04/18 21:14:59 hasufell Exp $
+
+*sdl2-net-2.0.0-r1 (18 Apr 2014)
+
+ 18 Apr 2014; Julian Ospald <hasufell@gentoo.org> +sdl2-net-2.0.0-r1.ebuild:
+ add multilib support
*sdl2-net-2.0.0 (28 Aug 2013)
diff --git a/media-libs/sdl2-net/sdl2-net-2.0.0-r1.ebuild b/media-libs/sdl2-net/sdl2-net-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..a9ea249111c2
--- /dev/null
+++ b/media-libs/sdl2-net/sdl2-net-2.0.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl2-net/sdl2-net-2.0.0-r1.ebuild,v 1.1 2014/04/18 21:14:59 hasufell Exp $
+
+EAPI=5
+inherit eutils multilib-minimal
+
+MY_P=SDL2_net-${PV}
+DESCRIPTION="Simple Direct Media Layer Network Support Library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_net/index.html"
+SRC_URI="http://www.libsdl.org/projects/SDL_net/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="media-libs/libsdl2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-gui \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ dodoc {CHANGES,README}.txt
+ use static-libs || prune_libtool_files
+}