summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-14 22:19:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-14 22:19:12 +0000
commit14ec02802d391430842dde65aad5ed22b8be896e (patch)
treed0f32e3811654dbdb10f086c2869f9e40e65adbe /media-libs/raptor
parentFix for gcc-4.3.0 Bug #217622 (diff)
downloadgentoo-2-14ec02802d391430842dde65aad5ed22b8be896e.tar.gz
gentoo-2-14ec02802d391430842dde65aad5ed22b8be896e.tar.bz2
gentoo-2-14ec02802d391430842dde65aad5ed22b8be896e.zip
version bump
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'media-libs/raptor')
-rw-r--r--media-libs/raptor/ChangeLog9
-rw-r--r--media-libs/raptor/raptor-1.4.17.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/media-libs/raptor/ChangeLog b/media-libs/raptor/ChangeLog
index 2cab4cc3d48f..3d2a5d7c684c 100644
--- a/media-libs/raptor/ChangeLog
+++ b/media-libs/raptor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/raptor
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.56 2007/11/13 18:30:18 corsair Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.57 2008/04/14 22:19:12 aballier Exp $
+
+*raptor-1.4.17 (14 Apr 2008)
+
+ 14 Apr 2008; Alexis Ballier <aballier@gentoo.org> +raptor-1.4.17.ebuild:
+ version bump
13 Nov 2007; Markus Rothe <corsair@gentoo.org> raptor-1.4.16.ebuild:
Stable on ppc64; bug #198768
diff --git a/media-libs/raptor/raptor-1.4.17.ebuild b/media-libs/raptor/raptor-1.4.17.ebuild
new file mode 100644
index 000000000000..7667e70296e8
--- /dev/null
+++ b/media-libs/raptor/raptor-1.4.17.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.4.17.ebuild,v 1.1 2008/04/14 22:19:12 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="The RDF Parser Toolkit"
+HOMEPAGE="http://librdf.org/raptor"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="curl unicode xml"
+
+RDEPEND="unicode? ( >=dev-libs/glib-2 )
+ xml? ( >=dev-libs/libxml2-2.6.8 )
+ !xml? ( dev-libs/expat )
+ curl? ( net-misc/curl )
+ dev-libs/libxslt"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf=""
+
+ if use xml; then
+ myconf="${myconf} --with-xml-parser=libxml"
+ else
+ myconf="${myconf} --with-xml-parser=expat"
+ fi
+
+ if use curl; then
+ myconf="${myconf} --with-www=curl"
+ elif use xml; then
+ myconf="${myconf} --with-www=xml"
+ else
+ myconf="${myconf} --with-www=none"
+ fi
+
+ econf $(use_enable unicode nfc-check) \
+ ${myconf}
+
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS NOTICE README
+ dohtml NEWS.html README.html RELEASE.html
+}