summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-05-30 11:39:48 +0000
committerJohannes Huber <johu@gentoo.org>2015-05-30 11:39:48 +0000
commit464f9d216ad7131ee8f5399f092087049950291b (patch)
tree9f5ad807439571d6938828794e226e0704a936e0 /media-libs/qt-gstreamer
parentarm stable, bug #530238 (diff)
downloadgentoo-2-464f9d216ad7131ee8f5399f092087049950291b.tar.gz
gentoo-2-464f9d216ad7131ee8f5399f092087049950291b.tar.bz2
gentoo-2-464f9d216ad7131ee8f5399f092087049950291b.zip
Add patch to fix build with dev-libs/boost-1.57, bug #550016. Thanks to David Kredba <nheghathivhistha@gmail.com> and Heiko Becker <heirecka@exherbo.org>.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'media-libs/qt-gstreamer')
-rw-r--r--media-libs/qt-gstreamer/ChangeLog7
-rw-r--r--media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-boost157.patch34
-rw-r--r--media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r1.ebuild4
3 files changed, 43 insertions, 2 deletions
diff --git a/media-libs/qt-gstreamer/ChangeLog b/media-libs/qt-gstreamer/ChangeLog
index 7955a06030b9..c7cfcc755820 100644
--- a/media-libs/qt-gstreamer/ChangeLog
+++ b/media-libs/qt-gstreamer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/qt-gstreamer
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qt-gstreamer/ChangeLog,v 1.23 2015/03/09 11:09:27 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qt-gstreamer/ChangeLog,v 1.24 2015/05/30 11:39:48 johu Exp $
+
+ 30 May 2015; Johannes Huber <johu@gentoo.org>
+ +files/qt-gstreamer-1.2.0-boost157.patch, qt-gstreamer-1.2.0-r1.ebuild:
+ Add patch to fix build with dev-libs/boost-1.57, bug #550016. Thanks to David
+ Kredba <nheghathivhistha@gmail.com> and Heiko Becker <heirecka@exherbo.org>.
09 Mar 2015; Michael Palimaka <kensington@gentoo.org>
qt-gstreamer-1.2.0-r1.ebuild:
diff --git a/media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-boost157.patch b/media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-boost157.patch
new file mode 100644
index 000000000000..a795420e3bcc
--- /dev/null
+++ b/media-libs/qt-gstreamer/files/qt-gstreamer-1.2.0-boost157.patch
@@ -0,0 +1,34 @@
+From fbb9dc6e291eaa058f3ef1cd93711265bfbfd162 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Fri, 7 Nov 2014 00:11:02 +0100
+Subject: [PATCH] Workaround build failures with boost>=1.57 and moc
+
+Otherwise I get the following error message:
+'usr/include/boost/type_traits/detail/has_binary_operator.hp:50:
+Parse error at "BOOST_JOIN"'. See
+https://bugreports.qt-project.org/browse/QTBUG-22829 for details.
+
+The old workaround to define BOOST_TT_HAS_OPERATOR_HPP_INCLUDED
+doesn't seem to work here.
+---
+ src/QGlib/connect.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/QGlib/connect.cpp b/src/QGlib/connect.cpp
+index 9ff6fde..58a3367 100644
+--- a/src/QGlib/connect.cpp
++++ b/src/QGlib/connect.cpp
+@@ -21,8 +21,10 @@
+ #include <QtCore/QHash>
+ #include <QtCore/QMutex>
+ #include <boost/multi_index_container.hpp>
++#ifndef Q_MOC_RUN // See: https://bugreports.qt-project.org/browse/QTBUG-22829
+ #include <boost/multi_index/sequenced_index.hpp>
+ #include <boost/multi_index/ordered_index.hpp>
++#endif
+ #include <boost/multi_index/member.hpp>
+
+ namespace QGlib {
+--
+2.1.3
+
diff --git a/media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r1.ebuild b/media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r1.ebuild
index e9d060f6c9fd..f81247a04b28 100644
--- a/media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r1.ebuild
+++ b/media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r1.ebuild,v 1.2 2015/03/09 11:09:27 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/qt-gstreamer/qt-gstreamer-1.2.0-r1.ebuild,v 1.3 2015/05/30 11:39:48 johu Exp $
EAPI=5
@@ -53,6 +53,8 @@ DEPEND="
)
"
+PATCHES=( "${FILESDIR}/${P}-boost157.patch" )
+
# bug 497880
RESTRICT="test"