summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2007-01-22 19:24:29 +0000
committerAlec Warner <antarus@gentoo.org>2007-01-22 19:24:29 +0000
commitd8102fbc5734464b36b39d45ce718b75aa5a2dd4 (patch)
treee9135ef319dca9bd4ac145ee9e03105216736d0a /media-libs/qhull/files
parentStable on sparc (diff)
downloadgentoo-2-d8102fbc5734464b36b39d45ce718b75aa5a2dd4.tar.gz
gentoo-2-d8102fbc5734464b36b39d45ce718b75aa5a2dd4.tar.bz2
gentoo-2-d8102fbc5734464b36b39d45ce718b75aa5a2dd4.zip
bumpity bump for bug 108223
(Portage version: 2.1.1-r2)
Diffstat (limited to 'media-libs/qhull/files')
-rw-r--r--media-libs/qhull/files/digest-qhull-2003.13
-rw-r--r--media-libs/qhull/files/qhull-2003.1-makefile.patch65
2 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/qhull/files/digest-qhull-2003.1 b/media-libs/qhull/files/digest-qhull-2003.1
new file mode 100644
index 000000000000..5bc0af7dca21
--- /dev/null
+++ b/media-libs/qhull/files/digest-qhull-2003.1
@@ -0,0 +1,3 @@
+MD5 48228e26422bff85ef1f45df5b6e3314 qhull-2003.1.tar.gz 724313
+RMD160 6c82ad27601f9aa12498e3bc08f06c7b777a5f4d qhull-2003.1.tar.gz 724313
+SHA256 68725c96603a426da748d38d0f83e7a9dd6a0bfc483525debe04001846475b0b qhull-2003.1.tar.gz 724313
diff --git a/media-libs/qhull/files/qhull-2003.1-makefile.patch b/media-libs/qhull/files/qhull-2003.1-makefile.patch
new file mode 100644
index 000000000000..87320474942a
--- /dev/null
+++ b/media-libs/qhull/files/qhull-2003.1-makefile.patch
@@ -0,0 +1,65 @@
+--- Makefile 2001-02-12 03:26:08.000000000 +0100
++++ /root/Makefile 2005-02-22 22:00:15.077553880 +0100
+@@ -78,7 +78,7 @@
+ qh-poly.htm qh-qhull.htm qh-set.htm qh-stat.htm qh-user.htm \
+ qdelau_f.htm qhalf.htm qvoronoi.htm qvoron_f.htm rbox.htm
+
+-all: rbox qconvex qdelaunay qhalf qvoronoi qhull
++all: rbox qconvex qdelaunay qhalf qvoronoi qhull libqhull.so
+
+ unix.o: qhull.h user.h mem.h
+ qconvex.o: qhull.h user.h mem.h
+@@ -100,6 +100,8 @@
+
+ .c.o:
+ $(CC) -c $(CCOPTS1) $<
++ mkdir -p .libs
++ $(CC) -c $(CCOPTS1) -fPIC $< -o .libs/$@
+
+ clean:
+ rm -f *.o ../core qconvex qdelaunay qhalf qvoronoi qhull
+@@ -142,23 +144,23 @@
+
+ # don't use ../qconvex. Does not work on Red Hat Linux
+ qconvex: qconvex.o libqhull.a
+- $(CC) -o qconvex $(CCOPTS2) qconvex.o -L. -lqhull -lm
++ $(CC) -o qconvex $(CCOPTS2) qconvex.o -L. libqhull.a -lm
+ cp qconvex ..
+
+ qdelaunay: qdelaun.o libqhull.a
+- $(CC) -o qdelaunay $(CCOPTS2) qdelaun.o -L. -lqhull -lm
++ $(CC) -o qdelaunay $(CCOPTS2) qdelaun.o -L. libqhull.a -lm
+ cp qdelaunay ..
+
+ qhalf: qhalf.o libqhull.a
+- $(CC) -o qhalf $(CCOPTS2) qhalf.o -L. -lqhull -lm
++ $(CC) -o qhalf $(CCOPTS2) qhalf.o -L. libqhull.a -lm
+ cp qhalf ..
+
+ qvoronoi: qvoronoi.o libqhull.a
+- $(CC) -o qvoronoi $(CCOPTS2) qvoronoi.o -L. -lqhull -lm
++ $(CC) -o qvoronoi $(CCOPTS2) qvoronoi.o -L. libqhull.a -lm
+ cp qvoronoi ..
+
+ qhull: unix.o libqhull.a
+- $(CC) -o qhull $(CCOPTS2) unix.o -L. -lqhull -lm
++ $(CC) -o qhull $(CCOPTS2) unix.o -L. libqhull.a -lm
+ cp qhull ..
+ -chmod +x ../eg/q_test ../eg/q_eg ../eg/q_egtest
+ -cd ..; ./rbox D4 | ./qhull
+@@ -179,11 +181,13 @@
+ cp rbox ..
+
+ user_eg: user_eg.o libqhull.a
+- $(CC) -o user_eg $(CCOPTS2) user_eg.o -L. -lqhull -lm
++ $(CC) -o user_eg $(CCOPTS2) user_eg.o -L. libqhull.a -lm
+ cp user_eg ..
+
+ user_eg2: user_eg2.o libqhull.a
+- $(CC) -o user_eg2 $(CCOPTS2) user_eg2.o -L. -lqhull -lm
++ $(CC) -o user_eg2 $(CCOPTS2) user_eg2.o -L. libqhull.a -lm
+ cp user_eg2 ..
+
+ # end of Makefile
++libqhull.so: $(OBJS)
++ ${CXX} -shared -Xlinker -soname -Xlinker $@ -o libqhull.so $(addprefix .libs/,$(OBJS))