summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefaan De Roeck <stefaan@gentoo.org>2008-08-10 12:10:17 +0000
committerStefaan De Roeck <stefaan@gentoo.org>2008-08-10 12:10:17 +0000
commit6809b637e6a61276a8bc8d64a7079ecfd4bc6328 (patch)
treecbce4292f73f5926872e18029c394059e114b447 /media-libs/openinventor
parentx86 stable, bug #229709 (diff)
downloadgentoo-2-6809b637e6a61276a8bc8d64a7079ecfd4bc6328.tar.gz
gentoo-2-6809b637e6a61276a8bc8d64a7079ecfd4bc6328.tar.bz2
gentoo-2-6809b637e6a61276a8bc8d64a7079ecfd4bc6328.zip
Small patch needed to support sparc (fixes #231962)
(Portage version: 2.2_rc6/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'media-libs/openinventor')
-rw-r--r--media-libs/openinventor/ChangeLog6
-rw-r--r--media-libs/openinventor/files/support-sparc.patch27
-rw-r--r--media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild3
3 files changed, 34 insertions, 2 deletions
diff --git a/media-libs/openinventor/ChangeLog b/media-libs/openinventor/ChangeLog
index 5242f1c4a49d..b820a06d809a 100644
--- a/media-libs/openinventor/ChangeLog
+++ b/media-libs/openinventor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/openinventor
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/ChangeLog,v 1.17 2008/06/07 08:57:45 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/ChangeLog,v 1.18 2008/08/10 12:10:16 stefaan Exp $
+
+ 10 Aug 2008; Stefaan De Roeck <stefaan@gentoo.org>
+ +files/support-sparc.patch, openinventor-2.1.5.10-r2.ebuild:
+ Small patch needed to support sparc (fixes #231962)
07 Jun 2008; Sébastien Fabbro <bicatali@gentoo.org>
files/gcc4-support.patch, openinventor-2.1.5.10-r2.ebuild:
diff --git a/media-libs/openinventor/files/support-sparc.patch b/media-libs/openinventor/files/support-sparc.patch
new file mode 100644
index 000000000000..0eec255143e1
--- /dev/null
+++ b/media-libs/openinventor/files/support-sparc.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/show_bug.cgi?id=231962
+
+sci-physics/geant-4.9.1_p02 wants to be able to get an openinventor with
+USE=openinventor. However, on sparc we must package.use.mask this option
+because openinventor will not build. It will not build because its
+architecture file (machine.h) does not know about sparc linux (or any
+big-endian linux for that matter). With the following little patch,
+openinventor will build and install on sparc, and the demos all seem good. I
+do not know if everything is correct, however, because this change only matters
+in a couple classes (SoInput, SoOutput), and I don't know if the demos hit
+them. No attachment because the test patch changes only one line.
+===============================================
+polylepis inventor # diff -u lib/database/include/machine.h-
+lib/database/include/machine.h
+--- lib/database/include/machine.h- 2008-07-16 12:54:21.000000000 +0000
++++ lib/database/include/machine.h 2008-07-16 12:54:34.000000000 +0000
+@@ -106,7 +106,7 @@
+ * SUN/BSD machine dependent setup
+ */
+
+-#if sun
++#if sun || sparc
+
+ #define MACHINE_WORD_FORMAT DGL_BIG_ENDIAN
+ #define MACHINE_FLOAT_FORMAT DGL_BIG_IEEE
+================================================
+
diff --git a/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild b/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild
index ad9e147b7cfd..508a82d4ba29 100644
--- a/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild
+++ b/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild,v 1.8 2008/06/07 08:57:45 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openinventor/openinventor-2.1.5.10-r2.ebuild,v 1.9 2008/08/10 12:10:16 stefaan Exp $
inherit eutils versionator flag-o-matic
@@ -43,6 +43,7 @@ src_unpack() {
epatch "${FILESDIR}"/use-byacc.patch
# support for amd64, sparc and alpha
epatch "${FILESDIR}"/support-archs.patch
+ epatch "${FILESDIR}"/support-sparc.patch
# freetype2 wasn't enabled by default
epatch "${FILESDIR}"/freetype2-activate.patch
# extra #include statement necessary for freetype2