summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-03-06 13:18:52 +0000
committerMichał Górny <mgorny@gentoo.org>2013-03-06 13:18:52 +0000
commit050755d945cf45a7b2df7dd164270a39e7189d45 (patch)
tree6556bd55cc68a9624d7a0ee1603f2139ed6c007f /media-libs/mesa
parentMigrate to python-r1. (diff)
downloadgentoo-2-050755d945cf45a7b2df7dd164270a39e7189d45.tar.gz
gentoo-2-050755d945cf45a7b2df7dd164270a39e7189d45.tar.bz2
gentoo-2-050755d945cf45a7b2df7dd164270a39e7189d45.zip
Migrate to python-r1.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/ChangeLog5
-rw-r--r--media-libs/mesa/mesa-9.1.ebuild13
2 files changed, 13 insertions, 5 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index 5faec6462c6a..aa82d649f345 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.462 2013/02/27 06:06:13 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.463 2013/03/06 13:18:52 mgorny Exp $
+
+ 06 Mar 2013; Michał Górny <mgorny@gentoo.org> mesa-9.1.ebuild:
+ Migrate to python-r1.
27 Feb 2013; Zac Medico <zmedico@gentoo.org> mesa-9.1.ebuild:
Add ~arm-linux keyword.
diff --git a/media-libs/mesa/mesa-9.1.ebuild b/media-libs/mesa/mesa-9.1.ebuild
index 7071902d7df3..d4d6f2f41634 100644
--- a/media-libs/mesa/mesa-9.1.ebuild
+++ b/media-libs/mesa/mesa-9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-9.1.ebuild,v 1.2 2013/02/27 06:06:13 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-9.1.ebuild,v 1.3 2013/03/06 13:18:52 mgorny Exp $
EAPI=5
@@ -11,7 +11,9 @@ if [[ ${PV} = 9999* ]]; then
EXPERIMENTAL="true"
fi
-inherit base autotools multilib flag-o-matic toolchain-funcs ${GIT_ECLASS}
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit base autotools multilib flag-o-matic python-single-r1 toolchain-funcs ${GIT_ECLASS}
OPENGL_DIR="xorg-x11"
@@ -115,8 +117,8 @@ DEPEND="${RDEPEND}
r600-llvm-compiler? ( >=sys-devel/llvm-3.1 )
video_cards_radeonsi? ( >=sys-devel/llvm-3.1 )
)
- =dev-lang/python-2*
- dev-libs/libxml2[python]
+ ${PYTHON_DEPS}
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
@@ -139,6 +141,8 @@ QA_WX_LOAD="usr/lib*/opengl/xorg-x11/lib/libGL.so*"
pkg_setup() {
# workaround toc-issue wrt #386545
use ppc64 && append-flags -mminimal-toc
+
+ python-single-r1_pkg_setup
}
src_unpack() {
@@ -260,6 +264,7 @@ src_configure() {
$(use_enable xorg) \
--with-dri-drivers=${DRI_DRIVERS} \
--with-gallium-drivers=${GALLIUM_DRIVERS} \
+ PYTHON2="${PYTHON}" \
${myconf}
}