summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-28 20:55:54 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-28 20:55:54 +0000
commitda5991772a9eb00674630f5754562a99a93fa861 (patch)
tree29d68eb1122b36ecb21557c16834cb75b6fef7c4 /media-libs/mash
parentBump to EAPI=4 (diff)
downloadgentoo-2-da5991772a9eb00674630f5754562a99a93fa861.tar.gz
gentoo-2-da5991772a9eb00674630f5754562a99a93fa861.tar.bz2
gentoo-2-da5991772a9eb00674630f5754562a99a93fa861.zip
New ebuild, moved from gnome overlay. Needed for gnome-color-manager-3.2.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/mash')
-rw-r--r--media-libs/mash/ChangeLog10
-rw-r--r--media-libs/mash/mash-0.2.0-r1.ebuild48
-rw-r--r--media-libs/mash/metadata.xml9
3 files changed, 67 insertions, 0 deletions
diff --git a/media-libs/mash/ChangeLog b/media-libs/mash/ChangeLog
new file mode 100644
index 000000000000..84fc2167bd05
--- /dev/null
+++ b/media-libs/mash/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-libs/mash
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mash/ChangeLog,v 1.1 2011/10/28 20:55:54 tetromino Exp $
+
+*mash-0.2.0-r1 (28 Oct 2011)
+
+ 28 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +mash-0.2.0-r1.ebuild, +metadata.xml:
+ New ebuild, moved from gnome overlay. Needed for gnome-color-manager-3.2.
+
diff --git a/media-libs/mash/mash-0.2.0-r1.ebuild b/media-libs/mash/mash-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..eab46fb58194
--- /dev/null
+++ b/media-libs/mash/mash-0.2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mash/mash-0.2.0-r1.ebuild,v 1.1 2011/10/28 20:55:54 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+# clutter.eclass does not support .xz tarballs
+inherit gnome2 versionator
+RV=($(get_version_components))
+SRC_URI="http://source.clutter-project.org/sources/${PN}/${RV[0]}.${RV[1]}/${P}.tar.xz"
+
+DESCRIPTION="A library for rendering 3D models with Clutter"
+HOMEPAGE="http://wiki.clutter-project.org/wiki/Mash"
+
+LICENSE="LGPL-2.1"
+SLOT="0.2"
+IUSE="doc examples +introspection"
+KEYWORDS="~amd64 ~x86"
+
+# Automagically detects x11-libs/mx, but only uses it for building examples.
+# Note: mash is using a bundled copy of rply because mash developers have
+# modified its API by adding extra arguments to various functions.
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=media-libs/clutter-1.5.10:1.0[introspection?]
+ virtual/opengl
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.14 )"
+
+pkg_setup() {
+ DOCS="AUTHORS NEWS README"
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable introspection)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins example/{*.c,*.ply}
+ fi
+}
diff --git a/media-libs/mash/metadata.xml b/media-libs/mash/metadata.xml
new file mode 100644
index 000000000000..b4df7ab52805
--- /dev/null
+++ b/media-libs/mash/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
+ for introspection</flag>
+</use>
+</pkgmetadata>