summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-08-15 15:35:23 +0000
committerMike Frysinger <vapier@gentoo.org>2012-08-15 15:35:23 +0000
commit034b19e42636fe0a221c5edd9101baf726ea0630 (patch)
tree66beaed29a0855741f0409e20d3e521d13cbd91c /media-libs/libvpx
parentStable for HPPA (bug #431520). (diff)
downloadgentoo-2-034b19e42636fe0a221c5edd9101baf726ea0630.tar.gz
gentoo-2-034b19e42636fe0a221c5edd9101baf726ea0630.tar.bz2
gentoo-2-034b19e42636fe0a221c5edd9101baf726ea0630.zip
Fix --enabled-shared for generic-gnu fallback targets (like ia64).
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libvpx')
-rw-r--r--media-libs/libvpx/ChangeLog6
-rw-r--r--media-libs/libvpx/files/libvpx-1.1.0-generic-gnu-shared.patch39
-rw-r--r--media-libs/libvpx/libvpx-1.1.0.ebuild7
3 files changed, 49 insertions, 3 deletions
diff --git a/media-libs/libvpx/ChangeLog b/media-libs/libvpx/ChangeLog
index 13bbc1a0a6b1..7d9362862eb5 100644
--- a/media-libs/libvpx/ChangeLog
+++ b/media-libs/libvpx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libvpx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/ChangeLog,v 1.62 2012/08/14 15:58:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/ChangeLog,v 1.63 2012/08/15 15:35:23 vapier Exp $
+
+ 15 Aug 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/libvpx-1.1.0-generic-gnu-shared.patch, libvpx-1.1.0.ebuild:
+ Fix --enabled-shared for generic-gnu fallback targets (like ia64).
14 Aug 2012; Mike Frysinger <vapier@gentoo.org> libvpx-1.0.0.ebuild:
Mark stable for arm.
diff --git a/media-libs/libvpx/files/libvpx-1.1.0-generic-gnu-shared.patch b/media-libs/libvpx/files/libvpx-1.1.0-generic-gnu-shared.patch
new file mode 100644
index 000000000000..84d536f5054c
--- /dev/null
+++ b/media-libs/libvpx/files/libvpx-1.1.0-generic-gnu-shared.patch
@@ -0,0 +1,39 @@
+From b4ab43f12cc44a24e8161eb2d0857b78c756b18c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@chromium.org>
+Date: Tue, 14 Aug 2012 14:24:28 -0400
+Subject: [PATCH] do not error out on generic-gnu + --enable-shared
+
+If you build with --enabled-shared on a Linux arch not explicitly
+listed, the configure script will abort because it didn't detect
+"linux" in the fallback generic-gnu tuple.
+
+Since this is the fallback tuple and people are passing
+--enable-shared, assume the user knows what they're in for.
+
+Change-Id: Ia35b657e7247c8855e3a94fca424c9884d4241e3
+---
+ configure | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/configure b/configure
+index 2e19e5b..dde215f 100755
+--- a/configure
++++ b/configure
+@@ -454,7 +454,13 @@ process_detect() {
+ # Can only build shared libs on a subset of platforms. Doing this check
+ # here rather than at option parse time because the target auto-detect
+ # magic happens after the command line has been parsed.
+- enabled linux || die "--enable-shared only supported on ELF for now"
++ if ! enabled linux; then
++ if enabled gnu; then
++ echo "--enable-shared is only supported on ELF; assuming this is OK"
++ else
++ die "--enable-shared only supported on ELF for now"
++ fi
++ fi
+ fi
+ if [ -z "$CC" ]; then
+ echo "Bypassing toolchain for environment detection."
+--
+1.7.9.7
+
diff --git a/media-libs/libvpx/libvpx-1.1.0.ebuild b/media-libs/libvpx/libvpx-1.1.0.ebuild
index dea80bcce35d..9540a8181720 100644
--- a/media-libs/libvpx/libvpx-1.1.0.ebuild
+++ b/media-libs/libvpx/libvpx-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-1.1.0.ebuild,v 1.11 2012/08/14 15:45:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-1.1.0.ebuild,v 1.12 2012/08/15 15:35:23 vapier Exp $
EAPI=4
inherit multilib toolchain-funcs base
@@ -39,7 +39,10 @@ REQUIRED_USE="
sse2? ( mmx )
"
-PATCHES=( "${FILESDIR}/${P}-chost.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-chost.patch"
+ "${FILESDIR}/${P}-generic-gnu-shared.patch"
+)
src_configure() {
#let the build system decide which AS to use (it honours $AS but