summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-10-22 17:58:33 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-10-22 17:58:33 +0000
commit3186b75f35e951e07bb2ab9e265faad227bd40d0 (patch)
treef0b374d3142722406537ea1a78b3e54ac2419718 /media-libs/libvorbis
parentUSE=nocxx (diff)
downloadgentoo-2-3186b75f35e951e07bb2ab9e265faad227bd40d0.tar.gz
gentoo-2-3186b75f35e951e07bb2ab9e265faad227bd40d0.tar.bz2
gentoo-2-3186b75f35e951e07bb2ab9e265faad227bd40d0.zip
Workaround for gcc-3.4 bug with -Os closes bug #68479.
Diffstat (limited to 'media-libs/libvorbis')
-rw-r--r--media-libs/libvorbis/ChangeLog6
-rw-r--r--media-libs/libvorbis/libvorbis-1.1.0.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/media-libs/libvorbis/ChangeLog b/media-libs/libvorbis/ChangeLog
index eb55f79534fd..813517bc3496 100644
--- a/media-libs/libvorbis/ChangeLog
+++ b/media-libs/libvorbis/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libvorbis
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/ChangeLog,v 1.43 2004/10/20 13:57:45 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/ChangeLog,v 1.44 2004/10/22 17:58:33 eradicator Exp $
+
+ 22 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ libvorbis-1.1.0.ebuild:
+ Workaround for gcc-3.4 bug with -Os closes bug #68479.
20 Oct 2004; Guy Martin <gmsoft@gentoo.org> libvorbis-1.1.0.ebuild:
Stable on hppa.
diff --git a/media-libs/libvorbis/libvorbis-1.1.0.ebuild b/media-libs/libvorbis/libvorbis-1.1.0.ebuild
index e4037fa2993a..09912e28285f 100644
--- a/media-libs/libvorbis/libvorbis-1.1.0.ebuild
+++ b/media-libs/libvorbis/libvorbis-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.1.0.ebuild,v 1.4 2004/10/20 13:57:45 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.1.0.ebuild,v 1.5 2004/10/22 17:58:33 eradicator Exp $
IUSE=""
@@ -24,9 +24,7 @@ src_unpack() {
# Fix a gcc crash. With the new atexit patch to gcc, it
# seems it does not handle -mno-ieee-fp very well.
sed -i -e "s:-mno-ieee-fp::g" configure
-}
-src_compile() {
# Fixes some strange sed-, libtool- and ranlib-errors on
# Mac OS X
if use macos || use ppc-macos; then
@@ -34,9 +32,12 @@ src_compile() {
else
elibtoolize
fi
+}
+src_compile() {
# Cannot compile with sse2 support it would seem #36104
use x86 && [ $(gcc-major-version) -eq 3 ] && append-flags -mno-sse2
+ [ "`gcc-version`" == "3.4" ] && replace-flags -Os -O2
# take out -fomit-frame-pointer from CFLAGS if k6-2
is-flag -march=k6-3 && filter-flags -fomit-frame-pointer