summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-12-16 13:35:56 +0000
committerHanno Böck <hanno@gentoo.org>2008-12-16 13:35:56 +0000
commita6e0a8808a59de3fb00b02a5bbafebc68291c2bc (patch)
tree7e8942d3d122d3ffc821bec9217e24e36e826e51 /media-libs/libsidplay
parentOutput full CPN when failing, to know what to rebuild. (diff)
downloadgentoo-2-a6e0a8808a59de3fb00b02a5bbafebc68291c2bc.tar.gz
gentoo-2-a6e0a8808a59de3fb00b02a5bbafebc68291c2bc.tar.bz2
gentoo-2-a6e0a8808a59de3fb00b02a5bbafebc68291c2bc.zip
libsidplay-1 gcc43 fix (bug #251159)
(Portage version: 2.2_rc17/cvs/Linux 2.6.28-rc8 x86_64)
Diffstat (limited to 'media-libs/libsidplay')
-rw-r--r--media-libs/libsidplay/ChangeLog6
-rw-r--r--media-libs/libsidplay/files/libsidplay-1.36.59-gcc43.patch40
-rw-r--r--media-libs/libsidplay/libsidplay-1.36.59.ebuild6
3 files changed, 49 insertions, 3 deletions
diff --git a/media-libs/libsidplay/ChangeLog b/media-libs/libsidplay/ChangeLog
index 605496897b2d..225df1157770 100644
--- a/media-libs/libsidplay/ChangeLog
+++ b/media-libs/libsidplay/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libsidplay
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsidplay/ChangeLog,v 1.37 2008/11/16 18:30:04 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsidplay/ChangeLog,v 1.38 2008/12/16 13:35:56 hanno Exp $
+
+ 16 Dec 2008; Hanno Boeck <hanno@gentoo.org>
+ +files/libsidplay-1.36.59-gcc43.patch, libsidplay-1.36.59.ebuild:
+ Fix for gcc 4.3 in libsidplay-1, patch taken from Frugalware Linux.
16 Nov 2008; Hanno Boeck <hanno@gentoo.org>
+files/libsidplay-2.1.1-gcc43.patch, libsidplay-1.36.57.ebuild,
diff --git a/media-libs/libsidplay/files/libsidplay-1.36.59-gcc43.patch b/media-libs/libsidplay/files/libsidplay-1.36.59-gcc43.patch
new file mode 100644
index 000000000000..5beef46c6c14
--- /dev/null
+++ b/media-libs/libsidplay/files/libsidplay-1.36.59-gcc43.patch
@@ -0,0 +1,40 @@
+diff --git a/src/sidtune.cpp b/src/sidtune.cpp
+index 4d1d33b..6fbae80 100644
+--- a/src/sidtune.cpp
++++ b/src/sidtune.cpp
+@@ -306,11 +306,7 @@ udword sidTune::loadFile(const char* fileName, ubyte** bufferRef)
+ return 0;
+ }
+ // Open binary input file stream at end of file.
+-#if defined(SID_HAVE_IOS_BIN)
+- ifstream myIn( fileName, ios::in|ios::bin|ios::ate );
+-#else
+ ifstream myIn( fileName, ios::in|ios::binary|ios::ate );
+-#endif
+ // As a replacement for !is_open(), bad() and the NOT-operator
+ // don't seem to work on all systems.
+ #if defined(SID_DONT_HAVE_IS_OPEN)
+@@ -972,11 +968,7 @@ bool sidTune::saveC64dataFile( const char* fileName, bool overWriteFlag )
+ }
+ // Open binary output file stream.
+ else
+-#if defined(SID_HAVE_IOS_BIN)
+- fMyOut.open( fileName, ios::out|ios::bin|ios::trunc );
+-#else
+ fMyOut.open( fileName, ios::out|ios::binary|ios::trunc );
+-#endif
+ if ( !fMyOut )
+ {
+ info.statusString = text_cantCreateFile;
+@@ -1061,11 +1053,7 @@ bool sidTune::savePSIDfile( const char* fileName, bool overWriteFlag )
+ }
+ // Open binary output file stream.
+ else
+-#if defined(SID_HAVE_IOS_BIN)
+- fMyOut.open( fileName, ios::out|ios::bin|ios::trunc );
+-#else
+ fMyOut.open( fileName, ios::out|ios::binary|ios::trunc );
+-#endif
+ if ( !fMyOut )
+ {
+ info.statusString = text_cantCreateFile;
diff --git a/media-libs/libsidplay/libsidplay-1.36.59.ebuild b/media-libs/libsidplay/libsidplay-1.36.59.ebuild
index 70db59d5a75e..5da4328ba3ce 100644
--- a/media-libs/libsidplay/libsidplay-1.36.59.ebuild
+++ b/media-libs/libsidplay/libsidplay-1.36.59.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsidplay/libsidplay-1.36.59.ebuild,v 1.3 2008/11/16 18:30:04 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsidplay/libsidplay-1.36.59.ebuild,v 1.4 2008/12/16 13:35:56 hanno Exp $
-inherit libtool
+inherit libtool eutils
IUSE=""
DESCRIPTION="C64 SID player library"
@@ -19,6 +19,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch" || die "epatch failed"
+
# Needed to get a sane .so versionning on fbsd, please don't drop
elibtoolize
}