summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-23 18:43:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-23 18:43:00 +0000
commit557308ba34189b90ed19b3f4e20494b0c3138ebe (patch)
tree09f955e1a07fb1b3b6b8ee03aa41551c40540f05 /media-libs/libogg/libogg-1.1.ebuild
parentAdd freetype USE flag for x11-libs/fox (diff)
downloadgentoo-2-557308ba34189b90ed19b3f4e20494b0c3138ebe.tar.gz
gentoo-2-557308ba34189b90ed19b3f4e20494b0c3138ebe.tar.bz2
gentoo-2-557308ba34189b90ed19b3f4e20494b0c3138ebe.zip
gnuconfig_update in src_unpack; tidy
Diffstat (limited to 'media-libs/libogg/libogg-1.1.ebuild')
-rw-r--r--media-libs/libogg/libogg-1.1.ebuild29
1 files changed, 12 insertions, 17 deletions
diff --git a/media-libs/libogg/libogg-1.1.ebuild b/media-libs/libogg/libogg-1.1.ebuild
index 1ada064630d1..3b2e5fa2311f 100644
--- a/media-libs/libogg/libogg-1.1.ebuild
+++ b/media-libs/libogg/libogg-1.1.ebuild
@@ -1,38 +1,33 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libogg/libogg-1.1.ebuild,v 1.14 2004/08/23 07:57:46 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libogg/libogg-1.1.ebuild,v 1.15 2004/08/23 18:43:00 mr_bones_ Exp $
inherit gnuconfig
-IUSE=""
-
DESCRIPTION="the Ogg media file format library"
-SRC_URI="http://www.vorbis.com/files/1.0.1/unix/${P}.tar.gz"
HOMEPAGE="http://www.xiph.org/ogg/vorbis/index.html"
+SRC_URI="http://www.vorbis.com/files/1.0.1/unix/${P}.tar.gz"
-DEPEND="virtual/libc"
-
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha hppa amd64 mips ~ia64 ppc64"
+IUSE=""
-src_compile() {
- #Needed for mips and probablly others
- gnuconfig_update
+DEPEND="virtual/libc"
- econf || die "Configure failed."
- emake || die "Emake failed."
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ gnuconfig_update
}
src_install () {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
# remove the docs installed by make install, since I'll install
# them in portage package doc directory
- echo "Removing docs installed by make install"
- rm -rf ${D}/usr/share/doc
+ rm -rf "${D}/usr/share/doc"
- dodoc AUTHORS CHANGES COPYING README
+ dodoc AUTHORS CHANGES README
dohtml doc/*.{html,png}
}
-