summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-11 16:28:26 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-11 16:28:26 +0000
commitae15e323dfc97d1c75273680847c7c3fd8a3bf36 (patch)
treea0d6e9883391ed064fec294ee0fbb876e06b2ee2 /media-libs/libofa
parentUnmask webkit on determinated packages (diff)
downloadgentoo-2-ae15e323dfc97d1c75273680847c7c3fd8a3bf36.tar.gz
gentoo-2-ae15e323dfc97d1c75273680847c7c3fd8a3bf36.tar.bz2
gentoo-2-ae15e323dfc97d1c75273680847c7c3fd8a3bf36.zip
Fix bug 265750, failure with gcc-4.4. Thanks to Andreas Sturmlechner <andreas.sturmlechner@gmail.com> for the patch.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libofa')
-rw-r--r--media-libs/libofa/ChangeLog9
-rw-r--r--media-libs/libofa/files/libofa-0.9.3-gcc-4.4.patch10
-rw-r--r--media-libs/libofa/libofa-0.9.3.ebuild24
3 files changed, 29 insertions, 14 deletions
diff --git a/media-libs/libofa/ChangeLog b/media-libs/libofa/ChangeLog
index fc4f09743665..e91bd828fc62 100644
--- a/media-libs/libofa/ChangeLog
+++ b/media-libs/libofa/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libofa
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libofa/ChangeLog,v 1.15 2008/04/16 12:57:29 drac Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libofa/ChangeLog,v 1.16 2009/04/11 16:28:25 loki_val Exp $
+
+ 11 Apr 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/libofa-0.9.3-gcc-4.4.patch, libofa-0.9.3.ebuild:
+ Fix bug 265750, failure with gcc-4.4. Thanks to Andreas Sturmlechner
+ <andreas.sturmlechner@gmail.com> for the patch.
16 Apr 2008; Samuli Suominen <drac@gentoo.org>
+files/libofa-0.9.3-gcc-4.3.patch, libofa-0.9.3.ebuild:
diff --git a/media-libs/libofa/files/libofa-0.9.3-gcc-4.4.patch b/media-libs/libofa/files/libofa-0.9.3-gcc-4.4.patch
new file mode 100644
index 000000000000..25cab143d23f
--- /dev/null
+++ b/media-libs/libofa/files/libofa-0.9.3-gcc-4.4.patch
@@ -0,0 +1,10 @@
+--- orig-libofa-0.9.3/examples/example.cpp 2009-04-11 12:22:55.397455430 +0200
++++ libofa-0.9.3/examples/example.cpp 2009-04-11 12:25:21.466456955 +0200
+@@ -9,6 +9,7 @@
+
+ #include "protocol.h"
+
++#include <stdio.h>
+ #include <string.h>
+
+ AudioData* loadWaveFile(char *file);
diff --git a/media-libs/libofa/libofa-0.9.3.ebuild b/media-libs/libofa/libofa-0.9.3.ebuild
index 8cc60ff6435c..273acd965b52 100644
--- a/media-libs/libofa/libofa-0.9.3.ebuild
+++ b/media-libs/libofa/libofa-0.9.3.ebuild
@@ -1,8 +1,10 @@
-# Copyright 2006-2008 Gentoo Foundation
+# Copyright 2006-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libofa/libofa-0.9.3.ebuild,v 1.16 2008/04/16 12:59:00 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libofa/libofa-0.9.3.ebuild,v 1.17 2009/04/11 16:28:25 loki_val Exp $
-inherit eutils
+EAPI=2
+
+inherit base eutils flag-o-matic
DESCRIPTION="Open Fingerprint Architecture"
HOMEPAGE="http://code.google.com/p/musicip-libofa/"
@@ -19,16 +21,14 @@ RDEPEND="dev-libs/expat
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-pkg_setup() {
- [[ "${CXXFLAGS}" != "${CXXFLAGS/-ffast-math/}" ]] && \
- die "Correct your C[XX]FLAGS. Using -ffast-math is unsafe and not supported."
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-4.patch
+ "${FILESDIR}"/${P}-gcc-4.3.patch
+ "${FILESDIR}"/${P}-gcc-4.4.patch
+)
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gcc-4.patch \
- "${FILESDIR}"/${P}-gcc-4.3.patch
+pkg_setup() {
+ is-flag -ffast-math && append-flags -fno-fast-math
}
src_install() {