summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChad Huneycutt <chadh@gentoo.org>2002-07-19 03:39:01 +0000
committerChad Huneycutt <chadh@gentoo.org>2002-07-19 03:39:01 +0000
commite22389d2209dfde1545ce249661326f9775e9f3c (patch)
tree2656e374d7947dde12d914ce0cde5f1a2186fad9 /media-libs/libfame/libfame-0.8.10.ebuild
parentadded new package libfame. This library has x86 assembly, but the alt arch (diff)
downloadgentoo-2-e22389d2209dfde1545ce249661326f9775e9f3c.tar.gz
gentoo-2-e22389d2209dfde1545ce249661326f9775e9f3c.tar.bz2
gentoo-2-e22389d2209dfde1545ce249661326f9775e9f3c.zip
new ebuild -- probably x86-only
Diffstat (limited to 'media-libs/libfame/libfame-0.8.10.ebuild')
-rw-r--r--media-libs/libfame/libfame-0.8.10.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/libfame/libfame-0.8.10.ebuild b/media-libs/libfame/libfame-0.8.10.ebuild
new file mode 100644
index 000000000000..803ca79777ac
--- /dev/null
+++ b/media-libs/libfame/libfame-0.8.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libfame/libfame-0.8.10.ebuild,v 1.1 2002/07/19 03:39:01 chadh Exp $
+
+#A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="libfame is a video encoding library. (MPEG-1 and MPEG-4)"
+SRC_URI="mirror://sourceforge/fame/${P}.tar.gz"
+HOMEPAGE="http://fame.sourceforge.net"
+LICENSE="GPL-2" # The web page says LGPL too, but no license in the tar ball
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf
+
+ use mmx && myconf="--enable-mmx"
+ use sse && myconf="${myconf} --enable-sse"
+
+ ./configure --prefix=/usr --host=${CHOST} ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/lib
+
+ make prefix=${D}/usr install || die
+ dobin libfame-config
+
+ insinto /usr/share/aclocal
+ doins libfame.m4
+
+ dodoc CHANGES README
+ doman doc/*.3
+}