summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-22 06:29:37 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-22 06:29:37 +0000
commitb1a1a95f5271965857bfe12428abaf582771dfb7 (patch)
tree7af1713108dad3f01e0c524b437e0e6a50933bd8 /media-libs/libass
parentversion bump (diff)
downloadgentoo-2-b1a1a95f5271965857bfe12428abaf582771dfb7.tar.gz
gentoo-2-b1a1a95f5271965857bfe12428abaf582771dfb7.tar.bz2
gentoo-2-b1a1a95f5271965857bfe12428abaf582771dfb7.zip
Version bump (bug #498796). Update to EAPI 5, add subslot version, and fix harfbuzz truetype useflag dep (bug #452210).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-libs/libass')
-rw-r--r--media-libs/libass/ChangeLog10
-rw-r--r--media-libs/libass/libass-0.10.2.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/media-libs/libass/ChangeLog b/media-libs/libass/ChangeLog
index 4fe436f8f560..47cb4a6e58c6 100644
--- a/media-libs/libass/ChangeLog
+++ b/media-libs/libass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libass
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libass/ChangeLog,v 1.65 2013/07/06 17:08:27 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libass/ChangeLog,v 1.66 2014/01/22 06:29:37 radhermit Exp $
+
+*libass-0.10.2 (22 Jan 2014)
+
+ 22 Jan 2014; Tim Harder <radhermit@gentoo.org> +libass-0.10.2.ebuild:
+ Version bump (bug #498796). Update to EAPI 5, add subslot version, and fix
+ harfbuzz truetype useflag dep (bug #452210).
06 Jul 2013; Agostino Sarubbo <ago@gentoo.org> libass-0.10.1.ebuild:
Stable for alpha, wrt bug #470762
diff --git a/media-libs/libass/libass-0.10.2.ebuild b/media-libs/libass/libass-0.10.2.ebuild
new file mode 100644
index 000000000000..aa67518aeb7f
--- /dev/null
+++ b/media-libs/libass/libass-0.10.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libass/libass-0.10.2.ebuild,v 1.1 2014/01/22 06:29:37 radhermit Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Library for SSA/ASS subtitles rendering"
+HOMEPAGE="http://code.google.com/p/libass/"
+SRC_URI="http://libass.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="ISC"
+SLOT="0/5" # subslot = libass soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="+enca +fontconfig +harfbuzz static-libs"
+
+RDEPEND="fontconfig? ( >=media-libs/fontconfig-2.4.2 )
+ >=media-libs/freetype-2.4:2
+ virtual/libiconv
+ >=dev-libs/fribidi-0.19.0
+ harfbuzz? ( >=media-libs/harfbuzz-0.9.11[truetype] )
+ enca? ( app-i18n/enca )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="Changelog"
+
+src_configure() {
+ econf \
+ $(use_enable enca) \
+ $(use_enable fontconfig) \
+ $(use_enable harfbuzz) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}