summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-03-10 03:31:27 +0000
committerMichael Weber <xmw@gentoo.org>2012-03-10 03:31:27 +0000
commit20dca6246bf838bde27a63190e32a8ee94822824 (patch)
tree3ecf287d3742f1e2ebde599aeda40c633696b7c2 /media-libs/libXcm
parentVersion bump for CVE-2012-1126, CVE-2012-1127, CVE-2012-1128, CVE-2012-1129, (diff)
downloadgentoo-2-20dca6246bf838bde27a63190e32a8ee94822824.tar.gz
gentoo-2-20dca6246bf838bde27a63190e32a8ee94822824.tar.bz2
gentoo-2-20dca6246bf838bde27a63190e32a8ee94822824.zip
Revbump to restore X use flag.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libXcm')
-rw-r--r--media-libs/libXcm/ChangeLog8
-rw-r--r--media-libs/libXcm/files/libXcm-0.5.0-buildsystem.patch30
-rw-r--r--media-libs/libXcm/libXcm-0.5.0-r1.ebuild40
3 files changed, 77 insertions, 1 deletions
diff --git a/media-libs/libXcm/ChangeLog b/media-libs/libXcm/ChangeLog
index 8cb2b7e64816..4082d5e99a0e 100644
--- a/media-libs/libXcm/ChangeLog
+++ b/media-libs/libXcm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libXcm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libXcm/ChangeLog,v 1.4 2012/03/09 18:47:12 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libXcm/ChangeLog,v 1.5 2012/03/10 03:31:27 xmw Exp $
+
+*libXcm-0.5.0-r1 (10 Mar 2012)
+
+ 10 Mar 2012; Michael Weber <xmw@gentoo.org> +libXcm-0.5.0-r1.ebuild,
+ +files/libXcm-0.5.0-buildsystem.patch:
+ Revbump to restore X use flag.
09 Mar 2012; Michael Weber <xmw@gentoo.org> libXcm-0.5.0.ebuild:
Work around upstream bug, [-X] does not work.
diff --git a/media-libs/libXcm/files/libXcm-0.5.0-buildsystem.patch b/media-libs/libXcm/files/libXcm-0.5.0-buildsystem.patch
new file mode 100644
index 000000000000..fd492be21566
--- /dev/null
+++ b/media-libs/libXcm/files/libXcm-0.5.0-buildsystem.patch
@@ -0,0 +1,30 @@
+--- libXcm-0.5.0/configure.ac
++++ libXcm-0.5.0/configure.ac
+@@ -37,6 +37,14 @@
+
+ LIBTOOL_VERSION=$LIBTOOL_CURRENT:$LIBTOOL_REVISION:$LIBTOOL_AGE
+
++AC_MSG_CHECKING([wether to enable x11 support])
++AC_ARG_WITH(x11,
++ [ --with-x11 enable x11 support],
++ with_x11=$withval,
++ with_x11=yes)
++AC_MSG_RESULT($with_x11)
++
++if test "$with_x11" = "yes"; then
+ PKG_CHECK_EXISTS([x11], [
+ PKG_CHECK_MODULES([libX11], [x11])
+ PKG_CHECK_MODULES([libXfixes], [xfixes])
+@@ -50,6 +58,12 @@
+ AM_CONDITIONAL([HAVE_X11], [false])
+ HAVE_X11=
+ ])
++else
++ AC_MSG_CHECKING([for libX11])
++ AC_MSG_RESULT([no])
++ AM_CONDITIONAL([HAVE_X11], [false])
++ HAVE_X11=
++fi
+
+ AC_PATH_PROGS(RPMBUILD, rpm, :)
+
diff --git a/media-libs/libXcm/libXcm-0.5.0-r1.ebuild b/media-libs/libXcm/libXcm-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..35cc49166d59
--- /dev/null
+++ b/media-libs/libXcm/libXcm-0.5.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libXcm/libXcm-0.5.0-r1.ebuild,v 1.1 2012/03/10 03:31:27 xmw Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="reference implementation of the net-color spec"
+HOMEPAGE="http://www.oyranos.org/libxcm/"
+SRC_URI="mirror://sourceforge/oyranos/${PN}/${PN}-0.4.x/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X doc static-libs"
+
+RDEPEND="X? ( x11-libs/libXmu
+ x11-libs/libXfixes
+ x11-libs/libX11
+ x11-proto/xproto )"
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-buildsystem.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-silent-rules \
+ $(use_with X x11)
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use doc && dohtml doc/html/*
+}