summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2014-01-19 12:32:00 +0000
committerMarkus Meier <maekke@gentoo.org>2014-01-19 12:32:00 +0000
commit911c13fc010cf0762d671141e4e4eb671e4dfa27 (patch)
tree7c2f3ecefe4018992137d8504e3c20572ec59da1 /media-libs/lensfun
parentFix building on hardened (bug #498074 by John Default). (diff)
downloadgentoo-2-911c13fc010cf0762d671141e4e4eb671e4dfa27.tar.gz
gentoo-2-911c13fc010cf0762d671141e4e4eb671e4dfa27.tar.bz2
gentoo-2-911c13fc010cf0762d671141e4e4eb671e4dfa27.zip
remove old
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 072AD062)
Diffstat (limited to 'media-libs/lensfun')
-rw-r--r--media-libs/lensfun/ChangeLog8
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.5-libpng15.patch40
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.5_p153-build.patch61
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch15
-rw-r--r--media-libs/lensfun/lensfun-0.2.5-r2.ebuild56
-rw-r--r--media-libs/lensfun/lensfun-0.2.5_p153-r1.ebuild39
-rw-r--r--media-libs/lensfun/lensfun-0.2.6.ebuild52
7 files changed, 7 insertions, 264 deletions
diff --git a/media-libs/lensfun/ChangeLog b/media-libs/lensfun/ChangeLog
index 059ef81a8fef..cb8962a9d7a1 100644
--- a/media-libs/lensfun/ChangeLog
+++ b/media-libs/lensfun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/lensfun
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.62 2014/01/18 20:05:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.63 2014/01/19 12:31:59 maekke Exp $
+
+ 19 Jan 2014; Markus Meier <maekke@gentoo.org> -lensfun-0.2.5-r2.ebuild,
+ -lensfun-0.2.5_p153-r1.ebuild, -lensfun-0.2.6.ebuild,
+ -files/lensfun-0.2.5-libpng15.patch, -files/lensfun-0.2.5_p153-build.patch,
+ -files/lensfun-0.2.5_p153-pc.patch:
+ remove old
18 Jan 2014; Agostino Sarubbo <ago@gentoo.org> lensfun-0.2.7.ebuild:
Stable for alpha, wrt bug #494692
diff --git a/media-libs/lensfun/files/lensfun-0.2.5-libpng15.patch b/media-libs/lensfun/files/lensfun-0.2.5-libpng15.patch
deleted file mode 100644
index 6d10b6c7d0ca..000000000000
--- a/media-libs/lensfun/files/lensfun-0.2.5-libpng15.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- libs/auxfun/image.cpp
-+++ libs/auxfun/image.cpp
-@@ -94,7 +94,7 @@ bool Image::LoadPNG ()
-
- png_init_io (png, file);
-
-- if (setjmp (png->jmpbuf))
-+ if (setjmp (png_jmpbuf(png)))
- // If we get here, we had a problem reading the file
- goto nomem;
-
-@@ -157,7 +157,7 @@ bool Image::LoadPNG ()
- row_pointers = new png_bytep [Height];
-
- if (!row_pointers
-- || setjmp (png->jmpbuf)) // Set a new exception handler
-+ || setjmp (png_jmpbuf(png))) // Set a new exception handler
- {
- delete [] row_pointers;
- nomem:
-@@ -214,7 +214,7 @@ bool Image::SavePNG (const char *fName)
- }
-
- /* Catch processing errors */
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- /* If we get here, we had a problem writing the file */
- goto error2;
-
-@@ -273,10 +273,6 @@ bool Image::SavePNG (const char *fName)
- /* It is REQUIRED to call this to finish writing the rest of the file */
- png_write_end (png, info);
-
-- /* if you malloced the palette, free it here */
-- if (info->palette)
-- free (info->palette);
--
- /* clean up after the write, and free any memory allocated */
- png_destroy_write_struct (&png, &info);
-
diff --git a/media-libs/lensfun/files/lensfun-0.2.5_p153-build.patch b/media-libs/lensfun/files/lensfun-0.2.5_p153-build.patch
deleted file mode 100644
index 425031dd511f..000000000000
--- a/media-libs/lensfun/files/lensfun-0.2.5_p153-build.patch
+++ /dev/null
@@ -1,61 +0,0 @@
---- docs/CMakeLists.txt
-+++ docs/CMakeLists.txt
-@@ -11,7 +11,7 @@
- CONFIGURE_FILE(doxyfile.in.cmake ${DOXYFILE} @ONLY)
-
- # now build documentation
--ADD_CUSTOM_TARGET(doc
-+ADD_CUSTOM_TARGET(doc ALL
- COMMAND "${DOXYGEN_EXECUTABLE}"
- DEPENDS doxyfile.in.cmake manual-main.txt ../include/lensfun/lensfun.h.in
- WORKING_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}"
-@@ -19,5 +19,4 @@
- )
-
- # install documentation
--FILE(GLOB doc_files "${CMAKE_DOC_OUT}/*.*")
--INSTALL(FILES ${doc_files} DESTINATION ${DOCDIR})
-+INSTALL(DIRECTORY "${CMAKE_BINARY_DIR}/doc_doxygen/" DESTINATION ${DOCDIR})
---- CMakeLists.txt
-+++ CMakeLists.txt
-@@ -30,7 +30,7 @@
-
- # options controlling the build process
- OPTION(BUILD_STATIC "Build static library" OFF)
--OPTION(BUILD_TESTS "Build test programs" ON)
-+OPTION(BUILD_TESTS "Build test programs" OFF)
- OPTION(BUILD_AUXFUN "Build auxfun library (requires libpng)" OFF)
- OPTION(BUILD_FOR_SSE "Build with support for SSE" OFF)
- OPTION(BUILD_FOR_SSE2 "Build with support for SSE2" OFF)
-@@ -71,13 +71,13 @@
- IF(BUILD_STATIC)
- ADD_DEFINITIONS(-DCONF_LENSFUN_STATIC)
- ENDIF()
--
-+
- # define destination dirs (relative to prefix)
- SET(BINDIR bin)
--SET(LIBDIR lib)
-+# SET(LIBDIR lib)
- SET(INCLUDEDIR include)
- SET(DATADIR share/lensfun)
--SET(DOCDIR share/doc/lensfun-${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_MICRO}.${VERSION_BUGFIX})
-+# SET(DOCDIR share/doc/lensfun-${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_MICRO}.${VERSION_BUGFIX})
-
- IF(WIN32)
- SET(PLATFORM_WINDOWS 1)
-@@ -125,12 +125,12 @@
- ENDIF()
-
- # install include files
--INSTALL(FILES ${CMAKE_BINARY_DIR}/lensfun.h DESTINATION ${INCLUDEDIR}/lensfun)
-+INSTALL(FILES ${CMAKE_BINARY_DIR}/lensfun.h DESTINATION ${INCLUDEDIR})
- IF(NOT HAVE_REGEX_H)
- INSTALL(FILES include/regex/regex.h DESTINATION ${INCLUDEDIR}/regex)
- ENDIF()
- IF(BUILD_AUXFUN)
-- INSTALL(FILES include/auxfun/image.h include/auxfun/rgbpixel.h DESTINATION ${INCLUDEDIR}/auxfun)
-+ INSTALL(FILES include/auxfun/image.h include/auxfun/rgbpixel.h DESTINATION ${INCLUDEDIR})
- ENDIF()
-
- # install db files
diff --git a/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch b/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch
deleted file mode 100644
index a68cf55521f5..000000000000
--- a/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- libs/lensfun/CMakeLists.txt
-+++ libs/lensfun/CMakeLists.txt
-@@ -26,3 +26,12 @@
- RUNTIME DESTINATION ${BINDIR}
- LIBRARY DESTINATION ${LIBDIR}
- ARCHIVE DESTINATION ${LIBDIR})
-+
-+IF(UNIX AND NOT APPLE)
-+ SET(CONF_VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_MICRO}.${VERSION_BUGFIX}")
-+ SET(CONF_LIBDIR "${CMAKE_INSTALL_LIBDIR}/")
-+ SET(CONF_INCLUDEDIR "${CMAKE_INSTALL_PREFIX}/${INCLUDEDIR}/")
-+ SET(CONF_LENSFUN_STATIC "")
-+ CONFIGURE_FILE("lensfun.pc.in" "lensfun.pc" @ONLY)
-+ INSTALL(FILES "${CMAKE_CURRENT_BINARY_DIR}/lensfun.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
-+ENDIF(UNIX AND NOT APPLE)
diff --git a/media-libs/lensfun/lensfun-0.2.5-r2.ebuild b/media-libs/lensfun/lensfun-0.2.5-r2.ebuild
deleted file mode 100644
index c53ab7d3eebf..000000000000
--- a/media-libs/lensfun/lensfun-0.2.5-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.5-r2.ebuild,v 1.14 2013/03/03 11:05:34 vapier Exp $
-
-EAPI=2
-inherit eutils python toolchain-funcs
-
-DESCRIPTION="lensfun: A library for rectifying and simulating photographic lens distortions"
-HOMEPAGE="http://lensfun.berlios.de/"
-SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.bz2"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
-IUSE="debug doc"
-
-RDEPEND=">=dev-libs/glib-2
- >=media-libs/libpng-1.2"
-DEPEND="${RDEPEND}
- || ( dev-lang/python:2.7 dev-lang/python:2.6 )
- virtual/pkgconfig
- doc? ( >=app-doc/doxygen-1.5.0 )"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- # disable stripping, remove ricer CFLAGS
- sed -i \
- -e 's:-s -O3 -fomit-frame-pointer -funroll-loops::g' \
- -e 's:GCC.LDFLAGS.release = -s:GCC.LDFLAGS.release =:g' \
- build/tibs/compiler/gcc.mak || die
-
- epatch "${FILESDIR}"/${P}-libpng15.patch
-}
-
-src_configure() {
- tc-export CXX
- export LD="${CXX}"
-
- local myconf=""
- use debug && myconf="--mode=debug"
- # econf does NOT work
- ./configure --prefix=/usr --docdir="/usr/share/doc/${PF}" --vectorization= ${myconf} || die
-}
-
-src_compile() {
- emake all V=1 || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- # TODO remove docs if ! use doc
-}
diff --git a/media-libs/lensfun/lensfun-0.2.5_p153-r1.ebuild b/media-libs/lensfun/lensfun-0.2.5_p153-r1.ebuild
deleted file mode 100644
index a8bf3ab718be..000000000000
--- a/media-libs/lensfun/lensfun-0.2.5_p153-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.5_p153-r1.ebuild,v 1.3 2013/03/03 11:05:34 vapier Exp $
-
-EAPI=4
-inherit python multilib cmake-utils
-
-DESCRIPTION="lensfun: A library for rectifying and simulating photographic lens distortions"
-HOMEPAGE="http://lensfun.berlios.de/"
-SRC_URI="http://dev.gentoo.org/~dilfridge/distfiles/${P}.tar.xz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
-IUSE="doc"
-
-RDEPEND=">=dev-libs/glib-2
- >=media-libs/libpng-1.2"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-PATCHES=(
- "${FILESDIR}/${P}-build.patch"
- "${FILESDIR}/${P}-pc.patch"
-)
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_build doc)
- -DLIBDIR=$(get_libdir)
- -DDOCDIR=/usr/share/doc/${P}
- )
- cmake-utils_src_configure
-}
diff --git a/media-libs/lensfun/lensfun-0.2.6.ebuild b/media-libs/lensfun/lensfun-0.2.6.ebuild
deleted file mode 100644
index 89d4f5d36618..000000000000
--- a/media-libs/lensfun/lensfun-0.2.6.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.6.ebuild,v 1.4 2013/03/03 11:05:34 vapier Exp $
-
-EAPI=4
-
-PYTHON_DEPEND="2:2.6"
-
-inherit cmake-utils multilib python
-
-DESCRIPTION="lensfun: A library for rectifying and simulating photographic lens distortions"
-HOMEPAGE="http://lensfun.berlios.de/"
-SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-3 CC-BY-SA-3.0" # See README for reasoning.
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc sse sse2"
-
-RDEPEND=">=dev-libs/glib-2.28
- media-libs/libpng:0
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-auxfun.patch
- "${FILESDIR}"/${PN}-0.2.5_p153-build.patch
- "${FILESDIR}"/${PN}-0.2.5_p153-pc.patch
- )
-
-DOCS=( README docs/mounts.txt )
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
- -DLIBDIR=$(get_libdir)
- -DBUILD_AUXFUN=ON
- $(cmake-utils_use_build doc)
- $(cmake-utils_use_build sse FOR_SSE)
- $(cmake-utils_use_build sse2 FOR_SSE2)
- -DBUILD_STATIC=OFF
- -DBUILD_TESTS=OFF
- )
-
- cmake-utils_src_configure
-}