summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-18 17:09:35 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-18 17:09:35 +0000
commite4d12d2573a02538067960fb135a405bd20b9a81 (patch)
treef793a26643f4a8e421d78abf9863a89c39cd2481 /media-libs/lcms
parentversion bump, drop old (diff)
downloadgentoo-2-e4d12d2573a02538067960fb135a405bd20b9a81.tar.gz
gentoo-2-e4d12d2573a02538067960fb135a405bd20b9a81.tar.bz2
gentoo-2-e4d12d2573a02538067960fb135a405bd20b9a81.zip
Backport multilib support to lcms:0, as required by older versions of wine.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/lcms')
-rw-r--r--media-libs/lcms/ChangeLog7
-rw-r--r--media-libs/lcms/lcms-1.19-r2.ebuild106
2 files changed, 112 insertions, 1 deletions
diff --git a/media-libs/lcms/ChangeLog b/media-libs/lcms/ChangeLog
index 5b4758543cc5..2bd8d2884512 100644
--- a/media-libs/lcms/ChangeLog
+++ b/media-libs/lcms/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/lcms
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lcms/ChangeLog,v 1.172 2014/06/10 00:51:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lcms/ChangeLog,v 1.173 2014/06/18 17:09:35 mgorny Exp $
+
+*lcms-1.19-r2 (18 Jun 2014)
+
+ 18 Jun 2014; Michał Górny <mgorny@gentoo.org> +lcms-1.19-r2.ebuild:
+ Backport multilib support to lcms:0, as required by older versions of wine.
10 Jun 2014; Mike Frysinger <vapier@gentoo.org> lcms-1.19-r1.ebuild,
lcms-1.19.ebuild, lcms-2.3.ebuild, lcms-2.4.ebuild, lcms-2.5-r1.ebuild,
diff --git a/media-libs/lcms/lcms-1.19-r2.ebuild b/media-libs/lcms/lcms-1.19-r2.ebuild
new file mode 100644
index 000000000000..4c049738df47
--- /dev/null
+++ b/media-libs/lcms/lcms-1.19-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lcms/lcms-1.19-r2.ebuild,v 1.1 2014/06/18 17:09:35 mgorny Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+
+# autoreconf needs to update python macros for py3 support.
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-multilib python-r1
+
+DESCRIPTION="A lightweight, speed optimized color management engine"
+HOMEPAGE="http://www.littlecms.com/"
+SRC_URI="http://www.littlecms.com/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="jpeg python static-libs tiff zlib"
+
+RDEPEND="
+ tiff? ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
+ jpeg? ( virtual/jpeg:0[${MULTILIB_USEDEP}] )
+ zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ python? ( >=dev-lang/swig-1.3.31 )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable_static_modules.patch"
+ "${FILESDIR}/${P}-implicit.patch"
+ "${FILESDIR}/${P}-fix-swig-destructor.patch"
+ "${FILESDIR}/${P}-fix-python3.2.patch"
+)
+
+src_prepare() {
+ # Breaks out-of-source build, only corresponding .in file is needed
+ rm include/icc34.h || die 'rm failed'
+
+ autotools-utils_src_prepare
+
+ # run swig to regenerate lcms_wrap.cxx and lcms.py (bug #148728)
+ if use python; then
+ cd python || die
+ bash swig_lcms || die
+ fi
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_with jpeg)
+ $(use_with tiff)
+ $(use_with zlib)
+ )
+ autotools-utils_src_configure --without-python
+
+ if multilib_is_native_abi && use python; then
+ python_parallel_foreach_impl \
+ autotools-utils_src_configure --with-python
+ fi
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python; then
+ # Note: it intentionally passes evaluated 'parent' dir.
+ python_parallel_foreach_impl \
+ autotools-utils_src_compile -C python \
+ top_builddir="${BUILD_DIR}"
+ fi
+}
+
+multilib_src_test() {
+ cp "${S}"/testbed/*icm testbed/ || die
+
+ default
+}
+
+multilib_src_install() {
+ emake DESTDIR="${ED}" BINDIR="${ED}"/usr/bin install
+
+ if multilib_is_native_abi && use python; then
+ # Note: it intentionally passes evaluated 'parent' dir.
+ python_foreach_impl \
+ autotools-utils_src_install -C python \
+ top_builddir="${BUILD_DIR}"
+
+ python_parallel_foreach_impl python_optimize
+ fi
+
+ insinto /usr/share/lcms/profiles
+ doins "${S}"/testbed/*.icm
+}
+
+multilib_src_install_all() {
+ DOCS=( AUTHORS README.1ST INSTALL NEWS doc/{LCMSAPI,TUTORIAL}.TXT )
+
+ einstalldocs
+ prune_libtool_files --modules
+}