summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2005-08-06 22:25:29 +0000
committerKito Danya Dietrich <kito@gentoo.org>2005-08-06 22:25:29 +0000
commit712bab2d8f9f7af41b9ff13dc7c87d100020a582 (patch)
tree149ae6ecaa5417e468078f6f153a88d1f714921b /media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
parent* bump (diff)
downloadgentoo-2-712bab2d8f9f7af41b9ff13dc7c87d100020a582.tar.gz
gentoo-2-712bab2d8f9f7af41b9ff13dc7c87d100020a582.tar.bz2
gentoo-2-712bab2d8f9f7af41b9ff13dc7c87d100020a582.zip
silence harmless warnings on gcc-apple-5026
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild')
-rw-r--r--media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild b/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
index e364699a9d60..060fcc9af4a6 100644
--- a/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
+++ b/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild,v 1.18 2005/05/01 18:24:34 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ladspa-cmt/ladspa-cmt-1.15.ebuild,v 1.19 2005/08/06 22:25:29 kito Exp $
inherit eutils
@@ -31,7 +31,12 @@ src_unpack() {
|| die "sed makefile failed"
cd "${S}"
- use ppc-macos && epatch ${FILESDIR}/${PN}-darwin.patch
+ if use userland_Darwin ; then
+ epatch ${FILESDIR}/${PN}-darwin.patch
+ # gcc-4 bails
+ sed -i -e 's|-Werror||g' makefile \
+ || die "sed makefile failed"
+ fi
}
src_compile() {
@@ -44,4 +49,4 @@ src_install() {
doins ../plugins/*.so || die "doins failed"
dodoc ../README || die "dodoc failed"
dohtml ../doc/* || die "dohtml failed"
-} \ No newline at end of file
+}