summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-14 11:00:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-14 11:00:43 +0000
commitada1d3f20d9db0c7de5aa82ea498e4c05d5c01df (patch)
tree2d9e4a718bd2212d264fe6ae3d55e2258a29650d /media-libs/jpeg
parentVersion bump (thanks euscan), drop old. (diff)
downloadgentoo-2-ada1d3f20d9db0c7de5aa82ea498e4c05d5c01df.tar.gz
gentoo-2-ada1d3f20d9db0c7de5aa82ea498e4c05d5c01df.tar.bz2
gentoo-2-ada1d3f20d9db0c7de5aa82ea498e4c05d5c01df.zip
Version bump wrt #452008 by Lars Wendler. With empty KEYWORDS while waiting for libjpeg-turbo to catch up.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'media-libs/jpeg')
-rw-r--r--media-libs/jpeg/ChangeLog10
-rw-r--r--media-libs/jpeg/jpeg-9.ebuild66
2 files changed, 74 insertions, 2 deletions
diff --git a/media-libs/jpeg/ChangeLog b/media-libs/jpeg/ChangeLog
index 4829380351fc..249d005cd27b 100644
--- a/media-libs/jpeg/ChangeLog
+++ b/media-libs/jpeg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/jpeg
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.136 2012/12/16 16:12:57 ulm Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/ChangeLog,v 1.137 2013/01/14 11:00:43 ssuominen Exp $
+
+*jpeg-9 (14 Jan 2013)
+
+ 14 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +jpeg-9.ebuild:
+ Version bump wrt #452008 by Lars Wendler. With empty KEYWORDS while waiting
+ for libjpeg-turbo to catch up.
16 Dec 2012; Ulrich Müller <ulm@gentoo.org> jpeg-6b-r9.ebuild,
jpeg-8d.ebuild:
diff --git a/media-libs/jpeg/jpeg-9.ebuild b/media-libs/jpeg/jpeg-9.ebuild
new file mode 100644
index 000000000000..fcbf145ccd70
--- /dev/null
+++ b/media-libs/jpeg/jpeg-9.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/jpeg/jpeg-9.ebuild,v 1.1 2013/01/14 11:00:43 ssuominen Exp $
+
+EAPI=5
+inherit eutils libtool toolchain-funcs
+
+DESCRIPTION="Library to load, handle and manipulate images in the JPEG format"
+HOMEPAGE="http://jpegclub.org/ http://www.ijg.org/"
+SRC_URI="http://www.ijg.org/files/${PN}src.v${PV}.tar.gz
+ mirror://debian/pool/main/libj/lib${PN}8/lib${PN}8_8d-1.debian.tar.gz"
+
+LICENSE="IJG"
+SLOT="0"
+# Waiting for libjpeg-turbo to gain .so.9 support!
+KEYWORDS=""
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+DOCS="change.log example.c README *.txt"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7-maxmem_sysconf.patch
+ elibtoolize
+}
+
+src_configure() {
+ # Fix building against this library on eg. Solaris and DragonFly BSD, see:
+ # http://mail-index.netbsd.org/pkgsrc-bugs/2010/01/18/msg035644.html
+ local ldverscript=
+ [[ ${CHOST} == *-solaris* ]] && ldverscript="--disable-ld-version-script"
+
+ econf \
+ $(use_enable static-libs static) \
+ --enable-maxmem=64 \
+ ${ldverscript}
+}
+
+src_compile() {
+ default
+
+ # Build exifautotran and jpegexiforient
+ cd ../debian/extra
+ emake CC="$(tc-getCC)" CFLAGS="${LDFLAGS} ${CFLAGS}"
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ # Install exifautotran and jpegexiforient
+ newdoc ../debian/changelog changelog.debian
+ cd ../debian/extra
+ emake \
+ DESTDIR="${D}" prefix="${EPREFIX}"/usr \
+ INSTALL="install -m755" INSTALLDIR="install -d -m755" \
+ install
+}
+
+pkg_postinst() {
+ ewarn "If you are switching from media-libs/libjpeg-turbo you might need to"
+ ewarn "rebuild reverse dependencies:"
+ ewarn
+ ewarn "# emerge gentoolkit"
+ ewarn "# revdep-rebuild --library libjpeg.so.8"
+}