summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-29 15:31:47 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-29 15:31:47 +0000
commit6463824f0ffe398ddd75cdcebf7a9275e4649dcb (patch)
tree537a88400b59cd627d2834209963315fe13489b5 /media-libs/gst-plugins-good
parentAdd 173.14.09 and missing x11-proto/xf86vidmodeproto dep. (diff)
downloadgentoo-2-6463824f0ffe398ddd75cdcebf7a9275e4649dcb.tar.gz
gentoo-2-6463824f0ffe398ddd75cdcebf7a9275e4649dcb.tar.bz2
gentoo-2-6463824f0ffe398ddd75cdcebf7a9275e4649dcb.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc3 x86_64)
Diffstat (limited to 'media-libs/gst-plugins-good')
-rw-r--r--media-libs/gst-plugins-good/ChangeLog8
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-0.10.8.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-good/ChangeLog b/media-libs/gst-plugins-good/ChangeLog
index 9b718e90154a..9e947780f6e1 100644
--- a/media-libs/gst-plugins-good/ChangeLog
+++ b/media-libs/gst-plugins-good/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-good
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.46 2008/02/21 10:19:41 zaheerm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.47 2008/06/29 15:31:47 drac Exp $
+
+*gst-plugins-good-0.10.8 (29 Jun 2008)
+
+ 29 Jun 2008; Samuli Suominen <drac@gentoo.org>
+ +gst-plugins-good-0.10.8.ebuild:
+ Version bump.
*gst-plugins-good-0.10.7 (21 Feb 2008)
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-0.10.8.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-0.10.8.ebuild
new file mode 100644
index 000000000000..c34ecf67e2f4
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-0.10.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-0.10.8.ebuild,v 1.1 2008/06/29 15:31:47 drac Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-good gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.18
+ >=media-libs/gstreamer-0.10.18
+ >=dev-libs/liboil-0.3.8"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.6"
+
+# overrides the eclass
+src_unpack() {
+ unpack ${A}
+ # Required for FreeBSD sane .so versioning
+ elibtoolize
+}
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-good_src_configure
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ echo
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ echo
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}