summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-09-28 20:15:35 +0000
committerPacho Ramos <pacho@gentoo.org>2013-09-28 20:15:35 +0000
commitec7837a01302432d23e4344c111e50edd28260e6 (patch)
tree9cc7503c115b3aa28625945bb538dd1f28f4c7d6 /media-libs/grilo
parentUse correct value for ${S} (bug #486282). (diff)
downloadgentoo-2-ec7837a01302432d23e4344c111e50edd28260e6.tar.gz
gentoo-2-ec7837a01302432d23e4344c111e50edd28260e6.tar.bz2
gentoo-2-ec7837a01302432d23e4344c111e50edd28260e6.zip
Version bump, drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-libs/grilo')
-rw-r--r--media-libs/grilo/ChangeLog8
-rw-r--r--media-libs/grilo/grilo-0.2.7.ebuild (renamed from media-libs/grilo/grilo-0.2.4.ebuild)59
2 files changed, 36 insertions, 31 deletions
diff --git a/media-libs/grilo/ChangeLog b/media-libs/grilo/ChangeLog
index 5fd1c8101af9..2ad97cc055e7 100644
--- a/media-libs/grilo/ChangeLog
+++ b/media-libs/grilo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/grilo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/ChangeLog,v 1.27 2013/08/02 22:29:55 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/ChangeLog,v 1.28 2013/09/28 20:15:35 pacho Exp $
+
+*grilo-0.2.7 (28 Sep 2013)
+
+ 28 Sep 2013; Pacho Ramos <pacho@gentoo.org> +grilo-0.2.7.ebuild,
+ -grilo-0.2.4.ebuild:
+ Version bump, drop old
02 Aug 2013; Gilles Dartiguelongue <eva@gentoo.org> grilo-0.2.6.ebuild,
-files/grilo-0.1.16-media-source-infinite-loop.patch:
diff --git a/media-libs/grilo/grilo-0.2.4.ebuild b/media-libs/grilo/grilo-0.2.7.ebuild
index 993b2e6b2f7a..5c911becd566 100644
--- a/media-libs/grilo/grilo-0.2.4.ebuild
+++ b/media-libs/grilo/grilo-0.2.7.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/grilo-0.2.4.ebuild,v 1.8 2013/02/02 22:47:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/grilo/grilo-0.2.7.ebuild,v 1.1 2013/09/28 20:15:35 pacho Exp $
EAPI="5"
GCONF_DEBUG="no" # --enable-debug only changes CFLAGS
GNOME2_LA_PUNT="yes"
-PYTHON_DEPEND="test? 2"
+PYTHON_COMPAT=( python2_{6,7} )
VALA_MIN_API_VERSION="0.12"
-VALA_MAX_API_VERSION="0.18" # explicitly specified in configure
+VALA_MAX_API_VERSION="0.20" # explicitly specified in configure
VALA_USE_DEPEND="vapigen"
-inherit gnome2 vala python
+inherit gnome2 python-any-r1 vala
DESCRIPTION="A framework for easy media discovery and browsing"
HOMEPAGE="https://live.gnome.org/Grilo"
@@ -18,60 +18,59 @@ HOMEPAGE="https://live.gnome.org/Grilo"
LICENSE="LGPL-2.1+"
SLOT="0.2/1" # subslot is libgrilo-0.2 soname suffix
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
IUSE="gtk examples +introspection +network test vala"
REQUIRED_USE="test? ( introspection )"
-RDEPEND=">=dev-libs/glib-2.29.10:2
+RDEPEND="
+ >=dev-libs/glib-2.29.10:2
dev-libs/libxml2:2
+ net-libs/liboauth
gtk? ( >=x11-libs/gtk+-3:3 )
introspection? ( >=dev-libs/gobject-introspection-0.9 )
- network? ( >=net-libs/libsoup-2.33.4:2.4 )"
+ network? ( >=net-libs/libsoup-2.41.3:2.4 )
+"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.10
+ >=dev-util/intltool-0.40
virtual/pkgconfig
vala? ( $(vala_depend) )
test? (
+ ${PYTHON_DEPS}
dev-python/pygobject:2
dev-python/pygobject:3
- media-plugins/grilo-plugins:0.2 )"
+ media-plugins/grilo-plugins:0.2 )
+"
# eautoreconf requires gnome-common
-# Tests fail horribly, but return 0
-RESTRICT="test"
+python_check_deps() {
+ has_version "dev-python/pygobject:2[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/pygobject:3[${PYTHON_USEDEP}]"
+}
pkg_setup() {
- if use test; then
- python_pkg_setup
- python_set_active_version 2
- fi
+ use test && python-any-r1_pkg_setup
}
src_prepare() {
- DOCS="AUTHORS NEWS README TODO"
- # --enable-debug only changes CFLAGS, useless for us
- G2CONF="${G2CONF}
- --disable-static
- --disable-debug
- $(use_enable gtk test-ui)
- $(use_enable introspection)
- $(use_enable network grl-net)
- $(use_enable test tests)
- $(use_enable vala)"
-
# Don't build examples
sed -e '/SUBDIRS/s/examples//' \
-i Makefile.am -i Makefile.in || die
- # Add missing file from tarball
- cp "${FILESDIR}"/${PN}-0.1.16-constants.py \
- tests/python/constants.py || die
-
use vala && vala_src_prepare
gnome2_src_prepare
}
-src_test() {
- emake check PYTHON=$(PYTHON -2)
+src_configure() {
+ # --enable-debug only changes CFLAGS, useless for us
+ gnome2_src_configure \
+ --disable-static \
+ --disable-debug \
+ $(use_enable gtk test-ui) \
+ $(use_enable introspection) \
+ $(use_enable network grl-net) \
+ $(use_enable test tests) \
+ $(use_enable vala)
}
src_install() {