summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-07-30 21:39:08 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-07-30 21:39:08 +0000
commitc4aff64d519f261feefcef7961c4d6b6dd064540 (patch)
treea527a075b8c09f201613806aab939c7e7c1cd280 /media-libs/freeglut
parentRemove old 022 revision. (diff)
downloadgentoo-2-c4aff64d519f261feefcef7961c4d6b6dd064540.tar.gz
gentoo-2-c4aff64d519f261feefcef7961c4d6b6dd064540.tar.bz2
gentoo-2-c4aff64d519f261feefcef7961c4d6b6dd064540.zip
Don't build demo that fails with newer mesa, bug #428382.
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/freeglut')
-rw-r--r--media-libs/freeglut/ChangeLog9
-rw-r--r--media-libs/freeglut/freeglut-2.8.0-r1.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/media-libs/freeglut/ChangeLog b/media-libs/freeglut/ChangeLog
index efe7b14545c6..c0e6c5bdf30d 100644
--- a/media-libs/freeglut/ChangeLog
+++ b/media-libs/freeglut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/freeglut
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/freeglut/ChangeLog,v 1.88 2012/05/10 18:28:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/freeglut/ChangeLog,v 1.89 2012/07/30 21:39:08 chithanh Exp $
+
+*freeglut-2.8.0-r1 (30 Jul 2012)
+
+ 30 Jul 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +freeglut-2.8.0-r1.ebuild:
+ Don't build demo that fails with newer mesa, bug #428382.
10 May 2012; Alexis Ballier <aballier@gentoo.org> freeglut-2.8.0.ebuild:
keyword ~amd64-fbsd
@@ -314,4 +320,3 @@
+freeglut-2.2.0.ebuild:
Initial import. Thanks to Tamer Fahmy <tamer@tammura.at> for the ebuild
submission. This closes bug 36783.
-
diff --git a/media-libs/freeglut/freeglut-2.8.0-r1.ebuild b/media-libs/freeglut/freeglut-2.8.0-r1.ebuild
new file mode 100644
index 000000000000..e500186c4669
--- /dev/null
+++ b/media-libs/freeglut/freeglut-2.8.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/freeglut/freeglut-2.8.0-r1.ebuild,v 1.1 2012/07/30 21:39:08 chithanh Exp $
+
+EAPI=4
+inherit eutils libtool
+
+DESCRIPTION="A completely OpenSourced alternative to the OpenGL Utility Toolkit (GLUT) library"
+HOMEPAGE="http://freeglut.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug static-libs"
+
+RDEPEND="virtual/glu
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/libXi-1.3
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_prepare() {
+ # Please read the comments in the patch before thinking about dropping it
+ # yet again...
+ epatch "${FILESDIR}"/${PN}-2.4.0-bsd-usb-joystick.patch
+
+ # smooth_opengl3 demo doesn't build with recent mesa, bug #428382
+ sed -i "s/smooth_opengl3 //" progs/demos/Makefile.* || die
+
+ # Needed for sane .so versionning on bsd, please don't drop
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --enable-replace-glut \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ dohtml -r doc
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}