summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-11-27 13:45:34 +0000
committerTim Harder <radhermit@gentoo.org>2014-11-27 13:45:34 +0000
commit4593851af099ec4bcf6adaff4e4b5a26ac6e32aa (patch)
tree5a42e9fc2873505b186bcb09586be7b61f23f166 /media-libs/flac
parentSupport python 3.4 (diff)
downloadgentoo-2-4593851af099ec4bcf6adaff4e4b5a26ac6e32aa.tar.gz
gentoo-2-4593851af099ec4bcf6adaff4e4b5a26ac6e32aa.tar.bz2
gentoo-2-4593851af099ec4bcf6adaff4e4b5a26ac6e32aa.zip
Version bump (bug #530848) and fix prefix support (bug #529566).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-libs/flac')
-rw-r--r--media-libs/flac/ChangeLog7
-rw-r--r--media-libs/flac/flac-1.3.1.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/media-libs/flac/ChangeLog b/media-libs/flac/ChangeLog
index fa774816375d..f668ade9432e 100644
--- a/media-libs/flac/ChangeLog
+++ b/media-libs/flac/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/flac
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/ChangeLog,v 1.179 2014/09/27 22:16:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/ChangeLog,v 1.180 2014/11/27 13:45:34 radhermit Exp $
+
+*flac-1.3.1 (27 Nov 2014)
+
+ 27 Nov 2014; Tim Harder <radhermit@gentoo.org> +flac-1.3.1.ebuild:
+ Version bump (bug #530848) and fix prefix support (bug #529566).
*flac-1.3.0-r1 (27 Sep 2014)
diff --git a/media-libs/flac/flac-1.3.1.ebuild b/media-libs/flac/flac-1.3.1.ebuild
new file mode 100644
index 000000000000..56d913a63593
--- /dev/null
+++ b/media-libs/flac/flac-1.3.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/flac/flac-1.3.1.ebuild,v 1.1 2014/11/27 13:45:34 radhermit Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+
+inherit autotools-multilib
+
+DESCRIPTION="free lossless audio encoder and decoder"
+HOMEPAGE="http://flac.sourceforge.net"
+SRC_URI="http://downloads.xiph.org/releases/${PN}/${P}.tar.xz"
+
+LICENSE="BSD FDL-1.2 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="3dnow altivec +cxx debug ogg sse static-libs"
+
+RDEPEND="ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-soundlibs-20130224-r1
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ abi_x86_32? ( dev-lang/nasm )
+ !elibc_uclibc? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.0-asneeded.patch
+ "${FILESDIR}"/${PN}-1.3.0-dontbuild-tests.patch
+ "${FILESDIR}"/${PN}-1.3.0-dontbuild-examples.patch
+ )
+
+ AT_M4DIR="m4" autotools-multilib_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable sse)
+ $(use_enable 3dnow)
+ $(use_enable altivec)
+ --disable-doxygen-docs
+ --disable-xmms-plugin
+ $(use_enable cxx cpplibs)
+ $(use_enable ogg)
+ --disable-examples
+ $([[ ${CHOST} == *-darwin* ]] && echo "--disable-asm-optimizations")
+ )
+ autotools-multilib_src_configure
+}
+
+src_test() {
+ if [[ ${UID} != 0 ]]; then
+ autotools-multilib_src_test -j1
+ else
+ ewarn "Tests will fail if ran as root, skipping."
+ fi
+}
+
+src_install() {
+ autotools-multilib_src_install \
+ docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}