summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-06 16:41:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-06 16:41:54 +0000
commitdcdb88016cef586fc072ba5d9595731a157454f5 (patch)
tree1361d06cb19493d040b964c6c8af95c9f0837408 /media-libs/dumb
parentppc stable #271241 (diff)
downloadgentoo-2-dcdb88016cef586fc072ba5d9595731a157454f5.tar.gz
gentoo-2-dcdb88016cef586fc072ba5d9595731a157454f5.tar.bz2
gentoo-2-dcdb88016cef586fc072ba5d9595731a157454f5.zip
Don't hardcode ecompress --suffix in postinst msg wrt #272915, thanks to Victor Ostorga.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/dumb')
-rw-r--r--media-libs/dumb/ChangeLog6
-rw-r--r--media-libs/dumb/dumb-0.9.3-r1.ebuild33
2 files changed, 21 insertions, 18 deletions
diff --git a/media-libs/dumb/ChangeLog b/media-libs/dumb/ChangeLog
index 419ebb9fac10..677d405e575a 100644
--- a/media-libs/dumb/ChangeLog
+++ b/media-libs/dumb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/dumb
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/dumb/ChangeLog,v 1.34 2009/05/08 16:30:59 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/dumb/ChangeLog,v 1.35 2009/06/06 16:41:54 ssuominen Exp $
+
+ 06 Jun 2009; Samuli Suominen <ssuominen@gentoo.org> dumb-0.9.3-r1.ebuild:
+ Don't hardcode ecompress --suffix in postinst msg wrt #272915, thanks to
+ Victor Ostorga.
08 May 2009; Samuli Suominen <ssuominen@gentoo.org>
files/dumb-0.9.2-PIC.patch:
diff --git a/media-libs/dumb/dumb-0.9.3-r1.ebuild b/media-libs/dumb/dumb-0.9.3-r1.ebuild
index 25e5f0a68c69..e2fe202987b8 100644
--- a/media-libs/dumb/dumb-0.9.3-r1.ebuild
+++ b/media-libs/dumb/dumb-0.9.3-r1.ebuild
@@ -1,24 +1,23 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/dumb/dumb-0.9.3-r1.ebuild,v 1.9 2007/04/30 22:57:35 genone Exp $
-
-IUSE="debug"
+# $Header: /var/cvsroot/gentoo-x86/media-libs/dumb/dumb-0.9.3-r1.ebuild,v 1.10 2009/06/06 16:41:54 ssuominen Exp $
+EAPI=2
inherit eutils
DESCRIPTION="IT/XM/S3M/MOD player library with click removal and IT filters"
HOMEPAGE="http://dumb.sourceforge.net/"
SRC_URI="mirror://sourceforge/dumb/${P}.tar.gz"
-KEYWORDS="alpha amd64 ia64 ppc sparc x86"
LICENSE="DUMB-0.9.2"
SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+IUSE="debug"
+RDEPEND=""
DEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
cat << EOF > make/config.txt
include make/unix.inc
ALL_TARGETS := core core-examples core-headers
@@ -28,7 +27,7 @@ EOF
epatch "${FILESDIR}"/${PN}-0.9.2-PIC.patch
epatch "${FILESDIR}"/${P}_CVE-2006-3668.patch
sed -i '/= -s/d' Makefile || die "sed failed"
- cp Makefile Makefile.rdy
+ cp -f Makefile Makefile.rdy
}
src_compile() {
@@ -36,19 +35,20 @@ src_compile() {
}
src_install() {
- dobin examples/{dumbout,dumb2wav}
- dolib.so lib/unix/libdumb.so
+ dobin examples/{dumbout,dumb2wav} || die "dobin failed"
+ dolib.so lib/unix/libdumb.so || die "dolib.so failed"
- use debug && dolib.so lib/unix/libdumbd.so
+ if use debug; then
+ dolib.so lib/unix/libdumbd.so || die "dolib.so failed"
+ fi
insinto /usr/include
- doins include/dumb.h
+ doins include/dumb.h || die "doins failed"
- dodoc readme.txt release.txt docs/* || die "dodoc failed"
+ dodoc readme.txt release.txt docs/*
}
pkg_postinst() {
- elog
elog "DUMB's core has been installed. This will enable you to convert module"
elog "files to PCM data (ready for sending to /dev/dsp, writing to a .wav"
elog "file, piping through oggenc, etc.)."
@@ -61,7 +61,6 @@ pkg_postinst() {
elog "As a developer, when you distribute your game and write your docs, be"
elog "aware that 'dumb' and 'aldumb' actually come from the same download."
elog "People who don't use Gentoo will only have to download and install one"
- elog "package. See /usr/share/doc/${PF}/readme.txt.gz for details on"
+ elog "package. See readme.txt in /usr/share/doc/${PF} for details on"
elog "how DUMB would be compiled manually."
- elog
}