summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-02-06 22:57:36 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-02-06 22:57:36 +0000
commit1456e66ea966daf2f785a5c99c32e3166a0a25a0 (patch)
tree7c2a8501c5a81c5c5897c1f9f3b75d7651e9d97b /media-libs/clutter
parentVersion bump. (diff)
downloadgentoo-2-1456e66ea966daf2f785a5c99c32e3166a0a25a0.tar.gz
gentoo-2-1456e66ea966daf2f785a5c99c32e3166a0a25a0.tar.bz2
gentoo-2-1456e66ea966daf2f785a5c99c32e3166a0a25a0.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-libs/clutter')
-rw-r--r--media-libs/clutter/ChangeLog9
-rw-r--r--media-libs/clutter/clutter-1.16.4.ebuild109
2 files changed, 116 insertions, 2 deletions
diff --git a/media-libs/clutter/ChangeLog b/media-libs/clutter/ChangeLog
index af046fce2e2f..910805d4893f 100644
--- a/media-libs/clutter/ChangeLog
+++ b/media-libs/clutter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/clutter
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.77 2013/12/24 17:22:19 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.78 2014/02/06 22:57:36 eva Exp $
+
+*clutter-1.16.4 (06 Feb 2014)
+
+ 06 Feb 2014; Gilles Dartiguelongue <eva@gentoo.org> +clutter-1.16.4.ebuild:
+ Version bump.
*clutter-1.16.2 (24 Dec 2013)
diff --git a/media-libs/clutter/clutter-1.16.4.ebuild b/media-libs/clutter/clutter-1.16.4.ebuild
new file mode 100644
index 000000000000..178f45611e55
--- /dev/null
+++ b/media-libs/clutter/clutter-1.16.4.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/clutter-1.16.4.ebuild,v 1.1 2014/02/06 22:57:36 eva Exp $
+
+EAPI="5"
+CLUTTER_LA_PUNT="yes"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+# since clutter-project.org doesn't provide .xz tarballs
+inherit clutter gnome2 virtualx
+
+DESCRIPTION="Clutter is a library for creating graphical user interfaces"
+
+LICENSE="LGPL-2.1+ FDL-1.1+"
+SLOT="1.0"
+IUSE="debug doc gtk +introspection test" # evdev tslib
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+# NOTE: glx flavour uses libdrm + >=mesa-7.3
+# XXX: uprof needed for profiling
+# >=libX11-1.3.1 needed for X Generic Event support
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=dev-libs/atk-2.5.3[introspection?]
+ >=dev-libs/json-glib-0.12[introspection?]
+ >=media-libs/cogl-1.15.9:1.0=[introspection?,pango]
+ media-libs/fontconfig
+ >=x11-libs/cairo-1.10:=[glib]
+ >=x11-libs/pango-1.30[introspection?]
+
+ virtual/opengl
+ x11-libs/libdrm:=
+ >=x11-libs/libX11-1.3.1
+ x11-libs/libXext
+ x11-libs/libXdamage
+ x11-proto/inputproto
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXcomposite-0.4
+
+ gtk? ( >=x11-libs/gtk+-3.3.18:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.15
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+ doc? (
+ >=dev-util/gtk-doc-1.15
+ >=app-text/docbook-sgml-utils-0.6.14[jadetex]
+ dev-libs/libxslt )
+ test? ( x11-libs/gdk-pixbuf )"
+
+# Tests fail with both swrast and llvmpipe
+# They pass under r600g or i965, so the bug is in mesa
+RESTRICT="test"
+
+src_prepare() {
+ # We only need conformance tests, the rest are useless for us
+ sed -e 's/^\(SUBDIRS =\).*/\1 accessibility data conform/g' \
+ -i tests/Makefile.am || die "am tests sed failed"
+ sed -e 's/^\(SUBDIRS =\)[^\]*/\1 accessibility data conform/g' \
+ -i tests/Makefile.in || die "in tests sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="README NEWS ChangeLog*"
+
+ # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
+ # (GLX error blabla)
+ # XXX: Profiling, coverage disabled for now
+ # XXX: What about cex100/egl/osx/wayland/win32 backends?
+ # XXX: evdev/tslib input seem to be experimental?
+ gnome2_src_configure \
+ --enable-xinput \
+ --enable-x11-backend=yes \
+ --disable-profile \
+ --disable-maintainer-flags \
+ --disable-gcov \
+ --disable-cex100-backend \
+ --disable-egl-backend \
+ --disable-quartz-backend \
+ --disable-wayland-backend \
+ --disable-win32-backend \
+ --disable-tslib-input \
+ --disable-evdev-input \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ $(use_enable doc docs) \
+ $(use_enable gtk gdk-backend) \
+ $(use_enable introspection) \
+ $(use_enable test conformance) \
+ $(use_enable test gdk-pixbuf)
+}
+
+src_compile() {
+ default
+ if use test; then
+ emake -C tests/conform
+ fi
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ clutter_src_install
+}