summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-02-27 22:24:32 +0000
committerMichał Górny <mgorny@gentoo.org>2015-02-27 22:24:32 +0000
commita8467f8f54a3d77bf1737a4df64fc56f19fd7d3d (patch)
tree1ad3342a5e9ebcc1e46c7b35aeead96eddadd772 /media-libs/chromaprint
parentAdd patch to fix crasher bug triggered on hardened x86_64 machines with USE=X... (diff)
downloadgentoo-2-a8467f8f54a3d77bf1737a4df64fc56f19fd7d3d.tar.gz
gentoo-2-a8467f8f54a3d77bf1737a4df64fc56f19fd7d3d.tar.bz2
gentoo-2-a8467f8f54a3d77bf1737a4df64fc56f19fd7d3d.zip
Use USE=libav to control ffmpeg/libav linking. Patch provided by Nikoli in https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/62.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-libs/chromaprint')
-rw-r--r--media-libs/chromaprint/ChangeLog8
-rw-r--r--media-libs/chromaprint/chromaprint-1.2.ebuild13
2 files changed, 14 insertions, 7 deletions
diff --git a/media-libs/chromaprint/ChangeLog b/media-libs/chromaprint/ChangeLog
index c7674f25d000..91597ef27c4a 100644
--- a/media-libs/chromaprint/ChangeLog
+++ b/media-libs/chromaprint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/chromaprint
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/ChangeLog,v 1.19 2014/11/20 17:07:44 klausman Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/ChangeLog,v 1.20 2015/02/27 22:24:32 mgorny Exp $
+
+ 27 Feb 2015; Michał Górny <mgorny@gentoo.org> chromaprint-1.2.ebuild:
+ Use USE=libav to control ffmpeg/libav linking. Patch provided by Nikoli in
+ https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/62.
20 Nov 2014; Tobias Klausmann <klausman@gentoo.org> chromaprint-1.2.ebuild:
Keyworded on alpha, bug 489436
diff --git a/media-libs/chromaprint/chromaprint-1.2.ebuild b/media-libs/chromaprint/chromaprint-1.2.ebuild
index 67a57927c062..32b122414eab 100644
--- a/media-libs/chromaprint/chromaprint-1.2.ebuild
+++ b/media-libs/chromaprint/chromaprint-1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/chromaprint-1.2.ebuild,v 1.2 2014/11/20 17:07:44 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/chromaprint/chromaprint-1.2.ebuild,v 1.3 2015/02/27 22:24:32 mgorny Exp $
EAPI=5
inherit cmake-utils
@@ -12,10 +12,13 @@ SRC_URI="https://bitbucket.org/acoustid/${PN}/downloads/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-fbsd"
-IUSE="test tools"
+IUSE="libav test tools"
-# note: use ffmpeg instead of fftw because it's recommended and required for tools
-RDEPEND=">=virtual/ffmpeg-0.10"
+# note: use ffmpeg or libav instead of fftw because it's recommended and required for tools
+RDEPEND="
+ libav? ( media-video/libav:0= )
+ !libav? ( media-video/ffmpeg:0= )
+"
DEPEND="${RDEPEND}
test? (
dev-cpp/gtest