summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-19 13:41:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-19 13:41:42 +0000
commit91ac995b73dab3d37f6e3ea9541bf977c179451c (patch)
tree18e2006c0604f55ec18be09bc856669e03b18dd3 /media-libs/babl
parentVersion bump (diff)
downloadgentoo-2-91ac995b73dab3d37f6e3ea9541bf977c179451c.tar.gz
gentoo-2-91ac995b73dab3d37f6e3ea9541bf977c179451c.tar.bz2
gentoo-2-91ac995b73dab3d37f6e3ea9541bf977c179451c.zip
Bump for #305623
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/babl')
-rw-r--r--media-libs/babl/ChangeLog9
-rw-r--r--media-libs/babl/babl-0.1.2.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/media-libs/babl/ChangeLog b/media-libs/babl/ChangeLog
index 458563de1000..2f2569fba532 100644
--- a/media-libs/babl/ChangeLog
+++ b/media-libs/babl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/babl
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.16 2009/12/20 14:26:10 ranger Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/ChangeLog,v 1.17 2010/02/19 13:41:42 patrick Exp $
+
+*babl-0.1.2 (19 Feb 2010)
+
+ 19 Feb 2010; Patrick Lauer <patrick@gentoo.org> +babl-0.1.2.ebuild:
+ Bump for #305623
20 Dec 2009; Brent Baude <ranger@gentoo.org> babl-0.0.22.ebuild:
Marking babl-0.0.22 ppc64 for bug 293127
diff --git a/media-libs/babl/babl-0.1.2.ebuild b/media-libs/babl/babl-0.1.2.ebuild
new file mode 100644
index 000000000000..b62d1e914abe
--- /dev/null
+++ b/media-libs/babl/babl-0.1.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-0.1.2.ebuild,v 1.1 2010/02/19 13:41:42 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+SRC_URI="ftp://ftp.gtk.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="sse mmx"
+
+src_configure() {
+ econf \
+ $(use_enable mmx) \
+ $(use_enable sse)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+ dodoc AUTHORS ChangeLog README NEWS || die "dodoc failed"
+}