summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-29 20:09:35 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-29 20:09:35 +0000
commit4364d2729979bf66cbf8ee25e5ec494f189a8583 (patch)
tree50264ae584497054535f72a22eccc790fae5a584 /media-libs/aubio
parentVersion bump (diff)
downloadgentoo-2-4364d2729979bf66cbf8ee25e5ec494f189a8583.tar.gz
gentoo-2-4364d2729979bf66cbf8ee25e5ec494f189a8583.tar.bz2
gentoo-2-4364d2729979bf66cbf8ee25e5ec494f189a8583.zip
USE="static-libs" and remove libtool files
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/aubio')
-rw-r--r--media-libs/aubio/ChangeLog7
-rw-r--r--media-libs/aubio/aubio-0.3.2-r1.ebuild43
2 files changed, 32 insertions, 18 deletions
diff --git a/media-libs/aubio/ChangeLog b/media-libs/aubio/ChangeLog
index 2537aa2f90e3..2c878ed91e94 100644
--- a/media-libs/aubio/ChangeLog
+++ b/media-libs/aubio/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-libs/aubio
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/aubio/ChangeLog,v 1.15 2010/12/02 18:41:32 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/aubio/ChangeLog,v 1.16 2011/09/29 20:09:35 ssuominen Exp $
+
+ 29 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> aubio-0.3.2-r1.ebuild:
+ USE="static-libs" and remove libtool files
02 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> aubio-0.3.2-r1.ebuild:
Rebuild the full autotools, so that we don't rely on old automake-1.8.
diff --git a/media-libs/aubio/aubio-0.3.2-r1.ebuild b/media-libs/aubio/aubio-0.3.2-r1.ebuild
index e87127a958f7..cc748df6c25e 100644
--- a/media-libs/aubio/aubio-0.3.2-r1.ebuild
+++ b/media-libs/aubio/aubio-0.3.2-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/aubio/aubio-0.3.2-r1.ebuild,v 1.9 2010/12/02 18:41:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/aubio/aubio-0.3.2-r1.ebuild,v 1.10 2011/09/29 20:09:35 ssuominen Exp $
-inherit eutils autotools
+EAPI=4
-IUSE="alsa doc jack lash"
+inherit eutils autotools
DESCRIPTION="Library for audio labelling"
HOMEPAGE="http://aubio.piem.org"
@@ -13,8 +13,9 @@ SRC_URI="http://aubio.piem.org/pub/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ppc64 sparc x86"
+IUSE="alsa doc jack lash static-libs"
-RDEPEND="=sci-libs/fftw-3*
+RDEPEND="sci-libs/fftw:3.0
media-libs/libsndfile
media-libs/libsamplerate
dev-lang/python
@@ -26,28 +27,36 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
doc? ( app-doc/doxygen virtual/latex-base )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
epatch "${FILESDIR}"/aubio-0.3.2-multilib.patch
eautoreconf
}
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable jack) \
+ $(use_enable alsa) \
+ $(use_enable lash)
+}
+
src_compile() {
- econf $(use_enable jack) $(use_enable alsa) $(use_enable lash)
- emake || die "emake failed."
+ default
+
if use doc; then
export VARTEXFONTS="${T}/fonts"
- cd "${S}/doc"
- doxygen user.cfg || die "creating user doc failed"
- doxygen devel.cfg || die "creating devel doc failed"
- doxygen examples.cfg || die "creating examples doc failed"
+ cd "${S}"/doc
+ doxygen user.cfg
+ doxygen devel.cfg
+ doxygen examples.cfg
fi
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog README TODO
+ default
+
doman doc/*.1
if use doc; then
mv doc/user/html doc/user/user
@@ -57,4 +66,6 @@ src_install() {
mv doc/examples/html doc/examples/examples
dohtml -r doc/examples/examples
fi
+
+ find "${ED}"usr -name '*.la' -exec rm -f {} +
}