summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-20 19:46:51 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-20 19:46:51 +0000
commit6cfcb6d591614485044d1cd6747efbf9f1538ef3 (patch)
treee0e7d52be68fa8a77cac085a008a28892af0f478 /media-libs/akode
parentFirst commit (diff)
downloadgentoo-2-6cfcb6d591614485044d1cd6747efbf9f1538ef3.tar.gz
gentoo-2-6cfcb6d591614485044d1cd6747efbf9f1538ef3.tar.bz2
gentoo-2-6cfcb6d591614485044d1cd6747efbf9f1538ef3.zip
Added a patch for gcc 4.3 compatibility as kindly provided by Steve Warren on bug 218300.
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'media-libs/akode')
-rw-r--r--media-libs/akode/ChangeLog7
-rw-r--r--media-libs/akode/akode-2.0.2.ebuild7
-rw-r--r--media-libs/akode/files/akode-2.0.2-gcc43.patch45
3 files changed, 56 insertions, 3 deletions
diff --git a/media-libs/akode/ChangeLog b/media-libs/akode/ChangeLog
index eb38f5e9622a..dc474fb85063 100644
--- a/media-libs/akode/ChangeLog
+++ b/media-libs/akode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/akode
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/akode/ChangeLog,v 1.35 2008/01/10 17:04:04 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/akode/ChangeLog,v 1.36 2008/04/20 19:46:51 philantrop Exp $
+
+ 20 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/akode-2.0.2-gcc43.patch, akode-2.0.2.ebuild:
+ Added a patch for gcc 4.3 compatibility as kindly provided by Steve Warren
+ on bug 218300.
10 Jan 2008; Samuli Suominen <drac@gentoo.org> -akode-2.0_beta3.ebuild,
akode-2.0_rc1.ebuild, -akode-2.0.1.ebuild:
diff --git a/media-libs/akode/akode-2.0.2.ebuild b/media-libs/akode/akode-2.0.2.ebuild
index 81a30d1775d2..fe20014dd621 100644
--- a/media-libs/akode/akode-2.0.2.ebuild
+++ b/media-libs/akode/akode-2.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/akode/akode-2.0.2.ebuild,v 1.2 2007/07/14 18:08:18 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/akode/akode-2.0.2.ebuild,v 1.3 2008/04/20 19:46:51 philantrop Exp $
WANT_AUTOMAKE="1.9"
WANT_AUTOCONF="2.5"
@@ -33,6 +33,9 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-amd64-flac-1.1.3.patch
+ # gcc 4.3 compatibility fix. cf. bug 218300.
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+
sed -i -e '/case $AUTO\(CONF\|HEADER\)_VERSION in/,+1 s/2\.5/2.[56]/g' \
admin/cvs.sh
diff --git a/media-libs/akode/files/akode-2.0.2-gcc43.patch b/media-libs/akode/files/akode-2.0.2-gcc43.patch
new file mode 100644
index 000000000000..266807c5368d
--- /dev/null
+++ b/media-libs/akode/files/akode-2.0.2-gcc43.patch
@@ -0,0 +1,45 @@
+
+diff -up akode-2.0.2/akode/lib/auto_sink.cpp.gcc43~ akode-2.0.2/akode/lib/auto_sink.cpp
+--- akode-2.0.2/akode/lib/auto_sink.cpp.gcc43~ 2008-01-13 08:54:32.000000000 +0000
++++ akode-2.0.2/akode/lib/auto_sink.cpp 2008-01-13 08:54:32.000000000 +0000
+@@ -18,6 +18,7 @@
+ Boston, MA 02110-1301, USA.
+ */
+
++#include <stdlib.h>
+ #include "audioframe.h"
+ #include "auto_sink.h"
+
+diff -up akode-2.0.2/akode/lib/player.cpp.gcc43~ akode-2.0.2/akode/lib/player.cpp
+--- akode-2.0.2/akode/lib/player.cpp.gcc43~ 2008-01-13 08:54:35.000000000 +0000
++++ akode-2.0.2/akode/lib/player.cpp 2008-01-13 08:54:35.000000000 +0000
+@@ -18,6 +18,7 @@
+ Boston, MA 02110-1301, USA.
+ */
+
++#include <string.h>
+ #include <pthread.h>
+ #include <semaphore.h>
+ #include <assert.h>
+diff -up akode-2.0.2/akode/lib/magic.cpp.gcc43~ akode-2.0.2/akode/lib/magic.cpp
+--- akode-2.0.2/akode/lib/magic.cpp.gcc43~ 2008-01-13 08:54:36.000000000 +0000
++++ akode-2.0.2/akode/lib/magic.cpp 2008-01-13 08:54:36.000000000 +0000
+@@ -18,6 +18,7 @@
+ Boston, MA 02110-1301, USA.
+ */
+
++#include <string.h>
+ #include "akodelib.h"
+ #include "magic.h"
+ #include "file.h"
+diff -up akode-2.0.2/akode/akodeplay/akodeplay.cpp.gcc43~ akode-2.0.2/akode/akodeplay/akodeplay.cpp
+--- akode-2.0.2/akode/akodeplay/akodeplay.cpp.gcc43~ 2008-01-13 08:54:53.000000000 +0000
++++ akode-2.0.2/akode/akodeplay/akodeplay.cpp 2008-01-13 08:54:53.000000000 +0000
+@@ -18,6 +18,7 @@
+ Boston, MA 02110-1301, USA.
+ */
+
++#include <stdlib.h>
+ #include <iostream>
+
+ #include "../lib/akodelib.h"